Jump to content
Калькуляторы

cisco1002 ipoe периодически пропадает линк

Коллеги, ситуация началась примерно пару дней назад и пока не могу отловить кто виноват.

 

Суть следующая, абонент цепляется по IPOE, все у него работает, но периодически пропадает связь. линк не рвется. просто не идут никакие пакеты, ни пинги, ничего. зависание.

само так же оживает и опять работает.

 

вот со стороны cisco попытался пингануть абонента, кое как поймал такую ситуацию. начало - был затык, далее все ок. С его стороны аналогичная ситуация. Жалобы получи от десятка абонентов.

всего пока около 100 одновременных сессий, только начали подключать.

железо абонов подключается через длинки DES-3200-52

 

ISG_BRAS_1#ping vrf INET ip 46.*.*.* repeat 1000

Type escape sequence to abort.

Sending 1000, 100-byte ICMP Echos to 46.*.*.*, timeout is 2 seconds:

...........!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!

 

ISG_BRAS_1#sh ver

Cisco IOS XE Software, Version 03.11.00.S - Standard Support Release

Cisco IOS Software, ASR1000 Software (PPC_LINUX_IOSD-ADVENTERPRISE-M), Version 15.4(1)S, RELEASE SOFTWARE (fc2)

ISG_BRAS_1 uptime is 8 weeks, 5 days, 21 hours, 44 minutes

Uptime for this control processor is 8 weeks, 5 days, 21 hours, 48 minutes

 

только-только запущено!

Share this post


Link to post
Share on other sites

проверьте по пути все мак таблицы.

либо записи пропадают, либо срок хранения маленький. у меня бывало такое, только с дсламами.

это первое, что приходит в голову.

Edited by elyor

Share this post


Link to post
Share on other sites

настройка порта:

interface TenGigabitEthernet0/1/0.700

description Abonents Vlan700

encapsulation dot1Q 700

ip vrf forwarding INET

ip dhcp relay information trusted

ip dhcp relay information policy-action keep

ip unnumbered Loopback700

arp timeout 60

service-policy type control DHCP-Subscriber

ip subscriber l2-connected

initiator dhcp class-aware

 

 

ISG_BRAS_1#sh int TenGigabitEthernet0/1/0.700

TenGigabitEthernet0/1/0.700 is up, line protocol is up

Hardware is SPA-1X10GE-L-V2, address is acf2.c5a6.3e10 (bia acf2.c5a6.3e10)

Description: Abonents Vlan700

Interface is unnumbered. Using address of Loopback700 (46.*.*.*)

MTU 1500 bytes, BW 10000000 Kbit/sec, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation 802.1Q Virtual LAN, Vlan ID 700.

ARP type: ARPA, ARP Timeout 00:01:00

Keepalive not supported

Last clearing of "show interface" counters never

 

после изменения времени надо ли сессию у абона дропать?

выставил 1 час через минуту словил очередной затык

ISG_BRAS_1#ping vrf INET ip 46.*.*.* repeat 1000

Type escape sequence to abort.

Sending 1000, 100-byte ICMP Echos to 46.*.*.*, timeout is 2 seconds:

...........!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!

Success rate is 98 percent (989/1000), round-trip min/avg/max = 1/1/12 ms

Share this post


Link to post
Share on other sites

elyor

Глупости. Даже если вы отключите весь mac-learning на коммутаторах, это не приведёт к отсутствию связи. К флуду чудовищному приведёт, но пакеты долетать до абонента будут.

 

delphivcl

Я бы посмотрел в сторону ARP-записей в момент проблемы. Очень похоже, что она истекает, и не обновляется корректно.

Share this post


Link to post
Share on other sites

К моему сожалению, для меня все ново и постигаю самоучкой. Поэтому даже на вопрос зачем ответить не могу. по дефолту на интерфейсе насколько я помню 4 часа.

эту строчку подкинули при написании конфига, и сути я особо ее не понимаю при ипое. возможно вообще не нужна она. буду благодарен за любые подсказки.

Share this post


Link to post
Share on other sites

Ну дак уберите попробуйте. Это вообще не хорошая привычка таймауты крутить на пустом месте.

Share this post


Link to post
Share on other sites

убрал я этот арп таймаут совсем. пока не помогло. так и затыкается.

Share this post


Link to post
Share on other sites

elyor

Глупости. Даже если вы отключите весь mac-learning на коммутаторах, это не приведёт к отсутствию связи. К флуду чудовищному приведёт, но пакеты долетать до абонента будут.

 

delphivcl

Я бы посмотрел в сторону ARP-записей в момент проблемы. Очень похоже, что она истекает, и не обновляется корректно.

я же написал, что у меня такое было с дсламами. я не утверждал, что это факт, что именно из-за этого проблема. я просто подкинул идею, куда копать.

Share this post


Link to post
Share on other sites

что удалось выяснить:

 

подвисает примерно на 20 сек. периодичность раз в ~1 минуту.

Share this post


Link to post
Share on other sites

Вы совсем траблшутить не умеете.

Подключите тестовый бук/комп как клиента, проверяйте.

Прокиньте до клиента статикой интерфейс и проверяйте.

А то у вас проблема "где-то" и вы ее даже локализовать не хотите.

Share this post


Link to post
Share on other sites

я же написал, что у меня такое было с дсламами. я не утверждал, что это факт, что именно из-за этого проблема. я просто подкинул идею, куда копать.

Да, и я назвал эту идею глупой, потому что она глупая. Вы увидели огонь, решили что это боги вам его послали, и теперь всем кто тоже видит огонь советуете копать в сторону богов. А то, что это молния дерево подожгла вы выяснить не осилили. И при чём тут ваши дсламы если у ТС сеть ethernet судя по описанию?

Никогда не перепрыгивайте от базовой диагностики сразу к решению.

 

delphivcl

Ну посмотрите вы уже ARP-записи то для клиента в момент возникновения проблемы. Хотя бы одну версию сможете локализовать/отбросить.

Share this post


Link to post
Share on other sites

коллеги, спасибо всем.

да сетка изернет на IPOE

 

с арпами и всем прочим все ок. причину нашли.

косяки на свитче DES3200-52. даже не на абонентских портах. снимаем его для изучения. сейчас все работает.

с длинкам не дружу совсем и что там не так пока прокомментировать не могу.

Share this post


Link to post
Share on other sites

Очень странно. На коллизии маков не похоже, не используете мак-ип-порт биндинги?

Share this post


Link to post
Share on other sites

при посещении это свитча выяснили следующее, в порт воткнут кабель с другого конца обрезан и голые жилы скручены замкнуты.

стормы включены, но не ловят они эту шнягу. со слов техника там порт поднимается и падает.

бинды не используем.

Share this post


Link to post
Share on other sites

на тестовом длинке протестили такую затычку - косяк повторяется.

Share this post


Link to post
Share on other sites

спасибо, проверю. но насколько я помню - технари клялись что такое включено.

 

проверил настройки. в длинке это было включено!

Loopback Detection Global Settings

Loopback Detection State Enabled

 

и так же на всех абон портах.

Edited by delphivcl

Share this post


Link to post
Share on other sites

Оно обнаруживает петлю не по одному кадру, сколько-то успевает пролететь.

А дальше ваше "раз в минуту" это скорее всего таймаут восстановления loopdetection. Можете таймаут поболее поставить.

Я так понимаю у вас не отдельный влан на каждого пользователя?

Share this post


Link to post
Share on other sites

Все верно, не отдельный. пока в тестовой эксплуатации 9 длинков. один влан на всех.

на счет таймаута спасибо, значение аккурат совпадает. Отпишу технарям чтоб курили.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this