Jump to content
Калькуляторы

REDBack SE-100 LACP access economical не работает load-balancing access economical

Здравствуйте господа. По ходу работы с SE-100 столкнулся с непонятной проблемой - при агрегации линков LACP в режиме ACCESS ECONOMICAL клипсы липнут только на один физический интерфейс. Используем авторизацию на основе Q-in-Q, каждая связка vlan:vlan - уникальный идентификатор пользователя. Что бы было более понятно приведу часть конфига с SE-100

context local
!
interface ospf1
 ip address xx.xx.xx.xx/xx
!
interface subscribers multibind
 ip address xx.xx.xx.xx/xx
 dhcp server interface
 ip arp proxy-arp
!
interface ospf2
 ip address xx.xx.xx.xx/xx
  ip source-address radius 
logging console
!
router ospf 1
 fast-convergence
 router-id xx.xx.xx.xx
 originate-default always
 area xx.xx.xx.xx
  default-route
  interface ospf1
   neighbor xx.xx.xx.xx cost 21
  interface ospf2
   neighbor xx.xx.xx.xx cost 10
 redistribute connected 
 redistribute static
!
subscriber default
  ip access-group subscriber_accept in
  http-redirect profile http-garden
  dhcp max-addrs 1
  dns primary xx.xx.xx.xx
  dns secondary xx.xx.xx.xx
!
dhcp server policy
  subnet xx.xx.xx.xx/xx
    range xx.xx.xx.xx xx.xx.xx.xx
    option router xx.xx.xx.xx
    default-lease-time 180
!
link-group access-lag access economical
encapsulation dot1q
mac-address auto 
dot1q pvc 1102 encapsulation 1qtunnel 
 dot1q pvc on-demand 1102:101 through 999 
 service clips dhcp source-mac maximum 1 context local
dot1q pvc 1103 encapsulation 1qtunnel 
 dot1q pvc on-demand 1103:10 through 999 
 service clips dhcp source-mac maximum 1 context local
dot1q pvc 1104 encapsulation 1qtunnel 
 dot1q pvc on-demand 1104:10 through 999 
 service clips dhcp source-mac maximum 1 context local
dot1q pvc 1105 encapsulation 1qtunnel 
 dot1q pvc on-demand 1105:10 through 999 
 service clips dhcp source-mac maximum 1 context local
dot1q pvc 1106 encapsulation 1qtunnel 
 dot1q pvc on-demand 1106:10 through 999 
 service clips dhcp source-mac maximum 1 context local
dot1q pvc 1107 encapsulation 1qtunnel 
 dot1q pvc on-demand 1107:10 through 999 
 service clips dhcp source-mac maximum 1 context local
dot1q pvc 1108 encapsulation 1qtunnel 
 dot1q pvc on-demand 1108:10 through 999 
 service clips dhcp source-mac maximum 1 context local
dot1q pvc 1109 encapsulation 1qtunnel 
 dot1q pvc on-demand 1109:10 through 999 
 service clips dhcp source-mac maximum 1 context local
dot1q pvc 1110 encapsulation 1qtunnel 
 dot1q pvc on-demand 1110:10 through 999 
 service clips dhcp source-mac maximum 1 context local
maximum-links 3
minimum-links 3
lacp active
lacp periodic-timeout long
!
!!! end of context
!
link-group tocore dot1q
dot1q pvc 57
 bind interface ospf2 local
dot1q pvc 58
 bind interface ospf1 local
lacp active
lacp periodic-timeout long
!
port ethernet 2/1 
no shutdown
encapsulation dot1q
link-group access-lag
lacp priority 1
!
port ethernet 2/2 
no shutdown
encapsulation dot1q
link-group tocore
!
port ethernet 2/3 
no shutdown
encapsulation dot1q
link-group access-lag
!
port ethernet 2/4 
no shutdown
encapsulation dot1q
link-group tocore
!
port ethernet 2/15 
no shutdown
encapsulation dot1q
link-group access-lag
!
port ethernet 2/16 
no shutdown
encapsulation dot1q
link-group tocore

 

Но при этом агрегация интерфейсов смотрящих на OSPF работает прекрасно. Вот тут детали для наглядности

 

Это детали access-lag

 


#show link-group access-lag detail

Link-Group: access-lag, ID   : 27, State : Up   
------------------------------------------------------------------------------
Ccct count      : 3                              Grouping        : LoadShare      
Card Type       : carrier                        Type            : access         
Bindings        : Unbound                        Minimum-links   : 2              
Maximum-links   : 3                             
Prot-Group-Type : round-robin                   
Internal Handle : 255/22:1:28/1/1/422           
Description     : 
Constituent Circuits:
 1. 2/15              (Up  )|  0.00% 
 2. 2/1               (Up  )|  0.00% 
 3. 2/3               (Up  )| 99.59% 

Как видите клипсы запрудили только 2/3 интерфейс - другие простаивают

а тут детали LACP link-group для OSPF

 

show link-group tocore detail

Link-Group: tocore (vlan-id 57), ID   : 297, State : Up   
------------------------------------------------------------------------------
Ccct count      : 3                              Grouping        : LoadShare      
Card Type       : unknown                        Type            : dot1q          
Bindings        : tocore@local                   Minimum-links   : 1              
Maximum-links   : 8                             
Internal Handle : 255/11:5:42/1/2/199           
Constituent Circuits:
 1. 2/16 vlan-id 57   (Up  )|  1.17% 
 2. 2/4 vlan-id 57    (Up  )|  1.27% 
 3. 2/2 vlan-id 57    (Up  )|  1.32% 


Link-Group: tocore (vlan-id 58), ID   : 297, State : Up   
------------------------------------------------------------------------------
Ccct count      : 3                              Grouping        : LoadShare      
Card Type       : unknown                        Type            : dot1q          
Bindings        : ospf1@local                    Minimum-links   : 1              
Maximum-links   : 8                             
Internal Handle : 255/11:5:42/1/2/200           
Constituent Circuits:
 1. 2/16 vlan-id 58   (Up  )|  32.22% 
 2. 2/4 vlan-id 58    (Up  )|  31.50% 
 3. 2/2 vlan-id 58    (Up  )|  31.46% 

 

со стороны свитча тоже все окей

 

#show lacp neighbor 
Flags:  S - Device is requesting Slow LACPDUs 
       F - Device is requesting Fast LACPDUs
       A - Device is in Active mode       P - Device is in Passive mode     

Channel group 1 neighbors

Partner's information:

         Partner Partner   LACP Partner  Partner   Partner  Partner     Partner
Port      Flags   State     Port Priority Admin Key Oper Key Port Number Port State
Gi2/43    SP      bndl      32767         0x0       0x1B     0x201       0x3C  
Gi2/45    SP      bndl      32767         0x0       0x1B     0x203       0x3C  
Gi2/46    SP      bndl      32767         0x0       0x1B     0x20F       0x3C  

Channel group 2 neighbors

Partner's information:

         Partner Partner   LACP Partner  Partner   Partner  Partner     Partner
Port      Flags   State     Port Priority Admin Key Oper Key Port Number Port State
Gi2/44    SA      bndl      32767         0x0       0x129    0x202       0x3D  
Gi2/47    SA      bndl      32767         0x0       0x129    0x204       0x3D  
Gi2/48    SA      bndl      32767         0x0       0x129    0x210       0x3D  

#show lacp internal 
Flags:  S - Device is requesting Slow LACPDUs 
       F - Device is requesting Fast LACPDUs
       A - Device is in Active mode       P - Device is in Passive mode     

Channel group 1
                           LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi2/43    SA      bndl      32768         0x1       0x1     0x22B       0x3D  
Gi2/45    SA      bndl      32768         0x1       0x1     0x22D       0x3D  
Gi2/46    SA      bndl      32768         0x1       0x1     0x22E       0x3D  

Channel group 2
                           LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi2/44    SP      bndl      32768         0x2       0x2     0x22C       0x3C  
Gi2/47    SP      bndl      32768         0x2       0x2     0x22F       0x3C  
Gi2/48    SP      bndl      32768         0x2       0x2     0x230       0x3C  

#show etherchannel summary 
Flags:  D - down        P - bundled in port-channel
       I - stand-alone s - suspended
       H - Hot-standby (LACP only)
       R - Layer3      S - Layer2
       U - in use      f - failed to allocate aggregator

       M - not in use, minimum links not met
       u - unsuitable for bundling
       w - waiting to be aggregated
Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi2/43(P)  Gi2/45(P)  Gi2/46(P)  
2      Po2(SU)         LACP      Gi2/44(P)  Gi2/47(P)  Gi2/48(P)  

 

отчего сие может быть ума не приложу. Может кто сталкивался? Связки LACP ACTIVE - PASSIVE менял во всех позах и направлениях - никакого влияния не оказывают. Заранее спасибо за помощь.

Share this post


Link to post
Share on other sites

Какова загрузка интерфесов со стороны свича ? И какой load-balance mode стоит на свиче ?

Share this post


Link to post
Share on other sites

Какова загрузка интерфейсов со стороны свитча ? И какой load-balance mode стоит на свитче ?

 

все так же как и на роутере. 2 интерфейса по нулям практически один интерфейс на 99 процентов

 

стоит layer3 сейчас, но я попробовал разные варианты с layer3 и по mac результат тот-же. На самом SE включал layer3 и layer4 и отключал в дефолт разницы нет в итоге вернул все по дефолту

 


#show etherchannel load-balance 
EtherChannel Load-Balancing Configuration:
       src-dst-ip
       mpls label-ip

EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source XOR Destination MAC address
 IPv4: Source XOR Destination IP address
 IPv6: Source XOR Destination IP address
 MPLS: Label or IP

Share this post


Link to post
Share on other sites

99 поц. И in и out ? Хоть в одном направление есть балланс ?

Share this post


Link to post
Share on other sites

99 проц. И in и out ? Хоть в одном направление есть баланс ?

никакого баланса, такое впечатление что SE принципиально не использует 2 других интерфейса. Для проверки достоверности, со стороны свитча убрал etherchannel, создал 3 линка и разбросал по ним все юзерские вланы. Со стороны эриксона оставил LAG. Что происходит - пользователи авторизуются, но все равно роутер даже не пытается слать пакеты авторизованных сессий через другие интерфейсы, все пакеты шлет через один и как итог работают только те пользователи, вланы которых разрешены для транка на этом интерфейсы со стороны свитча, остальные просто висят. Но авторизовались все пользователи, значит интерфейсы активны раз авторизация тех сабскрайберов чьи вланы разрешены на двух других интерфейсах прошла. (я извращался как мог, но то ли тут есть ньюанс какой то то ли это так работает на SE-100 вообше)

Edited by beepop

Share this post


Link to post
Share on other sites

Так правильно. Economical вам экономит ресурсы LAG.

 

The economical mode reduces the router resources used by the access link group, allowing more of these resources to become available to other applications. In non-economical mode (the default), circuit information on active ports is replicated on all standby ports. After an active port fails, no packets are lost when the standby port becomes active. In economical mode, which must be explicitly configured, the circuit information for 802.1Q single- or double-encapsulated (Q-in-Q) circuits on active ports is not replicated on the standby ports. After an active port fails and its standby port becomes active, a small number of packets on these circuits are lost in the transition. Circuit information on IPoE- (the default) or PPPoE-encapsulated circuits is replicated on all standby ports regardless of mode.

Share this post


Link to post
Share on other sites

Так правильно. Economical вам экономит ресурсы LAG.

 

The economical mode reduces the router resources used by the access link group, allowing more of these resources to become available to other applications. In non-economical mode (the default), circuit information on active ports is replicated on all standby ports. After an active port fails, no packets are lost when the standby port becomes active. In economical mode, which must be explicitly configured, the circuit information for 802.1Q single- or double-encapsulated (Q-in-Q) circuits on active ports is not replicated on the standby ports. After an active port fails and its standby port becomes active, a small number of packets on these circuits are lost in the transition. Circuit information on IPoE- (the default) or PPPoE-encapsulated circuits is replicated on all standby ports regardless of mode.

 

Это значит что нельзя агреггировать три порта на SE-100 для того что бы расширить полосу пропускания интерфейсов при использовании LAG access economical? При использовании LAG access, максимальное количество линков 2, а не 3 как при acess economical, и на них все дублируется, но не агрегируется - я так понял? Выходит единственный выход при access lag это создавать несколько групп с разным набором вланов?

Edited by beepop

Share this post


Link to post
Share on other sites

Да просто не используйте economical.

Более того интесно почему-же в сторону SE у вас не раскидываеться трафик ? Или вы все же как то неправильно мониторите.

Share this post


Link to post
Share on other sites

Да просто не используйте economical.

Более того интесно почему-же в сторону SE у вас не раскидываеться трафик ? Или вы все же как то неправильно мониторите.

Я использую три порта для аббонентов, 3 порта для траффика. (он у меня в роли MAS) Но если я использую не экономикал а просто аксесс то все равно не произойдет агрегации линков. Даже 2х. Будет бэкап линк, но никакой агрегации. В случае с CISCO я зоздаю пртчаннел интерфнйс 3го уровня, агрегируя до 8 линков, и на него вешаю что хочу и как хочу. Энкапсуляцию вланов, терминацию, нат. В случае с SE это не прокатит как я понял. Нужно балансить трафик по трем линкам вручную, если я хочу использовать все три. Это не удобно и не динамично. Так как разные сегменты сети в разное время проявляют различную активность и для четкого баланса придется перебрасывать их как минимум 2 раза сутки туда-обратно. Можно конечно все это повесть на скрипты, но это костыли. SE-100 разочаровал. Железка не дешёвая, но не достаточно гибкая выходит.

Share this post


Link to post
Share on other sites

Не правильно вы все понимаете.

Share this post


Link to post
Share on other sites

Так правильно. Economical вам экономит ресурсы LAG.

Я так понимаю балансировка для ipoe и для 802.1q или q-in-q работает по разному, у нас на ipoe (static clips и non-dhcp-clips) все балансируется на access economical, планируем сделать еще clips on-demand c 802.1q, но не хочется наступать на грабли.

Share this post


Link to post
Share on other sites

Вообще если кому интересно как настроить что бы эта байда динамически нагружала все интерфейсы при access-economical то вот кусок нашего рабочего конфига. Магическое слово - replicate )))

 

Вот кусок конфига с настройками под LACP

 

link-group access-lag_new access economical
encapsulation dot1q
service clips dhcp source-mac maximum 1 context local
dot1q pvc 1111 encapsulation 1qtunnel replicate 
 dot1q pvc on-demand 1111:1 through 999 
 service clips dhcp source-mac maximum 1 context local
maximum-links 3
minimum-links 1
lacp active
lacp periodic-timeout long

Edited by beepop

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this