Jump to content
Калькуляторы

Huawei S2300, MVR, multicast

День добрый!

 

Помогите пожалуйста решить проблему multicast mvr на

huiwei s2300. Если коротко, multicast работает в обычном режиме

без mvr. С мvr работает igmp сигнализация, но аб. порт не получает

сам multicast трафик.

 

Теперь поподробней. Есть тестовый стенд.

 

Источник multicast трафика vlc, подключенный к dlink 3120-24-SC,

к которому подключен s2326, и на нем уже vlc клиенты.

7 - влан с малтикастом

101 - абоненсткий влан 1 порта

 

1 порт - mvr абонент.

2 абонентский порт в multicast влане для проверки.

 

Клиенты подключаются по схеме vlan per сustomer, поэтому нужен mvr.

Настраивал все согласно последней документации с сайта

S2300&S3300_V100R006C05_02_en_DEC02204

 

В результате, через порт 2 без mvr все работает.

Через порт 1, где настроен mvr, работает только igmp сигнализация:

dlink, на котором настроен querier видит igmp,

создает группу, отправляет multicast хуавею. На

нем вижу по статистике, что uplink порт получает

mulicast, но не передает его в абонентский 1 порт.

 

На ноуте, подключенном в 1 первый порт, вижу правильный обмен igmp

пакетами, query, report'ы, leave. Все как положено. Работает как часы.

Стар стоп видео в vlc создает группы и igmp записи на обоих свитчах.

Только вот самого трафика нет!

 

На s2326 последня прошивка и патчи.

S2300 V100R006C05

Patch Package Version:V100R006SPH016

 

Вот конфиг:

#
!Software Version V100R006C05
sysname h26
#
info-center loghost 10.103.0.6 facility local0
#
dns resolve
dns server 10.103.0.100
#
vlan batch 4 to 5 7 101 to 124
#
stp mode rstp
stp enable
#
igmp-snooping enable
#
undo http server enable
undo http secure-server enable
#
drop illegal-mac alarm
#
vlan 7
igmp-snooping enable
igmp-snooping version 3
multicast-vlan enable
multicast-vlan user-vlan 101
multicast-vlan send-query prune-source-port
vlan 101
igmp-snooping enable
vlan 102
igmp-snooping enable
vlan 103
igmp-snooping enable
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
#
ntp-service unicast-peer 10.103.0.6
#
interface Vlanif5
ip address 10.105.0.6 255.255.255.0
#
interface Ethernet0/0/1
port hybrid pvid vlan 101
port hybrid untagged vlan 101
mac-limit maximum 5
loopback-detect recovery-time 60
loopback-detect enable
stp bpdu-filter enable
stp edged-port enable
#
interface Ethernet0/0/2
port link-type access
port default vlan 7
mac-limit maximum 5
loopback-detect recovery-time 60
loopback-detect enable
stp bpdu-filter enable
stp edged-port enable
#
#
interface GigabitEthernet0/0/1
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 4 to 5 7 101 to 124
#
interface GigabitEthernet0/0/2
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 4 to 5 7 101 to 124
#
interface NULL0
#
ip route-static 0.0.0.0 0.0.0.0 10.105.0.1
#
#
stelnet server enable
ssh user root
ssh user root authentication-type password
ssh user root service-type all
#
#
port-group uplinks
group-member GigabitEthernet0/0/1
group-member GigabitEthernet0/0/2
#
port-group user_ports
group-member Ethernet0/0/1
group-member Ethernet0/0/2
group-member Ethernet0/0/3
group-member Ethernet0/0/4
group-member Ethernet0/0/5
group-member Ethernet0/0/6
group-member Ethernet0/0/7
group-member Ethernet0/0/8
group-member Ethernet0/0/9
group-member Ethernet0/0/10
group-member Ethernet0/0/11
group-member Ethernet0/0/12
group-member Ethernet0/0/13
group-member Ethernet0/0/14
group-member Ethernet0/0/15
group-member Ethernet0/0/16
group-member Ethernet0/0/17
group-member Ethernet0/0/18
group-member Ethernet0/0/19
group-member Ethernet0/0/20
group-member Ethernet0/0/21
group-member Ethernet0/0/22
group-member Ethernet0/0/23
group-member Ethernet0/0/24
#
return

 

 

Вот, что показывает huawei.

 


[h26]disp igmp-snooping port-info
-----------------------------------------------------------------------
                    (Source, Group)  Port                          Flag
 Flag: S:Static     D:Dynamic     M: Ssm-mapping
-----------------------------------------------------------------------
VLAN 101, 1 Entry(s)
                     (*, 239.0.0.1)  Eth0/0/1                      -D-
                                               1 port(s)
-----------------------------------------------------------------------

[h26]disp l2-multicast forwarding-table vlan 7
VLAN ID : 7
----------------------------------------------------------------------
                    (Source, Group)    Interface             Out-Vlan
----------------------------------------------------------------------
                        Router-port    GigabitEthernet0/0/2     7
                     (*, 239.0.0.1)    GigabitEthernet0/0/2     7
                                       Ethernet0/0/1            101
----------------------------------------------------------------------

 

 

Чего я упустил?

Cпасибо!

Share this post


Link to post
Share on other sites

А вот и решение:

пользовательский порт должен разрешать и multicast vlan тоже

port hybrid untagged vlan 7 101

Share this post


Link to post
Share on other sites

А вот и решение:

пользовательский порт должен разрешать и multicast vlan тоже

port hybrid untagged vlan 7 101

СПАСИБО

Очень помог этот пост!

Share this post


Link to post
Share on other sites

Спасибо, коллеги! Работает на S2309TP-EI.

Share this post


Link to post
Share on other sites

Поднимем.

Каналы быстро переключаются? Столкнулся с тем, что минуты три-четыре.

На DES-3200-28 практически мгновенно...

Share this post


Link to post
Share on other sites

Столкнулся с похожей (или такой же) проблемой.
Имеется huawei s2326, в него постоянно наливается n групп мультикаста в влане 100. Нужно чтобы одна из групп подмешивалась в абонентский влан 20 по запросу.

Делаю как написано тут http://support.huawei.com/hedex/pages/EDOC1000023737DEC02204/07/EDOC1000023737DEC02204/07/resources/dc/dc_cfg_mvlan_0005.html

Не работает. В ваершарке вижу пакеты membership query general от источника и membership report group 239.100.10.1 от компа на котором запущен влц и больше ничего полезного.

 

 vlan batch 195 555
#
igmp-snooping enable
#
dhcp enable
dhcp snooping enable
dhcp option82 circuit-id format extend
#
 undo http server enable
 http server load s2300ei-v100r006c05.001.web.zip
#
 drop illegal-mac alarm
#
observe-port 1 interface GigabitEthernet0/0/2
#
acl number 3000
 rule 5 permit igmp
#
traffic classifier mvlan operator and
 if-match vlan-id 555
 if-match acl 3000
traffic classifier uvlan operator and
 if-match vlan-id 195
 if-match acl 3000
#
traffic behavior mvlan
 permit
traffic behavior uvlan
 deny
#
traffic policy igmp
 classifier mvlan behavior mvlan
 classifier uvlan behavior uvlan
#
vlan 195
 igmp-snooping enable
vlan 555
 igmp-snooping enable
 igmp-snooping querier enable
 multicast-vlan enable
 multicast-vlan user-vlan 195
 multicast-vlan send-query prune-source-port
#
interface Ethernet0/0/1
 description TEST
 port link-type access
 port default vlan 195
 loopback-detect enable
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 195 555
 loopback-detect enable
 traffic-policy igmp inbound
 dhcp snooping trusted
 port media type fiber
     undo negotiation auto
 combo-port auto
 port-mirroring to observe-port 1 inbound
 port-mirroring to observe-port 1 outbound

 

Share this post


Link to post
Share on other sites
45 минут назад, tiratore сказал:

в него постоянно наливается n групп мультикаста в влане 100. Нужно чтобы одна из групп подмешивалась в абонентский влан 20 по запросу

В конфигурации указаны VLAN 195 и 555.

Кроме того, сомнительно что требуется включение querier.

Обычно querier один и размещается поближе к источнику мультикаста.

Share this post


Link to post
Share on other sites
19 часов назад, alibek сказал:

В конфигурации указаны VLAN 195 и 555.

Кроме того, сомнительно что требуется включение querier.

Обычно querier один и размещается поближе к источнику мультикаста.

В конфигурации нужные вланы, текст скопирован с другой темы где для примера использовались влан 100 и 20. на счет querier согласен, мультики все время льются в хуавеи

Share this post


Link to post
Share on other sites
traffic-policy igmp inbound

убери на время 

ну и да. мультик у вас должен быть в влане 555

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this