Jump to content
Калькуляторы

cisco multicast

Здравствуйте. Помогите пожалуйста со следующим вопросом. Пожалуйста сильно не бейте...

 

От оператора телевидения получаем на циску через тунель мультикаст.

interface Tunnel1
ip address 172.16.1.37 255.255.255.252
ip pim sparse-dense-mode
load-interval 30
keepalive 10 3
tunnel source 
tunnel destination 
!

 

Внутрь к нам настроен интерфейс interface GigabitEthernet0/0/0

interface GigabitEthernet0/0/0
ip address 172.16.1.41 255.255.255.252
no ip redirects
no ip proxy-arp
ip pim sparse-dense-mode
!

 

На 172.16.1.42 стоит железка на которую приходит мультикаст и преобразуется в dvb-c...

Работает.

 

Есть интерфейс в нашу локальную сеть

interface GigabitEthernet0/0/1
ip address 10.1.0.1 255.255.255.0
no ip redirects
no ip proxy-arp
ip pim sparse-dense-mode
!

Оператор естественно ничего не знает о нашей сети 10.1.0.0/24.

Можно ли каким либо образом настроить cisco что бы в сети 10.1.0.0/24 можно было тоже смотреть iptv от оператора, без дополнительных настроек у оператора?

 

mtrace 172.16.1.37 239.1.1.123
0  172.16.1.37
-1  172.16.1.37 ==> 172.16.1.37 PIM_MT  [using shared tree]
-2  172.16.1.38 ==> 172.31.1.2 None  [using shared tree]
-3  172.31.1.1 ==> 0.0.0.0 PIM Reached RP/Core [using shared tree]

Share this post


Link to post
Share on other sites

>> Можно ли каким либо образом настроить cisco что бы в сети 10.1.0.0/24 можно было тоже смотреть iptv от оператора, без дополнительных настроек у оператора?

А почему вы думаете, что у оператора есть какие-то специфичные настройки, чтобы отдавать мультикаст только для сегмента dbv-c модулятора?

 

>>ip multicast-routing

>>и ip pim rp address, есть мнение вас спасут.

 

pim не будет работать без включенного раутинга мультикаста, если у тс работает хотя бы dense, значит он скорее всего включен.

Если я не прав - поправьте, но в sparse-dense режиме pim будет dense до тех пор, как раз, пока не будет определена rp.

По идее должно работать при указанных настройках.

Edited by tehmeh

Share this post


Link to post
Share on other sites

А мультикаст точно не уходит в GigabitEthernet0/0/1?

Может быть дело в IGMP? Подписчики-то в сегменте есть?

Что показывают:

sh ip igmp groups
sh ip igmp int GigabitEthernet0/0/1

?

З.Ы. Сам не силён в мультикасте.

Share this post


Link to post
Share on other sites

Можно ли каким либо образом настроить cisco что бы в сети 10.1.0.0/24 можно было тоже смотреть iptv от оператора, без дополнительных настроек у оператора?

ip helper-address для этого используется.

Share this post


Link to post
Share on other sites

Всем спасибо за ответ.

 

В ip pim rp address уже стоит адрес оператора, меняю на свой, понятно дело картинка через некоторое время пропадает - циска join'ы шлет не туда.

 

sh ip igmp groups

239.1.1.1 GigabitEthernet0/0/0 00:23:20 00:02:42 172.16.1.42

....

Share this post


Link to post
Share on other sites

sh ip igmp groups

239.1.1.1 GigabitEthernet0/0/0 00:23:20 00:02:42 172.16.1.42

 

Так, у вас, видимо, трафик валит в порт.

А так что показывает?

sh ip mro

Может у вас мультикаст фильтруется уже дальше в сегменте сети?

 

ip helper-address для этого используется.

А это разве не для того, чтобы пересылать броадкаст юникастом?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this