Jump to content
Калькуляторы

mikrotik rb750 пропадает трафик

Поставил вместо FreeBSD софт роутера, аппаратный микротик rb750, ибо с фрёй начались проблемы и первое что под рукой было, этот микротик. В сети работал DHCP, все маки перенес вручную на микротик, создал правила с лимитером. Включаю, работает(задержка пакетов меньше чем на фре), но переодически, через разные промежутки времени и на разное время(от 1сек до 15сек) пропадает интернет. Причину понять не могу. И еще, почему то микротиковскиц DHCP начал раздавать неправильные адреса, вместо 192.168.1.ХХ раздаёт дефолтные 192.168.88.ХХ а вот шлюз и DNS правильный. Как угомонить этот микротик?

Share this post


Link to post
Share on other sites

Необходимо сначала сбросить дефолтную конфигурацию уже потом создавать свои правила.

Share this post


Link to post
Share on other sites

Сбросить дефолтные настройки, и заново настроить.

Share this post


Link to post
Share on other sites

Необходимо сначала сбросить дефолтную конфигурацию уже потом создавать свои правила.

Естественно сбросил. Настраивал с нуля. Еще когда машины получают адрес 192.168.88.хх и отображаются в DHCP leases, переношу абонента в статик указав вручную IP, он отображается с двумя IP, один от DHCP второй от статика. Потом удаляю заранее вбитые MAC+IP из статика и абонент получает нужный IP....

В общем что хочу сказать, добавить в статик и нужным IP получается если только машина в сети и получила случайный IP, потом просто добавляю в статик. Но я перед этим потратил уйму времени вгоняя в микротик все связки MAC+IP плюс к этому сидеть ждать когда каждая машина подключится, получит рандомный IP и потом перегнать ее в статк не реально.

Либо я что то делаю не так, либо микротик ос уступает фре в гибкости, либо не знаю...

Влучит FreeBSD на ночь, нагрузка не большая справляется, но нужно край разобратся с микротиком...

Edited by Fint

Share this post


Link to post
Share on other sites

Необходимо сначала сбросить дефолтную конфигурацию уже потом создавать свои правила.

Естественно сбросил. Настраивал с нуля. Еще когда машины получают адрес 192.168.88.хх и отображаются в DHCP leases, переношу абонента в статик указав вручную IP, он отображается с двумя IP, один от DHCP второй от статика. Потом удаляю заранее вбитые MAC+IP из статика и абонент получает нужный IP....

В общем что хочу сказать, добавить в статик и нужным IP получается если только машина в сети и получила случайный IP, потом просто добавляю в статик. Но я перед этим потратил уйму времени вгоняя в микротик все связки MAC+IP плюс к этому сидеть ждать когда каждая машина подключится, получит рандомный IP и потом перегнать ее в статк не реально.

Либо я что то делаю не так, либо микротик ос уступает фре в гибкости, либо не знаю...

Влучит FreeBSD на ночь, нагрузка не большая справляется, но нужно край разобратся с микротиком...

А не проще с фрей разобраться? Судя по тому что у вас 750 микротик скорости у вас небольшие и абонентов не так много.

Микротик кстати тоже софтовый :)

 

У вас что за железо на фре стоит? Что крутиться?

Share this post


Link to post
Share on other sites

Необходимо сначала сбросить дефолтную конфигурацию уже потом создавать свои правила.

Либо я что то делаю не так, либо микротик ос уступает фре в гибкости, либо не знаю...

 

Вот настройка DHCP сервера, в бридж добавляются нужные порты:

 

/ip pool
add name=dhcp_pool1 ranges=192.168.0.2-192.168.0.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=bridge1 name=dhcp1
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
/ip address
add address=192.168.0.1/24 interface=bridge1
/ip dhcp-server network
add address=192.168.0.0/24 dns-server=192.168.0.1 gateway=192.168.0.1

 

А не проще с фрей разобраться? Судя по тому что у вас 750 микротик скорости у вас небольшие и абонентов не так много.

Микротик кстати тоже софтовый :)

 

У вас что за железо на фре стоит? Что крутиться?

 

Выкинуть эту фрю надо, она уже морально устарела.

Share this post


Link to post
Share on other sites

Выкинуть эту фрю надо, она уже морально устарела.

Вот только фря рвет микротик по цене, удобству и производительности.

Да даже убунта порвет.

 

Да и багов нету типа падение от SSH. От задач сложнее SOHO роутера не тормозит.

Да и эникейщики умеющие только кнопочки тыкать туда не полезут.

Share this post


Link to post
Share on other sites

Вот только фря рвет микротик по цене, удобству и производительности.

Да даже убунта порвет.

 

Да и багов нету типа падение от SSH. От задач сложнее SOHO роутера не тормозит.

Да и эникейщики умеющие только кнопочки тыкать туда не полезут.

 

Микротик с новья все умеет, достаточно залить конфиг с инета. Другие операционки нужно предварительно установить, интерфейс у них не очень не удобный.

Share this post


Link to post
Share on other sites
Поставил вместо FreeBSD софт роутера, аппаратный микротик rb750

Вертайте обратно!

мыкротык 750 по производительности аля дир620 - сотку может вывезти на пределе, если в фаервол, шейпер и днс там не юзать.

Аппаратный там только вроде нат и пппое клиент, для всего остального мипс проц мегагерц на 400, который всяко слабее даже п3.

 

но переодически, через разные промежутки времени и на разное время(от 1сек до 15сек) пропадает интернет

А на фре оно работало - напрашивается вывод что проблема в чём то ещё.

 

Микротик с новья все умеет, достаточно залить конфиг с инета. Другие операционки нужно предварительно установить, интерфейс у них не очень не удобный.

Да чё уж там, пусть сразу виндуст сервер и трафиг инсектор ставит, там всё ещё удобнее.

Share this post


Link to post
Share on other sites

У вас что за железо на фре стоит? Что крутиться?

железо

Мать ASUS p4s533-mx

Селерон 1.7Ггц

Чипсет SIS 651

слоты памяти 2DDR+2SDRAM, DDR400

Установленная память PC133 SDRAM 256Мб 133Мгц + PC133 SDRAM 128Мб 133Мгц

Сетевые: PCI D-Link DFE-520TX + встроенная на основе SIS 962

Загрузка процессора 20-33%, при макс макгрузке до 40%, с памятью тоже самое.

D-Link был заменен на Intel, по началу казалось что помогло, но проблемы снова появились.

 

FreeBSD 8.1 PFSense 2.0.2, статик DHCP, 60 абонентов, 12Мбит аплинка, Тарифы были 1Мбит и 2Мбит.Максимальная загрузка канала 10-11 Мбит, очень редко и на очень короткое время до 12 Мбит. PPS 1500-1700. Глюки заключаются в том что пинги у танкистов не стабильные, обычно 30-50, по вечерам 80-120 и бывает в пики нагрузок 400-600-800.Также есть проблемы со скоростью, от аплинка приходит все, проверял... Это все бывало при загрузке канала 5Мбит-10Мбит, тоесть не зависит от загрузки аплинка.

 

 

Добавлю, вря стабильно проработала год.

Edited by Fint

Share this post


Link to post
Share on other sites
Поставил вместо FreeBSD софт роутера, аппаратный микротик rb750

Вертайте обратно!

мыкротык 750 по производительности аля дир620 - сотку может вывезти на пределе, если в фаервол, шейпер и днс там не юзать.

Аппаратный там только вроде нат и пппое клиент, для всего остального мипс проц мегагерц на 400, который всяко слабее даже п3.

 

Мне нужно что бы он(или другой, все равно лиш бы работало) стабильно прожевал 20Мбит(сейчас 12Мбит), 750 должен 20Мбит прожевать, наверное... Я гдето накасячил с настройкой. + почему пал выбор на микротик, из за биллинга (не микробил).

Приму совет по любому стабильно работающему решению, спасибо.

Share this post


Link to post
Share on other sites

Есть HP Proliant DL360G4 2x3.4Ггц Xeon, 4x1024 ddr. Пролежал больше года, не могу влючить его, в агусте 2012 тоже не влючался, постоял 72м часа, с горем пополам утановил убунту и он работал, но за не надобностью отформатировал диски и задвинул его подальше. Никакой инфы по этим серверам найти не могу, кто нибуть разбирается в них? Было бы не плохо перенести на него фрю.

Share this post


Link to post
Share on other sites

Походу у вас что то аппаратное. Купите новую машинку.

У меня много машин на фре так все сурово больше года работают без глюков.

 

Купите новый PC на базе I3 с максимально возможной частотой, мамку на топовом чипсете, пару планок памяти хотя бы по 2гб на канал, если останется бабло то интесловскую 2 головую сетевуху на PCI-E.

Тогда настанет счастье. Этот комп легко прожует гбит и даже больше да и цена меньше килобакса выйдет :)

 

Как вариант взять готовый сервер на атоме от supermicro, полгига точно прожует возможно больше. Зато цена около 500$

 

С HP надо разбираться. Да и раз глючит в продакшен лучше не ставить.

Edited by pawel40

Share this post


Link to post
Share on other sites
Поставил вместо FreeBSD софт роутера, аппаратный микротик rb750

Вертайте обратно!

мыкротык 750 по производительности аля дир620 - сотку может вывезти на пределе, если в фаервол, шейпер и днс там не юзать.

Аппаратный там только вроде нат и пппое клиент, для всего остального мипс проц мегагерц на 400, который всяко слабее даже п3.

 

Мне нужно что бы он(или другой, все равно лиш бы работало) стабильно прожевал 20Мбит(сейчас 12Мбит), 750 должен 20Мбит прожевать, наверное... Я гдето накасячил с настройкой. + почему пал выбор на микротик, из за биллинга (не микробил).

Приму совет по любому стабильно работающему решению, спасибо.

 

Ну так сбросьте начальный конфиг и настройте с нуля, т.к. не может он сам по себе другие адреса выдавать. Либо у вас в сети есть другой микротик, который сбросить забыли и т.п.

Share this post


Link to post
Share on other sites
Поставил вместо FreeBSD софт роутера, аппаратный микротик rb750

Вертайте обратно!

мыкротык 750 по производительности аля дир620 - сотку может вывезти на пределе, если в фаервол, шейпер и днс там не юзать.

Аппаратный там только вроде нат и пппое клиент, для всего остального мипс проц мегагерц на 400, который всяко слабее даже п3.

 

Мне нужно что бы он(или другой, все равно лиш бы работало) стабильно прожевал 20Мбит(сейчас 12Мбит), 750 должен 20Мбит прожевать, наверное... Я гдето накасячил с настройкой. + почему пал выбор на микротик, из за биллинга (не микробил).

Приму совет по любому стабильно работающему решению, спасибо.

 

Ну так сбросьте начальный конфиг и настройте с нуля, т.к. не может он сам по себе другие адреса выдавать. Либо у вас в сети есть другой микротик, который сбросить забыли и т.п.

Осмтальные микротики бриджом настроены, радион-лан.

 

А можно будет на одной машине фрю и билинг зависти?

Share this post


Link to post
Share on other sites

Осмтальные микротики бриджом настроены, радион-лан.

 

А можно будет на одной машине фрю и билинг зависти?

 

Возможно на одном из них забыли отключить какие-то настройки. Биллинг и NAS на одной машине не держат.

Share this post


Link to post
Share on other sites
Глюки заключаются в том что пинги у танкистов не стабильные, обычно 30-50, по вечерам 80-120 и бывает в пики нагрузок 400-600-800.

И почему вы решили что именно фря даёт такую задержку?

 

Также есть проблемы со скоростью, от аплинка приходит все, проверял...

Ну приходить может что угодно, нужно смотреть не мусор ли это, может вам льют днс флуд на пару мегабит, фря его естессно дропает, но полезная пропускная способность канала падает, тк аплинк режет у себя.

Те вход на wan должен примерно соответствовать выходу на lan.

Share this post


Link to post
Share on other sites

А можно будет на одной машине фрю и билинг зависти?

Можно, но лучше на разных машинах держать.

Знаю пару операторов у которых на одном сервере реализовано, у них за сотню клиентов юриков...

Share this post


Link to post
Share on other sites

Осмтальные микротики бриджом настроены, радион-лан.

 

А можно будет на одной машине фрю и билинг зависти?

 

Возможно на одном из них забыли отключить какие-то настройки.

Не думаю.Больше года работают.

 

Глюки заключаются в том что пинги у танкистов не стабильные, обычно 30-50, по вечерам 80-120 и бывает в пики нагрузок 400-600-800.

И почему вы решили что именно фря даёт такую задержку?

 

Не именно фря, а нас в целом, в железе дело. Допилил микротик, не особо лучше чем на фре, но пинги не поднимаются выше 200. В данный момент 2-00 пинги 30-50, вечером около 10-00 были 70-150. До 400-600-800 не поднимались как на фре+небыло проблем с онлайн видео.

 

 

Те вход на wan должен примерно соответствовать выходу на lan.

Даже не подумал на счет днс... посмотрю.

Share this post


Link to post
Share on other sites

На ван интерфейсе входящего трафика больше чем на лан исходящего. Разница от 0.5Мбит до 2Мбит, как это решить?

Share this post


Link to post
Share on other sites

А его и будет больше.

Часть предназначена самому роутеру, часть оседает в шейпере, часть дропается.

По быстрому - можно выключить шейпер :)

Share this post


Link to post
Share on other sites

Тоесть увеличить аплинк, и все будет гуд? Раньше не замечал такой проблемы. 4Мбита, 6Мбит, 10Мбит, перед увеличением до 12Мбит начались подобные лаги, но слабо заметные. А сейчас очень ощутимо, при загрузке по лан 9-10Мбит, начинаются глюки, и по ван идет 11-13Мбит(при12Мбит аплинка). Теперь вот думаю, может дело было и не во фре)))

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this