Jump to content
Калькуляторы

Cisco like конфиг на Mikrotik Терминация вланов и шейпинг на Mikrotik

Добрый день! Абоненты терминируются (Vlan per user) на cisco след образом:

 

interface GigabitEthernet0/2
description TRUNK to DGS3627G 
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip virtual-reassembly max-reassemblies 64
ip route-cache flow
duplex auto
speed auto
negotiation auto
no cdp enable
!
interface GigabitEthernet0/2.112
description test
encapsulation dot1Q 112
ip address z.z.z.z 255.255.255.252
rate-limit input 2048000 25600 25600 conform-action transmit exceed-action drop
ip policy route-map MY_DPI
no snmp trap link-status
traffic-shape group 184 2048000 51200 51200 1000
traffic-shape group 185 128000 7936 7936 1000
no cdp enable
!
interface GigabitEthernet0/2.124
description test
encapsulation dot1Q 124
ip address y.y.y.y 255.255.255.252
rate-limit input 2048000 51200 51200 conform-action transmit exceed-action drop
ip policy route-map MY_DPI
no snmp trap link-status
traffic-shape rate 2048000 51200 51200 1000
!
interface GigabitEthernet0/2.126
description test
encapsulation dot1Q 126
ip address h.h.h.h 255.255.255.240
rate-limit input 5000000 100000 100000 conform-action transmit exceed-action drop
ip policy route-map MY_DPI
no snmp trap link-status
traffic-shape rate 5000000 125000 125000 1000
!
interface GigabitEthernet0/2.127
description test
encapsulation dot1Q 127
ip address n.n.n.n 255.255.255.248
rate-limit input 20000000 256000 256000 conform-action transmit exceed-action drop
ip policy route-map MY_DPI
no snmp trap link-status
traffic-shape rate 21000000 525000 525000 1000
!

Замечу: GigabitEthernet0/2 - используется для транка с коммутатором.

 

 

Как я понимаю, у Микротика нет монолитного конфига, что-то подобное там сделать сложно (терминация и шейпинг настраиваются там в разных местах).

Весь вопрос в том, как будет выглядеть подобный конфиг на Микротике?

 

 

2)Есть ли положительные отзывы/мнения о Mikrotik CCR1036-12G-4S. Что можно сказать о его производительности в реальной сети(1400-1500 абонентов онлайн)?

Edited by sergeyfromkomi

Share this post


Link to post
Share on other sites

1)Конфиг монолитный есть, сделать можно. Как будет выглядеть - велкам в wiki.

2)Зависит от нужного функционала и прошивки. Рядом есть тема по CCR, там выкладывали тесты.

Share this post


Link to post
Share on other sites

Конфиг то есть, но прописывание разного функционала в одной секции вроде нет. То есть как у циски в секции интерфейса в данном примере.

Хотя сама циска от этого сделала попытку уйти в IOS-XR.

Вопрос привычки и вообще достаточно спорный.

Share this post


Link to post
Share on other sites

да все тоже самое

 

export compact покажет текстовый вариант конфига.

конфигурируется точно так же путем перехода в контекст конфигурирования данной секции либо добавлении полной строчки конфига.

Share this post


Link to post
Share on other sites

Мне не достаточно ясна терминология микротика касательно сабинтерфейсов. Они привязываются к бриджам?

 

Как в микротике поднять сабинт-с, аналогичный следующему на cisc-е:

!
interface GigabitEthernet0/2.112
description test
encapsulation dot1Q 112
ip address z.z.z.z 255.255.255.252
rate-limit input 2048000 25600 25600 conform-action transmit exceed-action drop
ip policy route-map MY_DPI
no snmp trap link-status
traffic-shape group 184 2048000 51200 51200 1000
traffic-shape group 185 128000 7936 7936 1000
no cdp enable
!

Share this post


Link to post
Share on other sites

/interface vlan add name=vlan_66_mgm vlan-id=66 interface=ether1

/ip address add address=172.20.1.97/30 comment=MGM_Interface interface=vlan_66_mgm

ну а шейпер настраивается в queue это отдельная тема

 

Терминология везде одинаковая...

Edited by myst

Share this post


Link to post
Share on other sites

Ну это ж не то, что надо топикстартеру.

Если потом сделать листинг конфига, то обе эти строчки будут не рядом, не говоря уже про шейпер, который - отдельная тема.

То есть настройки будут размазаны по конфигу.

Share this post


Link to post
Share on other sites

Ну это ж не то, что надо топикстартеру.

Если потом сделать листинг конфига, то обе эти строчки будут не рядом, не говоря уже про шейпер, который - отдельная тема.

То есть настройки будут размазаны по конфигу.

Ну надо признать размазаны логично. Совсем немного не так как в циске..

 

Там полиси/роут мепы тоже отдельно от интерфейса настраиваются а потом цепляются непосредственно на интерфейс.

Share this post


Link to post
Share on other sites

Ну это ж не то, что надо топикстартеру.

Если потом сделать листинг конфига, то обе эти строчки будут не рядом, не говоря уже про шейпер, который - отдельная тема.

То есть настройки будут размазаны по конфигу.

Просто другая идеология (линуховая, если уж на то пошло). А vlan да, можно вешать и на бридж.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this