Jump to content
Калькуляторы

Помогите реализовать

Помогите с пробросом портов на микротие или как реализовать! Ситуация такая - стоит роутер с белым ип 11.11.11.1 на котором стоит биллинг 12.12.12.2, далее 12.12.12.3 стоит НАС и на абоны. Сделал сайт и ссылку для входа в личный кабинет на 11.11.11.1, с вне сети ссыка работает а вот со строны НАСа открывается интерфейс микротика. Как правильно настроить пробросы что бы и из внутреней сети открывался личный кабинет? А также разрешить доступ на сайт при негативном депозите!

Share this post


Link to post
Share on other sites

Помогите с пробросом портов на микротие или как реализовать! Ситуация такая - стоит роутер с белым ип 11.11.11.1 на котором стоит биллинг 12.12.12.2, далее 12.12.12.3 стоит НАС и на абоны. Сделал сайт и ссылку для входа в личный кабинет на 11.11.11.1, с вне сети ссыка работает а вот со строны НАСа открывается интерфейс микротика. Как правильно настроить пробросы что бы и из внутреней сети открывался личный кабинет? А также разрешить доступ на сайт при негативном депозите!

wiki.mikrotik.com port mapping.

Share this post


Link to post
Share on other sites

Помогите с пробросом портов на микротие или как реализовать! Ситуация такая - стоит роутер с белым ип 11.11.11.1 на котором стоит биллинг 12.12.12.2, далее 12.12.12.3 стоит НАС и на абоны. Сделал сайт и ссылку для входа в личный кабинет на 11.11.11.1, с вне сети ссыка работает а вот со строны НАСа открывается интерфейс микротика. Как правильно настроить пробросы что бы и из внутреней сети открывался личный кабинет? А также разрешить доступ на сайт при негативном депозите!

wiki.mikrotik.com port mapping.

Либо там не то написано что надо, либо я неправильно изложил вопрос, либо вы меня не поняли. Одним словом не получилось ничего.

Share this post


Link to post
Share on other sites

Либо там не то написано что надо, либо я неправильно изложил вопрос, либо вы меня не поняли.

И то и другое и третье!

И можно без хлеба (с)

Share this post


Link to post
Share on other sites

а кабинет у вас физически на чем расположен?

Share this post


Link to post
Share on other sites

а кабинет у вас физически на чем расположен?

кабинет стоит на роутере с ип 12.12.12.2, я сделал проброс порта и при наборе былого ип 11.11.11.1 с внешней сети захожу в кабинет а вот из сети открывается микротик!

Share this post


Link to post
Share on other sites

скрины настроек скиньте, будем смотреть

Share this post


Link to post
Share on other sites

скрины настроек скиньте, будем смотреть

Что еще нужно?

post-90911-043813600 1363769490_thumb.jpg

Share this post


Link to post
Share on other sites

пропишите порт 80 в обеих вкладках, и уберите In интерфейс.

Share this post


Link to post
Share on other sites

пропишите порт 80 в обеих вкладках, и уберите In интерфейс.

Ситуация та же!

Share this post


Link to post
Share on other sites

все верно. и не будет работать. вам нужно внутренний трафик маркировать и перенаправлять

Share this post


Link to post
Share on other sites

все верно. и не будет работать. вам нужно внутренний трафик маркировать и перенаправлять

Подскажите как? если не трудно...

Share this post


Link to post
Share on other sites
post-90911-072420500 1363808867_thumb.jpgпо внутренему ІР абоненты заходят! может я не правильно описал задачу, высылаю схему.

Share this post


Link to post
Share on other sites

/ip firewall filter

add chain=forward dst-limit=10,10,src-address dst-port=443 protocol=tcp src-address-list=list_balance_negative

add action=drop chain=forward dst-address=!10.0.0.0/8 src-address-list=list_balance_negative

/ip firewall nat

add action=redirect chain=dstnat dst-address=!10.0.0.0/8 dst-port=80 protocol=tcp src-address-list=list_balance_negative to-ports=8123

add action=masquerade chain=srcnat dst-address=!10.0.0.0/8 src-address=10.0.0.0/8

/ip proxy

set enabled=yes port=8123

/ip proxy access

add action=deny redirect-to=10.0.0.5/balance/index.html

 

 

Вот как-то так. На сервере 10.0.0.5 хранится страничка с уведомлением о отсутствии средств.

10.0.0.0/8 подсеть клиентов.

Самое первое правило пускает всех в инет, кто заблокирован, на порт 443 для доступа к страничке выставления счета через киви-кошелек.

Нужно не забыть отключить маскардинг для внутренних адресов, иначе ничего работать не будет.

Share this post


Link to post
Share on other sites

/ip firewall filter

add chain=forward dst-limit=10,10,src-address dst-port=443 protocol=tcp src-address-list=list_balance_negative

add action=drop chain=forward dst-address=!10.0.0.0/8 src-address-list=list_balance_negative

/ip firewall nat

add action=redirect chain=dstnat dst-address=!10.0.0.0/8 dst-port=80 protocol=tcp src-address-list=list_balance_negative to-ports=8123

add action=masquerade chain=srcnat dst-address=!10.0.0.0/8 src-address=10.0.0.0/8

/ip proxy

set enabled=yes port=8123

/ip proxy access

add action=deny redirect-to=10.0.0.5/balance/index.html

 

 

Вот как-то так. На сервере 10.0.0.5 хранится страничка с уведомлением о отсутствии средств.

10.0.0.0/8 подсеть клиентов.

Самое первое правило пускает всех в инет, кто заблокирован, на порт 443 для доступа к страничке выставления счета через киви-кошелек.

Нужно не забыть отключить маскардинг для внутренних адресов, иначе ничего работать не будет.

Перенаправления на личный кабинет при негативном балансе естьи работает только через dst-nat а вот клиенты которые хотят пополнится раньше не могут зайти в кабинет кроме тех кто находится за натом на удаленных НАС серверах!

Share this post


Link to post
Share on other sites

Если они не могут, значит доступа до личного кабинета не имеют. Нужно что бы НАТ работал только в сторону интернета, а на адреса вашей сети был отключен.

Share this post


Link to post
Share on other sites

Если они не могут, значит доступа до личного кабинета не имеют. Нужно что бы НАТ работал только в сторону интернета, а на адреса вашей сети был отключен.

Спасибо помогло!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this