Jump to content
Калькуляторы

Агрегация портов Cisco

Ситуация следующая - Есть две циски 2960. Нужно настроить агрегацию портов. В логический интерфейс объединены с обоих сторон

гигабитные порты. Настроено вот так:

 

interface GigabitEthernet1/1

channel-protocol lacp

channel-group 1 mode active

switchport mode trunk

!

interface GigabitEthernet1/2

channel-protocol lacp

channel-group 1 mode active

switchport mode trunk

!

interface Port-channel 1

channel-protocol lacp

switchport mode trunk

!

Эзерченел поднялся, но если рвется Gi1/1, то связь теряется. Если Gi1/2, то связь есть. Подумал, что это из-за STP. Отключил STP глобально на

1 влане

 

no spanning-tree vlan 1

 

ситуация изменилась. Теперь какой линк не рви, связь падает. Подскажите что нужно сделать, чтобы связь не терялась при наличии хотябы одного

линка в езерченале?

Edited by fing

Share this post


Link to post
Share on other sites

lacp для 2960 не лучший вариант, используйте pagp (mode desirable)

 

conf t

no int port-channel 1

int range g1/1 , g1/2

no channel-protocol

no channel-group 1

channel-group 1 mode desirable

 

аналогично и со второй стороны

Share this post


Link to post
Share on other sites

acp для 2960 не лучший вариант, используйте pagp (mode desirable)

сделал как говорили

 

interface GigabitEthernet1/1

channel-group 1 mode desirable

switchport mode trunk

!

interface GigabitEthernet1/2

channel-group 1 mode desirable

switchport mode trunk

!

interface Port-channel 1

switchport mode trunk

 

и верул STP. Опять получается так,что если рву первый линк, то пропадает все. Если второй, то работает. Видимо STP на первый линк все отправляет. Почему не перестраивается та на второй линк не пойму.

Share this post


Link to post
Share on other sites

acp для 2960 не лучший вариант, используйте pagp (mode desirable)

сделал как говорили

 

interface GigabitEthernet1/1

channel-group 1 mode desirable

switchport mode trunk

!

interface GigabitEthernet1/2

channel-group 1 mode desirable

switchport mode trunk

!

interface Port-channel 1

switchport mode trunk

 

и верул STP. Опять получается так,что если рву первый линк, то пропадает все. Если второй, то работает. Видимо STP на первый линк все отправляет. Почему не перестраивается та на второй линк не пойму.

 

Для первого варианта дайте sh lacp nei, что даст? Скорее всего второй линк не живой.

Share this post


Link to post
Share on other sites

1. Покажите конфигурации интерфейсов.

2. Интерфейсы должны быть сконфигурированы идентично (скорости, дуплексы, вланы, STP)

Cмотрите sh lacp nei и sh lacp intern

 

В sh lacp inern оба интерфейса должны быть bndl в таком случае LACP собрался

Share this post


Link to post
Share on other sites

А если все нормально, но трафик бежит только через один интерфейс? (правда трафика пока маловато)

 

me-3400#show etherchannel load-balance

EtherChannel Load-Balancing Configuration:

src-mac

 

Port Flags State Priority Key Key Number State

Gi0/13 SA bndl 32768 0x1 0x1 0x10E 0x3D

Gi0/14 SA bndl 32768 0x1 0x1 0x10F 0x3D

 

Channel group 2

LACP port Admin Oper Port Port

Port Flags State Priority Key Key Number State

Gi0/10 SA bndl 32768 0x2 0x2 0x10B 0x3D

Gi0/11 SA bndl 32768 0x2 0x2 0x10C 0x3D

 

GigabitEthernet0/13 is up, line protocol is up (connected)

MTU 9000 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not set

Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseLX SFP

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:05, output 00:00:05, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

 

GigabitEthernet0/14 is up, line protocol is up (connected)

MTU 9000 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not set

Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseLX SFP

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:01, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 141000 bits/sec, 142 packets/sec

5 minute output rate 440000 bits/sec, 64 packets/sec

Share this post


Link to post
Share on other sites

А если все нормально, но трафик бежит только через один интерфейс? (правда трафика пока маловато)

 

me-3400#show etherchannel load-balance

EtherChannel Load-Balancing Configuration:

src-mac

если у вас там точка-точка, то такая балансировка бесполезна.

src-dst-ip на обоих концах даст более менее размазанную нагрузку.

Share this post


Link to post
Share on other sites

в любом случае стоит поиграться с режимом балансировки - оптимальный выбор сильно зависит от конкретных условий работы сети.

Share this post


Link to post
Share on other sites

А если сделать статиком аггрегат?

 

channel-group 1 mode on

Share this post


Link to post
Share on other sites

Сделал, толку - 0. Все так же бегает через один интерфейс

Share this post


Link to post
Share on other sites

АААА, убейте меня АП стенку... Видимо сказывается переработка, мне же ОБЯЗАТЕЛЬНО надо ставить src-dst-ip.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this