Jump to content
Калькуляторы

Ха-ха! PBR и UNNUMBERED на Cisco Catalyst 4900M

Господа, помогите разобраться. Кажется, наткнулся на неприятную особенность платформы 4900M. Похоже, что Policy-Based Routing невозможен на Unnumbered интерфейсах. ;)))) А чего хотелось бы непременно.

 

Рассказываю суть проблемы. После Киски стоит шейпер с BGP через два соска по гигабиту, на самой Cisco сейчас поднят unnumbered infcs, все работает, но в качестве роутинга на эти два соска используется round-robib routing, то есть в тупую два дефолта. Хотел привернуть Policy-Based Routing, чтобы раскидать по сетям входящим - половину на один 1GB, половину на второй, но похоже наконец понял суть надписи при конфигурении unnumbered: Warning: dynamic routing protocols will not work on non-point-to-point interfaces with IP unnumbered configured .

 

И так, кусок конфига с unnumbered:

===

!

interface Loopback0

description Main IP Pool

ip address 2.2.2.2 255.255.255.0 secondary

ip address 1.1.1.1 255.255.255.0

no ip redirects

!

interface Vlan2

description Clients Vlan

ip unnumbered Loopback0 poll

ip policy route-map OutToBGP

!

interface Vlan3

description To-BGP-Link1

ip address 10.10.10.2 255.255.255.252

!

interface Vlan4

description To-BGP-Link2

ip address 10.10.10.6 255.255.255.252

!

ip route 0.0.0.0 0.0.0.0 10.10.10.1

ip route 0.0.0.0 0.0.0.0 10.10.10.5

!

access-list 10 permit 1.1.1.1 0.0.0.255

access-list 11 permit 2.2.2.2 0.0.0.255

!

route-map OutToBGP permit 10

description NextHop is Link1 Vlan3

match ip address 10

set ip next-hop 10.10.10.1

!

route-map OutToBGP permit 11

description NextHop is Link2 Vlan4

match ip address 11

set ip next-hop 10.10.10.5

!

===

 

Как становится понятно, из моего объяснения, ip policy route-map OutToBGP не работает на Vlan2, то есть если бы не было ip route 0.0.0.0 0.0.0.0 10.10.10.1 и ip route 0.0.0.0 0.0.0.0 10.10.10.5, то роутинг отсутствовал бы.

 

Теперь, если мы сконфигурим без unnumbered, то все будет работать. Пример:

 

===

!

interface Vlan2

description Clients Vlan

ip address 2.2.2.2 255.255.255.0 secondary

ip address 1.1.1.1 255.255.255.0

no ip redirects

ip policy route-map OutToBGP

!

interface Vlan3

description To-BGP-Link1

ip address 10.10.10.2 255.255.255.252

!

interface Vlan4

description To-BGP-Link2

ip address 10.10.10.6 255.255.255.252

!

access-list 10 permit 1.1.1.1 0.0.0.255

access-list 11 permit 2.2.2.2 0.0.0.255

!

route-map OutToBGP permit 10

description NextHop is Link1 Vlan3

match ip address 10

set ip next-hop 10.10.10.1

!

route-map OutToBGP permit 11

description NextHop is Link2 Vlan4

match ip address 11

set ip next-hop 10.10.10.5

!

===

 

Таким образом, Unnumbered исключает PBR. Пробовал вешать policy на интерфейс, с которого выгребается Unnumbered (loopback0), делать его в виде Vlan (на поднятом Ethernet и-фейсе), ничего не помогает. Собственно говоря сижу и думаю, это конец использованию PBR? :))) Или есть еще трюки?

 

p.s. ios = cat4500e-entservicesk9-mz.122-54.SG.bin

Edited by tartila

Share this post


Link to post
Share on other sites

похороните эту затею. вам кошка в открытую варнинг дала, а вы лбом в бетонную стену ломитесь.

Share this post


Link to post
Share on other sites

похороните эту затею. вам кошка в открытую варнинг дала, а вы лбом в бетонную стену ломитесь.

 

Разобрался! ;))) Ларчик просто открывался, я по привычке всегда пишу Null-роутинг, чтобы отсечь bounce, так вот еще к обоим конфигам дополнение:

 

ip route 1.1.1.1 255.255.255.0 Null0

ip route 2.2.2.2 255.255.255.0 Null0

 

В первом случае оно почему то дало такой эффект, что не работал PBR. Убрал и все заработало. ;)

Share this post


Link to post
Share on other sites

гениально )) особенно при наличии не полного конфига ), а варнинги - это просто варнинги и к PBR никак не относятся.

Кстати, роут в Null0 повышает загрузку ЦП

Share this post


Link to post
Share on other sites

Роут Null0 не всегда повышает загрузку ЦПУ, а в некоторых случаях как раз играет роль защиты от закольцовки трафика. Например роутер отвечает за сеть 192.168.1.1/24, логично на нем сделать маршрут в Null0 для 192.168.0.0/16, чтобы все остальное не уходило обратно на дефолт.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this