Jump to content
Калькуляторы

Cisco 6500 не пингуется комп.... ((

Здравствуйте.

Разъясните пожалуйста следующую ситуацию:

Есть С6500 с 48 FastEthernet/IEEE 802.3 interface к данной плате подключен компьютер с IP 192.168.0.1

На самой С6500 поднят vlan с ip 192.168.0.254

Так вот если на компьютере с 0.1 не прописан шлюз 0.254 то циска не пингует 0.1

Если на компьютере указать шлюз 0.254 тогда циска начинает пинговать 0.1

Почему так происходит?

Share this post


Link to post
Share on other sites

Я думаю ФАЕРВОЛЛ!

Share this post


Link to post
Share on other sites

show run

 

Оставил то что нужно... все лишнее удолил.

 

Router#sh run

Building configuration...

 

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service counters max age 10

!

hostname Router

!

boot system flash slot0:c6sup22-ps-mz.121-26.E6.bin

!

ip subnet-zero

!

!

!

mls flow ip destination

mls flow ipx destination

mls qos

!

spanning-tree mode pvst

!

redundancy

mode rpr-plus

main-cpu

auto-sync running-config

auto-sync standard

!

!

!

interface Loopback1

no ip address

 

!

interface FastEthernet5/1

description komp

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,100

switchport mode trunk

!

 

interface Vlan1

ip address 192.168.0.254 255.255.255.0 secondary

ip address 172.16.1.3 255.255.255.248

!

interface Vlan100

ip address 10.10.10.254 255.255.255.0

!

router isis

!

 

line con 0

line vty 0 4

login local

!

ntp master

Share this post


Link to post
Share on other sites

на компе маска какая?

netstat -rn чего пишет?

Share this post


Link to post
Share on other sites

на компе маска какая?

netstat -rn чего пишет?

 

на компе маска 255.255.255.0

 

Возможно что нужно на циске включить опцию которая якобы слушала или проверяла широковещательные запросы... или что то в этом роде... тоесть работал ка Switch?

У меня такое ощущени е что он работает как маршрутизатор... или что то в этом роде...

Share this post


Link to post
Share on other sites

с компа - вывод netstat -rn, arp -a

с каталиста - show ip arp 192.168.0.1

Share this post


Link to post
Share on other sites

с компа - вывод netstat -rn, arp -a

с каталиста - show ip arp 192.168.0.1

 

Router#show ip arp 192.168.0.101

Protocol Address Age (min) Hardware Addr Type Interface

Internet 192.168.0.101 0 485b.39ac.b2dd ARPA Vlan1

Router#

 

___________________________________________________________________________

 

 

C:\Documents and Settings\a>netstat -rn

 

Таблица маршрутов

===========================================================================

Список интерфейсов

0x1 ........................... MS TCP Loopback interface

0x2 ...48 5b 39 ac b2 dd ...... Realtek PCIe GBE Family Controller - ╠шэшяюЁЄ яы

рэшЁют∙шър яръхЄют

===========================================================================

===========================================================================

Активные маршруты:

Сетевой адрес Маска сети Адрес шлюза Интерфейс Метрика

0.0.0.0 0.0.0.0 192.168.0.1 192.168.0.101 10

127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1

192.168.0.0 255.255.255.0 192.168.0.101 192.168.0.101 10

192.168.0.101 255.255.255.255 127.0.0.1 127.0.0.1 10

192.168.0.255 255.255.255.255 192.168.0.101 192.168.0.101 10

224.0.0.0 240.0.0.0 192.168.0.101 192.168.0.101 10

255.255.255.255 255.255.255.255 192.168.0.101 192.168.0.101 1

Основной шлюз: 192.168.0.1

===========================================================================

Постоянные маршруты:

Отсутствует

 

C:\Documents and Settings\a>arp -a

 

Интерфейс: 192.168.0.101 --- 0x2

Адрес IP Физический адрес Тип

192.168.0.1 00-18-f3-32-07-4e динамический

C:\Documents and Settings\a>

 

Из этого всего видно, что у циски есть мак адрес компьютера... а вот у компьютера мак адрес циски отсутсвует... хотя циска и компьютер находятся в одной сети и в одном vlan. (то что у компьютера стоит шлюз 192.168.0.1 - это я осазнаю и также осознаю что на эхо запросы и ответы между cisco и компьютером влиять не должно).

Получается что циска не транслирует в сеть свой ARP ???

 

Кстати при таком раскладе компьютер пингует Циску а вот циска нет.

Edited by smartkz

Share this post


Link to post
Share on other sites

interface Vlan1

ip address 192.168.0.254 255.255.255.0 secondary

ip address 172.16.1.3 255.255.255.248

!

у вас адрес 192.168.0.254 настроен как secondary

попробуйте убрать шлюз на компьютере, и пропинговать его c cisco вот так:

ping 192.168.0.1 source 192.168.0.254 

или прописать адрес 192.168.0.254 на vlan1 как primary

или, как правильно говорит GFORGX, wireshark вам в помощь

Edited by C@T

Share this post


Link to post
Share on other sites

Все верно.

Cisco будет пинговать с основного адреса, а не секондари.

Пакет на хосте не найдет дорогу обратно и будет там убит.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this