Jump to content
Калькуляторы

прозрачный cisco роутер

Всем привет.

Есть вопрос по поводу "прозрачного маршрутизатора", на данный момент есть около 10 офисов, офисы собираюсь переводить на MPLS. Перевод будет происходить не сразу, а по несколько офисов

вот схема сети

router.gif

нужно настроить cisco 2801 так что бы было видно сети котрые к ней подключены. делал на этой циске НАТ , но из-за НАТа тз основной сети не вижу сети которые висят за НАТом

вот конфиг циски с натом

Building configuration... 

Current configuration : 1293 bytes 
! 
version 12.3 
service timestamps debug datetime msec 
service timestamps log datetime msec 
service password-encryption 
! 
hostname test 
! 
boot-start-marker 
boot-end-marker 
! 
logging buffered 4096 debugging 
enable secret 5 *** 
! 
username support password 7 *** 
no aaa new-model 
ip subnet-zero 
! 
! 
! 
! 
interface FastEthernet0/0 
description office lan 
ip address 10.xx.xx.5 255.255.255.0 
ip nat outside 
duplex auto 
speed auto 
! 
interface FastEthernet0/1 
description to mpls 
ip address 172.0.0.1 255.255.255.0 
ip nat inside 
duplex auto 
ip ospf network broadcast 
logging event subif-link-status 
speed auto 
! 
ip default-gateway 10.xx.xx.1 
ip nat inside source list 101 interface FastEthernet0/0 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 10.xx.xx.1 
ip http server 
no ip http secure-server 
! 
access-list 101 permit ip any any 
! 
router ospf 10 
router-id 1.0.0.1 
log-adjacency-changes 
network 10.58.0.0 0.1.255.255 area 0 
network 172.0.0.0 0.0.0.255 area 0 
! 
line con 0 
login local 
line aux 0 
line vty 0 4 
login local 
! 
! 
! 
end

помогите правильно настроить!

Share this post


Link to post
Share on other sites

Делайте L2 тунелирование, или бриджевание, что синоним.

Share this post


Link to post
Share on other sites
Делайте L2 тунелирование, или бриджевание, что синоним.
а это как? не подскажите, а то я ниразу не сталкивалс с таким.

 

Share this post


Link to post
Share on other sites

Если честно, ничерта не понял, что нужно. Из слов "прозрачный роутер" думается, что ТС нужен обычный бридж, но не понятно, каким тут боком MPLS, а формулировка "нужно настроить..." ввела в когнитивный диссонанс.

Share this post


Link to post
Share on other sites

Попытался вчитаться ещё раз, 2801 не видел, но, видимо, автору нужно:

 

int Fa0/0
switchport mode access
int Fa0/1
switchport mode access

Share this post


Link to post
Share on other sites
Попытался вчитаться ещё раз, 2801 не видел, но, видимо, автору нужно:

 

int Fa0/0
switchport mode access
int Fa0/1
switchport mode access

вы картинку видели?))

если делать switchport mode access то мне нат надо убрать?

могу еще раз объяснить:

задача объеденить 2 сети, если смотреть картинку http://dl.dropbox.com/u/5029575/router.gif то сеть справа надо объеденить с сетью слева, через существующую офисную сеть.

В сети слева настроин ospf в нее будут переносится офисы справа (будут меняться настройки итд).

вопрос такой как объеденить 2 сети, на 2801 НАТ неподходит,насчет switchport mode access не знаю,надо пробовать.

 

 

Share this post


Link to post
Share on other sites

TranceMaker

схема не читабельна, описание непонятное.

 

перефразируйте вопрос с подробным описание что где как

какие подсети, что во что включино, какое железо, какие настройки.....

 

и только потом спрашивайте

 

зы по вашей схеме вам нужно везде влан 500 (или влан 200) прокинуть и все..

Edited by mukca

Share this post


Link to post
Share on other sites
TranceMaker

схема не читабельна, описание непонятное.

 

перефразируйте вопрос с подробным описание что где как

какие подсети, что во что включино, какое железо, какие настройки.....

 

и только потом спрашивайте

 

зы по вашей схеме вам нужно везде влан 500 (или влан 200) прокинуть и все..

дело в том что мы сами вланы прокидываем только на cisco 3825 через вирутуальные интерфейсы(на схеме справа). - от них мы отказываемся и переводим сеть на OSPF. Соответственно офисы которые подключены к 3825 я хочу переключить на 2801.

Провайдеру говорим чтоб они все офисы перекинули допустим в влан 500 (на схеме слева) , они через ospf будут вещать в сеть маршруты. 2801 нужна для того чтобы офисы которые мы переводим на ospf (все сразу перевести нельзя) могли обмениваться траффиком с офисами справа.

как еще объяснить незнаю. Я еще новичок в этом.

 

upd. все что подключено к 2801 оно работает через нат, но из сети которая справа из-за ната не видно сеть которая слева.

Edited by TranceMaker

Share this post


Link to post
Share on other sites

Начну с начала и попробую объяснить подробней чего я хочу :)

есть сеть в которой каждый офис имеет свой vlan, в каждом офисе он разный. Все vlanы падают на cisco 3825.

Для обменя трафиком между офисами трафик всегда проходит через 3825 и например уходит в другой офис.

в нешний порт у 3825 - trunk , без ip. все офисы в конфиге его выглядят так

interface GigabitEthernet0/1.13
description office name
encapsulation dot1Q 578
ip address 172.17.10.49 255.255.255.252
ip nbar protocol-discovery
no cdp enable

внутренний порт соеденен с сетью центрального офиса и имеет ип 10.58.0.1

вот картинка

1-1.gif

это я рассказал по первой картинке,там эта сеть расположена справа(назавем ее основной сетью).

 

поехали далее

к основной сети нам нужно подключить дополнительную у которой будет 1 влан на все офисы и в качестве протокола маршрутизации будет OSPF для свобоного обмена трафиком между офисом минуя центральную циску как на первой схеме. Все офисы из основной схемы буду переводить на OSPF

схема 2

 

2-1.gif

cisco 2801 включена в тоже сеть что и 3825.

задача:

обеспечить обмен трафиком между цисками 2801 и 3825 через центральных офис.

т.к они обе включены в сеть центрального офиса.

что у меня не получилось:

на 2801 я поднял нат, сеть которую эта циска держит - спокойно ходит по сети центрального офиса и обменивается трафиком только в односторнним порядке

тоесть из сети цетрального офиса и сети которую держит 3825 нельзя попасть в сеть 2801 потому что на 2801 весит нат.(конфиг в первом посте)

вопрос:

как обеспечить свободный проход трафика из ценртального офиса и сети циски 3825 в сеть которую держит 2801.

я так думаю что от ната надо отказаться, но как это сделать я не знаю. очень прошу вашей помощи.

Edited by TranceMaker

Share this post


Link to post
Share on other sites

имхо ясности чтото не внесло в то что вы хотите сделать

 

Правильная постановка задачи - половина решения

 

протокола маршрутизации будет OSPF для свобоного обмена трафиком между офисом минуя центральную циску как на первой схеме.
между какими железяками???

(OSPF (англ. Open Shortest Path First) — протокол динамической маршрутизации, основанный на технологии отслеживания состояния канала (link-state technology) и использующий для нахождения кратчайшего пути Алгоритм Дейкстры (Dijkstra’s algorithm).

как вы собираетесь его использовать между клиентскими компами в сети. если я правильно понял, ну неясно где вы хотите его использовать)

 

куда подключены 2801 и 3825, в какую железяку/??

или сразу друг в друга включены/??

какое железо включено в 2801 и в 3825

какое устройство является маршрутизатором для сети 10.58.0.0 ???

какие функции на себе несут маршрутизаторы 2801 и 3825?? (для чего они в одном офисе и в другом??? через них работает интернет или они еще куда то конектятся?? )

сети офисов соединяются через канал какова то третьего провайдера или полностью это ваш канал/?

если канал провайдера какие нибуть есть ограничения??

 

ps использовать в локальных сетях можно 172.16.0.0/16, а 172.0.0.0 и 172.17.16.0 сюда явно не попадает

 

pss если выкинуть все лишнее вам нужен 1 L3 свитч с поддержкой IP Routing, до него доводим все вланы, в них делаем интерфейсы и вуаля - вся сеточка между собой общается

Edited by mukca

Share this post


Link to post
Share on other sites
имхо ясности чтото не внесло в то что вы хотите сделать

 

Правильная постановка задачи - половина решения

 

протокола маршрутизации будет OSPF для свобоного обмена трафиком между офисом минуя центральную циску как на первой схеме.
между какими железяками???

(OSPF (англ. Open Shortest Path First) — протокол динамической маршрутизации, основанный на технологии отслеживания состояния канала (link-state technology) и использующий для нахождения кратчайшего пути Алгоритм Дейкстры (Dijkstra’s algorithm).

как вы собираетесь его использовать между клиентскими компами в сети. если я правильно понял, ну неясно где вы хотите его использовать)

 

куда подключены 2801 и 3825, в какую железяку/??

или сразу друг в друга включены/??

какое железо включено в 2801 и в 3825

какое устройство является маршрутизатором для сети 10.58.0.0 ???

какие функции на себе несут маршрутизаторы 2801 и 3825?? (для чего они в одном офисе и в другом??? через них работает интернет или они еще куда то конектятся?? )

сети офисов соединяются через канал какова то третьего провайдера или полностью это ваш канал/?

если канал провайдера какие нибуть есть ограничения??

 

ps использовать в локальных сетях можно 172.16.0.0/16, а 172.0.0.0 и 172.17.16.0 сюда явно не попадает

 

pss если выкинуть все лишнее вам нужен 1 L3 свитч с поддержкой IP Routing, до него доводим все вланы, в них делаем интерфейсы и вуаля - вся сеточка между собой общается

1) ospf я на него буду перодить останые офисы в которых вланы пробрасываются в 3825. сооветственно приход к одному влану и изменению схемы включения 3825 у которого прот который смотрит в провайдера работает как транк -> мы отказывается от транка делаем везде 1 влан и в нем делаем ospf

2) они воткнуты в свитч 3750

3) 3825 является маршрутизатором для сети 10.58.0.0

4) 2801 будет работать для оспф, 3825 сейчас работает на вланах,но после будет тоже ospf. они физически находятся в одном офисе потому что мы потихоньку перетаскиваем офисы на ospf для организации mpls. 2801 я ставлю как вспомогательный роутер для того что бы с 3825 убирать вланы по одному и переность их на 2801.

5) провайдер у нас один, канал полность наш ограничений нет. провайдер нам дает дополнительный порт для того что бы мы отказались от разных вланов и перешли на единый что позволит нам сделать mpls.

pss если выкинуть все лишнее вам нужен 1 L3 свитч с поддержкой IP Routing, до него доводим все вланы, в них делаем интерфейсы и вуаля - вся сеточка между собой общается
у нас так неполучиться потому что провайдер на строне любого офиса на порту прописывает влан который пробрасывает в центральный офис на 3825.

повторюсь, от такой схемы мы отказывается и вводим ospf, для этого я включаю 2801 одним портом в провайдерский свитч на который я буду переводить офисы , 2м портом я включась в ту сеть где 3825. Мне нужно настроить мост между 2801 и сетью где 3825.

Edited by TranceMaker

Share this post


Link to post
Share on other sites

Я вот тоже прочитал и ничего не понял. Предлагаю отвлечься от производителей, моделей и сформулировать задачу в простых терминах. То что я понял:

1. Есть центральный офис

2. Есть филиалы

3. Филиалы должны "видеть" центральный офис и наоборот

4. Филиалы должны "видеть" друг друга

5. в центральном офисе используется IP подсеть 10.xx.xx.0/24 (будем считать что xx.xx очень секретная информация :) )

6. Каналы арендуются у оператора(ов) связи.

7. Точки подключения делятся на 2 типа

7.1 На каждую сво VLAN

7.2 Все в куче в одном VLAN

8. Все VLAN оператор(ы) приводят в центральный офис

Вот собственно все что я понял.

 

Задача - собрать и настроить схему на существующем оборудовании.

Возможно я чего-то не понимаю но задача очень простая. Берется один из маршрутизаторов, все VLAN собираются на его сабинтерфейсах. Он является шлюзом по умолчанию для всех остальных. Если кто-то (в одном VLAN) должен видеть другие филиалы напрямую, то поднимаем в этом сегменте протокол динамической маршрутизации. Если вообще не хочется статических маршрутов писать, то делаем динамическую маршрутизацию на всей сети.

Теперь вопрос - а в чем собственно у топикстартера проблема?

Share this post


Link to post
Share on other sites
у нас так неполучиться потому что провайдер на строне любого офиса на порту прописывает влан который пробрасывает в центральный офис на 3825.
а что мешает выкинуть нафиг роутеры 2801/3825 включить все с циску 3750 на ней сделать интерфейсы в каждом влане и включить ip routing????

 

Мне нужно настроить мост между 2801 и сетью где 3825.
какой мост вы о чем???

просто пускаете туда влан с 3750 и все..

 

зы я так и непонял где вы собираетесь использоватсья ospf - это не DHCP/ ospf протокол который позволяет обмениваться между роутерами информацией о маршрутах, то етсь динамически строить таблицу ip маршрутов

 

я как понял сейчас у вас етсь сеть:

 

офис (стоит свитч L2) - 2801 - 3750 - 3825 - офис (стоит свитч L2)

к 3750 также присоединение какой то офис

 

если провайдеры могут по своей сети покинуть ваш влан предложение выкинуть нафиг 2801 и 3825 все включить в центральную циску и настроить маршрутизацию между вланами...

если есть необходимость брать интернет от провайдера.. то взять какой нибуть из маршрутизаторов и с 3750 пустить на него ддва порта с разными влан. один влан который идет от провайдера а другой влан с интерфейсом в локальной сети

 

зы вы или слишком усложняете себе жизнь или не можете понять чего хотите...

 

 

Edited by mukca

Share this post


Link to post
Share on other sites

надо купить ASR9000, желательно как можно больше.

на втором-третьем бандле оно самоорганизуется и заработает самостоятельно :)

 

Share this post


Link to post
Share on other sites
у нас так неполучиться потому что провайдер на строне любого офиса на порту прописывает влан который пробрасывает в центральный офис на 3825.
а что мешает выкинуть нафиг роутеры 2801/3825 включить все с циску 3750 на ней сделать интерфейсы в каждом влане и включить ip routing????

 

Мне нужно настроить мост между 2801 и сетью где 3825.
какой мост вы о чем???

просто пускаете туда влан с 3750 и все..

 

зы я так и непонял где вы собираетесь использоватсья ospf - это не DHCP/ ospf протокол который позволяет обмениваться между роутерами информацией о маршрутах, то етсь динамически строить таблицу ip маршрутов

 

я как понял сейчас у вас етсь сеть:

 

офис (стоит свитч L2) - 2801 - 3750 - 3825 - офис (стоит свитч L2)

к 3750 также присоединение какой то офис

 

если провайдеры могут по своей сети покинуть ваш влан предложение выкинуть нафиг 2801 и 3825 все включить в центральную циску и настроить маршрутизацию между вланами...

если есть необходимость брать интернет от провайдера.. то взять какой нибуть из маршрутизаторов и с 3750 пустить на него ддва порта с разными влан. один влан который идет от провайдера а другой влан с интерфейсом в локальной сети

 

зы вы или слишком усложняете себе жизнь или не можете понять чего хотите...

сеть провайдера она закрытая, провайдер дает нам канал и мы в нем делаем что хотим, из инета этот какнал не видно. инет мы берем из другова канала по прокси.

у меня цель такая!

в офисную сеть где уже работает 3825 на котрой построена вся сеть!

мне тупо надо чтобы в том свиче где уже включена 3825 включить 2801

с 3825 мы отключаем по одному влану и подлючаем их к 2801 по оспф (да для динамиеской маршрутизации)

мне надо чтобы приходящий траифк на 2801 мог нормально ходить в инет и брать почту через офисную сеть где уже работает 3825(3825 используется как шлюз чтобы трафик ходил в разные офисы)

тоесть тупо маршрутизировать трафик в офисную сеть и ходять в другие офисы через 3825.

как это сделать?

п.с провайдеры переведут все офисы в 1 влан ( или будут переводить по одному офису)

п.с2 как внутри локалки прокинуть влан от провайдера?

Edited by TranceMaker

Share this post


Link to post
Share on other sites

отключите для начала нат на 2801

Share this post


Link to post
Share on other sites

отключите для начала нат на 2801

нат давно отключен. не работает оно.

Share this post


Link to post
Share on other sites
с 3825 мы отключаем по одному влану и подлючаем их к 2801 по оспф (да для динамиеской маршрутизации)
эээ это как?? для работы ospf нужно 2 устройства (маршрутизатора к примеру) которые были бы соединены 1 интерфейсом

 

п.с2 как внутри локалки прокинуть влан от провайдера?
порт на свитче куда включен провод провайдер перевести в какойнибуть влан и дальше уже прокидывать..

 

зы вот теперь дабы дальше не запутываться... можете про все что было предложено забыть и заново рассказать как у вас построена сеть с учетом всего что у вас допытались или предложили..

зы и все таки лучше расскажите по подробнее какое еще железо стоит в офисах. так как может можно сделать еще проще чем думаете..

Edited by mukca

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this