Jump to content
Калькуляторы

ASR 1002 Route map

Добрый день! Со сменой платформы C7301 на ASR 1002 появилась проблема с route-map.

На 7301 конфиг

 

interface Virtual-Template1

mtu 1492

ip unnumbered GigabitEthernet0/2.12

ip access-group pppoe_session in

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip flow egress

ip route-cache policy

no ip route-cache cef

ip policy route-map gwhop

ppp max-bad-auth 3

ppp reliable-link

ppp authentication chap

ppp pap refuse

 

 

К пакетам из нужных мне сетей применялся ip policy route-map gwhop. Остальные все пакеты шли по дефолтному маршруту.

На платформе ASR 1002 на interface Virtual-Template нет команды ip policy route-map. Тех. поддержка циски подтвердила что на данной платформе ip policy route-map не включен на interface Virtual-Template из-за каких то проблем с зависанием циски при его включении.

 

Сейчас стоит задача сети 10.X.0.0 послать на один шлюз, а сети 10.Y.0.0 на другой. А дефолтный маршрут соответственно только один. Каким образом можно решить эту задачу на циске без применения route-map ??? Получается мне необходима маршрутизация по источнику.

Share this post


Link to post
Share on other sites
VRF?

дак вот сейчас у меня на ASR еще BGP поднято и чтобы не пересекалась маршрутизация, PPPoE помещено в VRF. кусок конфига:

ip vrf pppoe

rd 2:2

 

interface Virtual-Template1

mtu 1492

ip vrf forwarding pppoe

 

interface GigabitEthernet0/0/0.3001

encapsulation dot1Q 3001

no ip redirects

no ip unreachables

no ip proxy-arp

pppoe enable group global

pppoe max-sessions 1000

 

ip route vrf pppoe 0.0.0.0 0.0.0.0 X.X.X.X

 

 

В данном конфиге все из туннелей PPPoE летят по дефолтному маршруту X.X.X.X. А как с помощью VFR сделать чтобы нужные мне пакеты летели по другому маршруту?

 

 

 

interface GigabitEthernet0/0/0.3001 - это интерфейс откуда прилетают клиенты.

 

 

Share this post


Link to post
Share on other sites
VRF?

дак вот сейчас у меня на ASR еще BGP поднято и чтобы не пересекалась маршрутизация, PPPoE помещено в VRF. кусок конфига:

ip vrf pppoe

rd 2:2

 

interface Virtual-Template1

mtu 1492

ip vrf forwarding pppoe

 

interface GigabitEthernet0/0/0.3001

encapsulation dot1Q 3001

no ip redirects

no ip unreachables

no ip proxy-arp

pppoe enable group global

pppoe max-sessions 1000

 

ip route vrf pppoe 0.0.0.0 0.0.0.0 X.X.X.X

 

 

В данном конфиге все из туннелей PPPoE летят по дефолтному маршруту X.X.X.X. А как с помощью VFR сделать чтобы нужные мне пакеты летели по другому маршруту?

 

 

 

interface GigabitEthernet0/0/0.3001 - это интерфейс откуда прилетают клиенты.

Никто не знает? :((

Share this post


Link to post
Share on other sites

evg_b

 

насколько я помню, АСРам не доступны роутмапы...

Share this post


Link to post
Share on other sites

Если используете для аутентификации RADIUS, то можно передавать для каждого абонента атрибут с именем VRF и рассаживать абонентов по VRF в зависимости от того, куда должен уходить их трафик.

Share this post


Link to post
Share on other sites

Если используете для аутентификации RADIUS, то можно передавать для каждого абонента атрибут с именем VRF и рассаживать абонентов по VRF в зависимости от того, куда должен уходить их трафик.

Т.е получается создаю еще один VRF в него сажаю мой второй шлюз и тем абонентам которых хочу послать на этот VRF в радиус атрибутах указываю это?

Share this post


Link to post
Share on other sites

Именно так.

Share this post


Link to post
Share on other sites

evg_bradius'ом не пробовали вешать route-map на Virtual-Access'ы?

 

lcp:interface-config=ip policy route-map test

Share this post


Link to post
Share on other sites
evg_bradius'ом не пробовали вешать route-map на Virtual-Access'ы?

 

lcp:interface-config=ip policy route-map test

 

чего то не хочет. 691 или 619 вылетает при добавлении параметра lcp:interface-config=ip policy route-map test

в дебаге радиуса на циске вижу что приходит параметр

Apr 30 11:57:52 192.168.3.40 8058475: .Apr 30 11:49:42.163: RADIUS: Cisco AVpair [1] 46 "lcp:interface-config=ip policy route-map test"

Apr 30 11:57:52 192.168.3.40 8058476: .Apr 30 11:49:42.164: RADIUS(000F21D8): Received from id 1645/238

Apr 30 11:57:52 192.168.3.40 8058477: .Apr 30 11:49:42.173: %FMANRP_ESS-4-WRNPARAM_XU: ESS Get Segment by EVSI: EVSI already deleted!: ess_evsi_dpidb/EVSI (0x0 / 1795)

Apr 30 11:57:52 192.168.3.40 8058478: -Traceback= 1#b9954263fb38baa86d672c99f2dcd955 :10000000+B8DB7C :10000000+B8DF00 :10000000+3541684 :10000000+35521D4 :10000000+34F8DF8 :10000000+10

 

 

route-map test на циске создан

 

почему не проходит аутентификация?

Пробовал послать с радиуса sub-qos-policy-in=test_in - полисер на зарезку скорости - все нормально работает

Share this post


Link to post
Share on other sites
lcp:interface-config=ip policy route-map test

ip:sub-qos-policy-in=test_in

разницу выделил.

Share this post


Link to post
Share on other sites
lcp:interface-config=ip policy route-map test

ip:sub-qos-policy-in=test_in

разницу выделил.

на циске не хватало параметра

aaa policy interface-config allow-subinterface

 

все заработало. Policy map стал применяться к туннелям пппое.

Всем спасибо

Share this post


Link to post
Share on other sites
lcp:interface-config=ip policy route-map test

ip:sub-qos-policy-in=test_in

разницу выделил.

на циске не хватало параметра

aaa policy interface-config allow-subinterface

 

все заработало. Policy map стал применяться к туннелям пппое.

Всем спасибо

Вышел иос 2.6.1. И вместе с ним "радостная новость". Теперь уже и с помощью радиуса нельзя привязать Policy map к VA.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this