Jump to content
Калькуляторы

Cisco, Shaping...

Имеем кошку 7120, работает Интернет-роутером. Раздает инет юзерам по IP (другой авторизации не предусмотрено, IP прибит на портах коммутаторов доступа).

Стоит задача Шейпить юзеров по нескольким заданным скоростям (256,512,1024... kbit)

Юзеров 300+ (online 100+). Создавать на каждого зверя access-list - не катит (на всех просто access-listов не хватит). Чем и как можно обойти эту проблему?

Гугление и поиск по форуму окромя разнообразного флейма на тему linux vs cisco не принесло.

 

Как шейпить? Ставить отдельный сервачок для шейпинга - не прикольно.

Share this post


Link to post
Share on other sites

Не встречал такого зверя... На каждого пользователя подынтерфейс с прибитым шейпером/полисером не спасут?

Share this post


Link to post
Share on other sites

Как на каждого зверя сделать подинтерфейс, если юзеры сидят в нескольких подсетях /24 ? И киска от юзеров отделена L3 свитчом?

Share this post


Link to post
Share on other sites

На этой железке значит никак, если ACL на всех не хватит.

Share this post


Link to post
Share on other sites
На этой железке значит никак, если ACL на всех не хватит.

Если не ошибаюсь на любой железке номера ACLек от 1 до 100 (не extended которые)... Или я ошибаюсь ?

Share this post


Link to post
Share on other sites
На этой железке значит никак, если ACL на всех не хватит.

Если не ошибаюсь на любой железке номера ACLек от 1 до 100 (не extended которые)... Или я ошибаюсь ?

Router(config)#access-list ?

<1-99> IP standard access list

<100-199> IP extended access list

<1000-1099> IPX SAP access list

<1100-1199> Extended 48-bit MAC address access list

<1200-1299> IPX summary address access list

<1300-1999> IP standard access list (expanded range)

...

 

99+700?

 

Router(config)#ip access-list standard ?

<1-99> Standard IP access-list number

<1300-1999> Standard IP access-list number (expanded range)

WORD Access-list name

Share this post


Link to post
Share on other sites

Там ещё и NAMED ACLs есть, но смысл?

policy-map может содержать не более 256 class-map...

Share this post


Link to post
Share on other sites

Хм. ну допустим, буду вешать на интерфейс кучу traffic-shape group 1300 64000

Или это не правильный подход? Как вообще правильно (чтобы циска не сильно напрягалась) шейпить?

Share this post


Link to post
Share on other sites
Хм. ну допустим, буду вешать на интерфейс кучу traffic-shape group 1300 64000

Или это не правильный подход? Как вообще правильно (чтобы циска не сильно напрягалась) шейпить?

шейпить на циске дорого.

а если массово полисить то либо virtual-access с ppp, либо isg

Share this post


Link to post
Share on other sites
шейпить на циске дорого.

а если массово полисить то либо virtual-access с ppp, либо isg

Дорого это ысмысле циска мало шейпов сможет прожувать?

virtual-access не катит, а isg в нашей железке и не пахнет...

Share this post


Link to post
Share on other sites
шейпить на циске дорого.

а если массово полисить то либо virtual-access с ppp, либо isg

На софтовой - понятно. На хардовой-то (ESR например, или ASR) чем дорого?

Однако же в ISG только полисинг. :(

Share this post


Link to post
Share on other sites
На софтовой - понятно. На хардовой-то (ESR например, или ASR) чем дорого?

Однако же в ISG только полисинг. :(

Как шейпит ESR не знаю, не пробовал, a ASR тоже софтовый.

Впрочем и то и другое само по себе тоже не дёшево.

Share this post


Link to post
Share on other sites
Там ещё и NAMED ACLs есть, но смысл?

policy-map может содержать не более 256 class-map...

 

ну и что что 256? рекурсию никто не отменял.

 

interface FastEthernet0/0.101

service-policy output unlim-out

 

policy-map unlim-out

class unlim-0

shape peak 256000

service-policy unlim-0

class unlim-1

shape peak 256000

service-policy unlim-1

class unlim-2

shape peak 256000

service-policy unlim-2

class unlim-3

shape peak 256000

service-policy unlim-3

class unlim-4

shape peak 256000

service-policy unlim-4

class unlim-5

shape peak 256000

service-policy unlim-5

class unlim-6

shape peak 256000

service-policy unlim-6

class 1-system

class unlim-7

shape peak 256000

service-policy unlim-7

class unlim-8

shape peak 256000

service-policy unlim-8

class unlim-9

shape peak 256000

service-policy unlim-9

class clients

class limited

class class-default

service-policy DropAll

!

policy-map unlim-6

class p430_XXX_YYY

bandwidth 16

class p840_XXX_YYY

bandwidth 16

class p834_XXX_YYY

bandwidth 16

class p848_XXX_YYY

bandwidth 16

class p847_XXX_YYY

bandwidth 16

class p155_XXX_YYY

bandwidth 16

class p422_XXX_YYY

bandwidth 16

class p564_XXX_YYY

bandwidth 16

class p389_XXX_YYY

bandwidth 16

class p515_XXX_YYY

bandwidth 16

class p18_XXX_YYY

bandwidth 16

class p283_XXX_YYY

bandwidth 16

class p732_XXX_YYY

bandwidth 16

class p589_XXX_YYY

bandwidth 16

class p852_XXX_YYY

bandwidth 16

class p725_XXX_YYY

bandwidth 16

 

ip access-list extended USERS-FOR-UNLIM-6

permit ip any host ZZZ.ZZZ.XXX.YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

 

ip access-list extended p185_XXX_YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

ip access-list extended p18_XXX_YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

ip access-list extended p456_XXX_YYY

permit ip any host ZZZ.ZZZ.XXX.YYY

 

class-map match-any unlim-7

match access-group name USERS-FOR-UNLIM-7

class-map match-any unlim-4

match access-group name USERS-FOR-UNLIM-4

class-map match-any unlim-5

match access-group name USERS-FOR-UNLIM-5

 

class-map match-any p675_XXX_YYY

match access-group name p675_XXX_YYY

class-map match-any p685_XXX_YYY

match access-group name p685_XXX_YYY

class-map match-any p769_XXX_YYY

match access-group name p769_XXX_YYY

 

 

Share this post


Link to post
Share on other sites
Там ещё и NAMED ACLs есть, но смысл?

policy-map может содержать не более 256 class-map...

 

ну и что что 256? рекурсию никто не отменял.

 

interface FastEthernet0/0.101

service-policy output unlim-out

 

policy-map unlim-out

class unlim-0

shape peak 256000

service-policy unlim-0

class unlim-1

....

 

Там вроде на очереди "bandwidth" и "priority" ограничение еще более сильное их всего 64 шт. на policy-map

 

только непонятно оно действует на родительскую policy-map со всеми потомками вместе или на каждую policy-map в отдельности ?

Edited by packetizer

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this