Jump to content
Калькуляторы

4550, dotq-tunnel, QoS

Может не работать режим dot1q-tunnel для приходящих кадров, с QoS != 0 ?

SoftWare Package Version 7.0.3.0(R0246.0139)

 

 

Покачто в качестве предположения только.

Share this post


Link to post
Share on other sites

может не работать если у вас арендованный канал и транзитный оператор имеет всякие хитрые правила (такие случаи реально бывали) по обработке трафика с dscp/8021p != 0 (диагностируется по счётчикам)

Share this post


Link to post
Share on other sites

Да мы сами оператор. состыковались с ростелекомом и через QinQ не проходят кадры в циску на соседнем порту того-же коммутатора. Вот даумаю какие могут быть причины.

Причем monitor показывает, что кадры от них приходят с не нулевым dot1p.

Share this post


Link to post
Share on other sites

причина может быть в несовпадающих ethertype (0x8100, 0x9100)

Share this post


Link to post
Share on other sites

Этот линк мы переткнули в ASR903 и без каких либо плясок с бубном все заработало. Ethertype не менял.

Пожалуй соберу стенд, попроверяю сам.

Share this post


Link to post
Share on other sites

@ShyLion Есть есть возможность, снимите дамп пакетов которые не матчатся и приложив 'sh run' оставьте обращение на support.nag.ru. Оперативно поможем.

Share this post


Link to post
Share on other sites
11:45:43.996169 1c:1d:86:9d:c9:bf > ff:ff:ff:ff:ff:ff, ethertype 802.1Q (0x8100), length 68: vlan 86, p 0, ethertype 802.1Q, vlan 738, p 0, ethertype ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 10.72.53.164 tell 10.72.53.163, length 46

это по другую сторону от порта

Interface Ethernet1/0/13
 speed-duplex force1g-full
 negotiation off
 mls qos queue wrr weight 1 2 3 0 5 6 7 8 
 lldp transmit optional tlv portDesc sysName sysDesc sysCap
 dot1q-tunnel enable
 switchport access vlan 86

Интересные дела...

Share this post


Link to post
Share on other sites

Сделали магические пасы с перевтыканием трансивера, выключения  интерфейса и его настроек и все завелось.

Share this post


Link to post
Share on other sites

Вобщем нашел причину:

 

switchport discard packet untag

С таким параметром dot1q-tunnel не работает.

 

Это баг или фича?

Share this post


Link to post
Share on other sites

@Aleksey Sonkin добрый день, покажите, пожалуйста, текущую конфигурацию порта здесь, или в тикете. Вероятно это все-таки не баг.

 

Если конфигурация осталась прежней:

 

Interface Ethernet1/0/13
 speed-duplex force1g-full
 negotiation off
 mls qos queue wrr weight 1 2 3 0 5 6 7 8 
 lldp transmit optional tlv portDesc sysName sysDesc sysCap
 dot1q-tunnel enable
 switchport access vlan 86

То в таком случае действительно нельзя использовать 'switchport discard packet untag', так как с точки зрения коммутатора кадры, попадающие в dotiq-tunnel являются нетегированными.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this