Jump to content
Калькуляторы

Cisco MP BGP route reflector

Прошу помощи.

Делаю лабу по L3 VPN, не могу разобраться почему  на PE нет  маршрутов от удаленного клиента, но при этом есть от другого PE?

PE1#sh ip ro vrf client



     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.0.0.0/30 is directly connected, FastEthernet0/0
B       10.0.0.0/24 [200/0] via 3.3.3.3, 00:28:10
O E2 192.168.1.0/24 [110/20] via 10.0.0.2, 00:48:37, FastEthernet0/0
PE1#
PE2>sh ip ro vrf client


     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B       10.0.0.0/30 [200/0] via 1.1.1.1, 00:38:54
C       10.0.0.0/24 is directly connected, FastEthernet0/0
O E2 192.168.2.0/24 [110/20] via 10.0.0.6, 00:57:56, FastEthernet0/0

 

Безымянный.png

PE1.txt

PE2.txt

P.txt

Share this post


Link to post
Share on other sites

Собственно переделал на простую схему CE-PE-P-PE-CE, без роутрефлектора, а проблема осталась. Что-то не так с OSPF ? Подскажите, уже голову сломал.

CE1 анонсирует 192.168.1.0/24, CE2 192.168.2.0/24. PE1 и PE2 соответственно их принимают в VRF "client" и должны передать друг другу через mp-BGP.

 

image.thumb.png.8f40cf5a60db14a2ce6eeff457e73c0d.png 

Проблема в том, что передаются только транспортные сети 10.0.0.0/30 и 10.0.0.4/30, вот например на PE1 приходит только 10.0.0.4/30:

PE1#sh ip route vrf client
...
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C        10.0.0.0/30 is directly connected, FastEthernet0/0
L        10.0.0.1/32 is directly connected, FastEthernet0/0
B        10.0.0.4/30 [200/0] via 3.3.3.3, 00:00:03
O E2  192.168.1.0/24 [110/20] via 10.0.0.2, 00:01:49, FastEthernet0/0

а на PE2 10.0.0.0/30:

PE2#sh ip route vrf client
...
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
B        10.0.0.0/30 [200/0] via 1.1.1.1, 00:04:34
C        10.0.0.4/30 is directly connected, FastEthernet0/0
L        10.0.0.5/32 is directly connected, FastEthernet0/0
O E2  192.168.2.0/24 [110/20] via 10.0.0.6, 00:06:20, FastEthernet0/0

 

конфиг PE1:


ip cef
!
ip vrf client
 rd 64500:1
 route-target export 64500:1
 route-target import 64500:1
!
!
!

!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 description to client
 ip vrf forwarding client
 ip address 10.0.0.1 255.255.255.252
 speed auto
 duplex auto
!
interface FastEthernet0/1
 description to core
 ip address 20.0.0.1 255.255.255.252
 speed auto
 duplex auto
 mpls ip
!
router ospf 2 vrf client
 redistribute bgp 64500 subnets
 network 10.0.0.0 0.0.0.7 area 0
!
router ospf 1
 router-id 1.1.1.1
 network 1.1.1.1 0.0.0.0 area 0
 network 20.0.0.0 0.0.0.7 area 0
!
router bgp 64500
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 64500
 neighbor 3.3.3.3 update-source Loopback0
 !
 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community both
 exit-address-family
 !
 address-family ipv4 vrf client
  redistribute connected
  redistribute ospf 2
 exit-address-family
!

конфиг PE2


ip cef
!
ip vrf client
 rd 64500:1
 route-target export 64500:1
 route-target import 64500:1
!

!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 description to client
 ip vrf forwarding client
 ip address 10.0.0.5 255.255.255.252
 speed auto
 duplex auto
!
interface FastEthernet0/1
 description to core
 ip address 20.0.0.5 255.255.255.252
 speed auto
 duplex auto
 mpls ip
!
router ospf 2 vrf client
 redistribute bgp 64500 subnets
 network 10.0.0.0 0.0.0.7 area 0
!
router ospf 1
 router-id 3.3.3.3
 network 3.3.3.3 0.0.0.0 area 0
 network 20.0.0.0 0.0.0.7 area 0
!
router bgp 64500
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 64500
 neighbor 1.1.1.1 update-source Loopback0
 !
 address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community both
 exit-address-family
 !
 address-family ipv4 vrf client
  redistribute connected
  redistribute ospf 2
 exit-address-family
!

 

Edited by kuterye
благодарю всех, кто откликнулся

Share this post


Link to post
Share on other sites

Немного не понятно в чем вообще проблема. Вы опишите понятным образом. Схема такая, анонсирую это, вижу это тут и не вижу там. Конфиги в 

код

заверните. И после этого можно ждать ответ.

Я бы вот посмотрел, но мне тупо лень разбиратья, что там в текстовичках и искать что там не огласилось

Share this post


Link to post
Share on other sites
6 часов назад, kuterye сказал:

...Делаю лабу по L3 VPN...

По обращению:

Лабораторные работы НАДО делать самому, а не "дядю" просить за Вас сделать. Такой "тухлый" специалист никому не нужен, зачем Вам учиться, если Вы всё равно станете потом никому не нужной "тухлятиной" ? Идите лучше сразу работать продавцом в Ашан.

 

Про Ваш вопрос:

Ни конфигов, ни постановки задачи, ни схемы маршрутизации, ни стройных мыслей, вообще НИЧЕГО! Вы что думаете, здесь передача "Что? Где? Когда?"? Команды пинг и трасерт знаете? Что выводят? С обеих сторон.

 

З.Ы.

Интересно, где так учат молодежь?

ЧИТАЙТЕ КНИЖКИ! УЧИТЕСЬ САМИ!

Share this post


Link to post
Share on other sites

OSPF External маршруты по умолчанию не редистрибьютятся в BGP. Нужно явно указывать, чтобы External маршруты передавались, а также указывать какие типы - только E1, только E2 или оба типа.

https://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/5242-bgp-ospf-redis.html
 

Share this post


Link to post
Share on other sites
46 минут назад, crank сказал:

OSPF External маршруты по умолчанию не редистрибьютятся в BGP. Нужно явно указывать, чтобы External маршруты передавались, а также указывать какие типы - только E1, только E2 или оба типа.

https://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/5242-bgp-ospf-redis.html
 

Спасибо тебе, добрый человек

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this