Jump to content
Калькуляторы

КАК ТАК Mikrotik не принимает от CISCO OSPF L2PT over кто нибудь спаривал ?

Имеем картину , Циска 3845 и Микротик CCR1016  , на  Cisco Mikrotik  настроен OSPF, поднял L2TP -PPTP Server на киске,  ip peers добавлено в OSPF.  Микротик поднимает L2TPСLient на киску. OSPF LSA на Микротике появляется таблица INSTANCE , Циска 1.177.177.24 , Миктик 1.177.177.20.  В Таблице OSPF ROUTES у Микротика добавлены маршруты но поля интерфейса пустое.  Соответсвенно на Микроитке IP Route ....> нет маршрутов  в таблице. Как решить этот трабл. Какие есть варианты ?. 

 

Edited by bg80211

Share this post


Link to post
Share on other sites

instance_4.thumb.jpg.30c2bb1681074d76c8e03b5740aa8a25.jpgФото

instance_1.jpg

instance_2.jpg 

 

 

1.177.177.20 Микротик, 1.177.177.24 CiSCO 3845, Остальные DebX86

instance_3.jpg

 

 

instance_3.jpg

Cisco 

 

router ospf 2
 router-id 1.177.177.24
 network 1.177.177.24 0.0.0.0 area 17
 network 4.175.1.0 0.0.0.255 area 17
 network 10.130.208.0 0.0.0.255 area 17
 network 10.130.209.0 0.0.0.255 area 17
 network 10.130.210.0 0.0.0.255 area 17
 network 155.10.0.0 0.0.0.255 area 17
 network 172.20.64.0 0.0.0.255 area 17
!
 

 

Cisco3845 #sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.177.177.20      0   FULL/  -        00:00:30    155.10.0.17     Virtual-Access3.1
1.10.10.49        1   FULL/DROTHER    00:00:31    4.175.1.49      GigabitEthernet0/0.175
1.177.177.222     1   FULL/DR         00:00:31    4.175.1.222     GigabitEthernet0/0.175

 

 

 

#sh ip ospf data

            OSPF Router with ID (1.177.177.24) (Process ID 2)

                Router Link States (Area 17)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.10.10.49      1.10.10.49      1214        0x80000651 0x0096A7 2
1.177.177.20    1.177.177.20    1022        0x80000034 0x001C86 3
1.177.177.24    1.177.177.24    885         0x8000002C 0x00D7DB 4
1.177.177.222   1.177.177.222   1224        0x80000374 0x0008C0 2

                Net Link States (Area 17)

Link ID         ADV Router      Age         Seq#       Checksum
4.175.1.222     1.177.177.222   1524        0x8000001D 0x0093C9

sh ip ospf int

Virtual-Access3.1 is up, line protocol is up
  Interface is unnumbered. Using address of Loopback1 (155.10.0.254), Area 17
  Process ID 2, Router ID 1.177.177.24, Network Type POINT_TO_POINT, Cost: 10
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           10        no          no            Base
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:01
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 4/4, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 1.177.177.20
  Suppress hello for 0 neighbor(s)
 

 


 

 

 

Edited by bg80211

Share this post


Link to post
Share on other sites

Покажите конфиги

/routing ospf network print 

/routing ospf interface print detail

 

Share this post


Link to post
Share on other sites
В 03.03.2019 в 09:49, bg80211 сказал:

Имеем картину , Циска 3845 и Микротик CCR1016  , на  Cisco Mikrotik  настроен OSPF, поднял L2TP -PPTP Server на киске,  ip peers добавлено в OSPF.  Микротик поднимает L2TPСLient на киску. OSPF LSA на Микротике появляется таблица INSTANCE , Циска 1.177.177.24 , Миктик 1.177.177.20.  В Таблице OSPF ROUTES у Микротика добавлены маршруты но поля интерфейса пустое.  Соответсвенно на Микроитке IP Route ....> нет маршрутов  в таблице. Как решить этот трабл. Какие есть варианты ?. 

 

 

юникастом настрой соседей

Share this post


Link to post
Share on other sites
15 часов назад, fractal сказал:

юникастом настрой соседей

type broadcast?. 

 

Share this post


Link to post
Share on other sites
20 часов назад, bg80211 сказал:

type broadcast?. 

 

pptp и l2tp это протоколы p2p, на cisco в interface Virtual-Template прописать  ip ospf network point-to-point, на микроте на порт l2tp выставить type  point-to-point

 

к примеру, накидал конфиг в gns3

 

Циска

aaa new-model
!
!
aaa authentication login default local
aaa authentication ppp default local
aaa authorization exec default local
aaa authorization network default local
!
aaa session-id common
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
vpdn enable
!
vpdn-group l2tp
 accept-dialin
  protocol l2tp
  virtual-template 1
 terminate-from hostname mikrotik
 lcp renegotiation on-mismatch
 l2tp tunnel password 0 12345
 ip pmtu
!
vpdn-group l2tpl2tp
! Default L2TP VPDN group
 accept-dialin
  protocol l2tp
  virtual-template 1
 no l2tp tunnel authentication
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username l2tp privilege 0 password 0 12345
username l2tp autocommand exit
!
!
ip tcp synwait-time 5
!
!
crypto isakmp policy 20
 encr 3des
 authentication pre-share
 group 2
 lifetime 3600
crypto isakmp key cisco address 0.0.0.0 0.0.0.0 no-xauth
crypto isakmp keepalive 3600
!
!
crypto ipsec transform-set l2tp esp-3des esp-sha-hmac
 mode transport
!
crypto dynamic-map l2tp_dmap 10
 set nat demux
 set transform-set l2tp
!
!
crypto map l2tp_map 10 ipsec-isakmp dynamic l2tp_dmap
!
!
!
!
interface Loopback0
 ip address 100.100.100.100 255.255.255.255
!
interface Loopback1
 ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.252
 duplex auto
 speed auto
 crypto map l2tp_map
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Virtual-Template1
 ip address 192.168.100.1 255.255.255.0
 ip mtu 1400
 ip ospf network point-to-point
 peer default ip address pool pool_l2tp
 no keepalive
 ppp encrypt mppe auto
 ppp authentication ms-chap-v2
!
router ospf 100
 router-id 100.100.100.100
 log-adjacency-changes
 redistribute connected subnets
 passive-interface default
 no passive-interface Virtual-Template1
 network 192.168.100.0 0.0.0.255 area 0.0.0.0
!
ip local pool pool_l2tp 192.168.100.10 192.168.100.20
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
!
!
end

Микрот

 

/interface bridge
add name=lo0
add name=lo1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=\
    aes-256-cbc,aes-192-cbc,aes-128-cbc,3des
/ppp profile
add name=l2tp
/interface l2tp-client
add allow=mschap2 connect-to=10.10.10.1 disabled=no ipsec-secret=cisco \
    max-mru=1500 max-mtu=1400 name=l2tp-out1 password=12345 profile=default \
    user=l2tp
/routing ospf instance
set [ find default=yes ] router-id=200.200.200.200
/ip address
add address=10.10.10.2/30 interface=ether5 network=10.10.10.0
add address=200.200.200.200 interface=lo0 network=200.200.200.200
add address=192.168.200.1/24 interface=lo1 network=192.168.200.0
/ip dhcp-client
add disabled=no interface=ether1
/routing ospf interface
add interface=l2tp-out1 network-type=point-to-point
/routing ospf network
add area=backbone network=192.168.200.0/24
add area=backbone network=192.168.100.0/24
/system package update
set channel=long-term

 

 

все работает, loopback пингаются с обеих сторон

Edited by fractal

Share this post


Link to post
Share on other sites

Пасибо !! , Зачет... Сегодня  пофиксю на киске.

Share this post


Link to post
Share on other sites
1 час назад, bg80211 сказал:

Пасибо !! , Зачет... Сегодня  пофиксю на киске.

Да не за что

Share this post


Link to post
Share on other sites

А в случае когда на циске исходный интерфейс unnumbered кому-нибудь удавалось добиться передачи маршрутов по osfp? Циска отдаёт в этом случае гейт с маской /32, в результате маршруты микротик получает но в таблицу маршрутизации не вставляет.

Share this post


Link to post
Share on other sites

@SinClaus У меня другая схема и вместо циски джун, но /32 маска с pppoe интересов прекрасно передается. Можно конфиг? 

Share this post


Link to post
Share on other sites

На циске, относящиеся к вопросу:

 

multilink bundle-name authenticated
vpdn enable

!

interface Loopback1
 ip address 172.31.1.1 255.255.255.0

!
vpdn-group L2TP
 ! Default L2TP VPDN group
 accept-dialin
  protocol l2tp
  virtual-template 1
 lcp renegotiation on-mismatch
 no l2tp tunnel authentication
 ip pmtu
 ip mtu adjust

!

interface Virtual-Template1
 ip unnumbered Loopback1
 ip nat inside
 ip virtual-reassembly in
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 7 094F471A1A0A
 peer ip address forced
 peer default ip address pool L2TP_POOL
 ppp authentication ms-chap-v2

!

ip local pool L2TP_POOL 172.31.1.10 172.31.1.250

!

на микротике

/interface l2tp-client
add allow=mschap2 connect-to=192.168.130.175 disabled=no max-mru=1465 max-mtu=1465 name=l2tp-out1 password=12345 user=ppp

 

/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1 router-id=20.20.20.3
/routing ospf network
add area=backbone network=20.20.20.0/24
add area=backbone network=172.20.20.0/24
add area=backbone network=172.31.1.0/24
add area=backbone network=10.1.2.0/24

 

В таком виде циска получает маршруты от микротиков, микротики показывают маршруты в запросе /routing ospf route pri, но за запрос /ip route pri нет ни одного из пула ospf.

Share this post


Link to post
Share on other sites

@SinClaus Эта подсеть локально на микротике прописана? 172.31.1.0/24  

Если нет то это как бы лишнее add area=backbone network=172.31.1.0/24

 

Чет я не совсем схему понял. Можете подробней расписать или нарисовать. 

Из того, что вы написали могу предположить, циско у вас центр к ней подключен микротик и вам нужно за миротиком выдать ip адреса из 172.31.1.0/24?

 

Share this post


Link to post
Share on other sites

Схема простейшая: циска в центре, к ней цепляются микротики. Отдают все свои локальные сети. 172.31.0.0/24 это как раз сеть которой они соединены. Цсковская ospf стандартная.

Share this post


Link to post
Share on other sites

@SinClaus Я вас понять не могу.

 

Выложите полностью конфиг с микротика. 

 

Как я понял у вас стоят микротик на нем есть IP допустим 172.31.1.33/24 и вы хотите на этот микротик отдать маршут  172.31.1.10/32 верно? 

 

 

Share this post


Link to post
Share on other sites

Могу и выложить, другое дело - не понимаю зачем отдавать в сеть её адреса. Здесь стенд, конфиг не мой, но стандарт в любой сети - на стороне общей сети имеем некие адреса, на стороне локальной сети имеем непересекающиеся адреса. Редистрибутим нужным клиентам адресоа локальной сети.

 

Микротик, текущий конфиг:

 

# oct/08/2019 16:08:25 by RouterOS 6.42.10
# software id = U0GI-S4L2
#
# model = RB750Gr3
# serial number = 8AFF0A83E2D9
/interface bridge
add name=bridge1
add name=loopback
/interface ethernet
set [ find default-name=ether1 ] name=ISP
/interface l2tp-client
add allow=mschap2 connect-to=192.168.130.175 disabled=no max-mru=1465 max-mtu=1465 name=l2tp-out1 password=12345 user=ppp
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp_pool1 ranges=172.20.20.2-172.20.20.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=bridge1 name=dhcp1
/routing ospf instance
set [ find default=yes ] router-id=20.20.20.3
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
/ip address
add address=192.168.130.176/24 interface=ISP network=192.168.130.0
add address=172.20.20.1/24 interface=bridge1 network=172.20.20.0
add address=20.20.20.3 interface=loopback network=20.20.20.3
/ip dhcp-server network
add address=172.10.10.0/24 gateway=172.10.10.1
add address=172.20.20.0/24 gateway=172.20.20.1
/ip dns
set servers=1.1.1.1,8.8.8.8
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ISP
/ip route
add distance=1 gateway=192.168.130.100
/routing ospf network
add area=backbone network=20.20.20.0/24
add area=backbone network=172.20.20.0/24
add area=backbone network=172.31.1.0/24
add area=backbone network=10.1.2.0/24
/system clock
set time-zone-name=Asia/Novosibirsk
/system routerboard settings
set silent-boot=no

 

Share this post


Link to post
Share on other sites

@SinClaus дайте выхлоп 

 

ip route print 

routing ospf route print 

ip address print

routing ospf lsa print

routing ospf neighbor print

С циски то же нужна инфа 

 

У меня со стороны микротика настроен nssa, принимаю чисто дефолт 

Lo интерфейс на микротике через бридж 172.16.255.2/32 

Линковая сетка между маршутизаторами статика 172.16.254.0/30 

Стоит обратить внимание на network-type 

 

 

 /routing ospf area
set [ find default=yes ] disabled=yes
/routing ospf instance
set [ find default=yes ] disabled=yes router-id=172.16.255.2
add name=ospf2 redistribute-connected=as-type-1 router-id=172.16.255.2
/routing ospf area
add area-id=0.0.0.2 default-cost=1 inject-summary-lsas=no instance=ospf2 name=area2 translator-role=translate-never type=nssa
/routing ospf interface
add interface=sfp2.3800 network-type=point-to-point
add interface=loopback network-type=broadcast passive=yes
add network-type=broadcast passive=yes
/routing ospf network
add area=area2 network=172.16.0.0/18
add area=area2 network=172.16.255.2/32
add area=area2 network=172.16.254.0/30

 

Все же вам стоит нарисовать схему, хоть она и простая 

 

 

 

Share this post


Link to post
Share on other sites

Вопрос что с другой стороны. Насколько понимаю, unnumbered интерфейс на циске - это её ноу-хау, и именно там проблема.

 

Если вообразить такую сложность невозможно, вот схема:

 

[CISCO]--------[Mikrotic]

Share this post


Link to post
Share on other sites

@SinClaus Если в routing ospf route print  маршрут уже есть, он должен передаваться в таблицу маршрутизации

У меня обратная модель я передают /32 маску с pppoe интерфейсов и статические записи unnumbered интерфейсов с микротика(сделано не фонтан, но работает) 

Share this post


Link to post
Share on other sites
7 часов назад, SinClaus сказал:

Вопрос что с другой стороны. Насколько понимаю, unnumbered интерфейс на циске - это её ноу-хау, и именно там проблема.

 

Если вообразить такую сложность невозможно, вот схема:

 

[CISCO]--------[Mikrotic]

Ну не особо новая, с unnambered все пашет, выше команды, дайте то что выведут, я думаю просто где то небольшая ошибка

Share this post


Link to post
Share on other sites

@SinClaus Вот эта схема, хотя можно было написать [MX]------[CCR1036]---[клиент] ну то же будет правильно все же просто 5a39e4dca81c8_i16cimgpsh_orig.png.eedbd84d93c0a3518bf2a054d6876db7.png

Share this post


Link to post
Share on other sites

MX80 - это циска выпущенная джунипером, в курсе :)

Share this post


Link to post
Share on other sites

@SinClaus Я то же в курсе, что вы хотите получить помощь и у вас есть уже опыт, но вы не хотите потратить 5-10 минут, выкладывания конфига и выхлопа. Что вы выложили это обрывки по которым тяжело как-то помогать. Каждый случай индивидуальный, хоть вы это видите как "обычный" 

 

Когда я понимал  OSPF мне все люди писали нужно понять LSA, я в тот момент не очень понимал зачем это, но только с 5-8 мануала, осознал важность LSA при этом мануал был не на основе Juniper или Mikrotik, а всеми любимая Cisco. У каждого вендора свое виденье на протоколы, но общие правила не кто не отменял.

Если все как вы утверждаете, что маршрут прилетает на микротик в routing ospf route print (хотя я не видел выхлопа) как писал выше fractal, где-то есть ошибка и скорее всего она на микротике, поэтому не видя полной картины нет смысла, что-то советовать. Я вам скинул пример своего конфига, у меня работает. Не через L2TP тунель, а на статике, но так же я тестил на PPTP все работало. 

 

Всего вам доброго. 

 

З.Ы. Спасение утопающего зависит от самого утопающего. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this