Jump to content
Калькуляторы

Sheduler не отрабатывает

Есть конструкция:

 

/system scheduler
add interval=1d name="wifi off" on-event="/inteface wireless disable wlan1" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=nov/29/2018 start-time=08:00:00
add interval=1d name="wifi on" on-event="/inteface wireless enable wlan1" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=nov/29/2018 start-time=13:00:00

 

run count растет

next count Mar/02/2019 08:00:00

Правда с start-date=nov/29/2018 всего 8 раз

 

руками команду /inteface wireless disable wlan1 отрабатывает

 

ЧЯДН?

Share this post


Link to post
Share on other sites
Quote

Properties

 

interval (time; default: 0s) - interval between two script executions, if time interval is set to zero, the script is only executed at its start time, otherwise it is executed repeatedly at the time interval is specified

 

name (name) - name of the task

 

on-event (name) - name of the script to execute. It must be presented at /system script

 

run-count (read-only: integer) - to monitor script usage, this counter is incremented each time the script is executed

 

start-date (date) - date of the first script execution

 

start-time (time) - time of the first script execution

 

startup - execute the script 3 seconds after the system startup.

 

Share this post


Link to post
Share on other sites

Может надо / убрать?

 

А само включение или выключение нужно делать так, что бы правило, которое выключает интерфейс, отключало себя после выполнения и включало правило, которое интерфейс включает. А то, правило, которое включает, выключало себя и включало на выключение.

Share this post


Link to post
Share on other sites

Заходим в terminal и набираем:   interface wireless> print
  Результатом выполнения команды print из раздела interface wireless будут данные о беспроводных интерфейсах.
Видим что оснащён всего одним беспроводным интерфейсом, порядковый номер которого в списке 0.
По этому номеру, можно включать и отключать беспроводной интерфейс.

В разделе System Sheduler создадим правило для отключения беспроводного интерфейса.

Name: WirelessOff – название задания.
Start Date: – дата начала задания.
Start Time: 01:00:00 – время выполнения задания.
Interval: 1d 00:00:00 – интервал выполнения задания.

/interface wireless disable 0 – команда для отключения беспроводного интерфейса.

/interface wireless enable 0  - команда для включения беспроводного интерфейса.

Share this post


Link to post
Share on other sites
В 01.03.2019 в 17:36, McSea сказал:

 

То есть так:

 /system scheduler
add interval=1d name="wifi off" on-event=wlan1_disable policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=nov/29/2018 start-time=08:00:00
add interval=1d name="wifi on" on-event=wlan1_enable policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=nov/29/2018 start-time=13:00:00

и

/system script
add dont-require-permissions=no name=wlan1_disable owner=prm policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="/inteface wireless disable wlan1"
add dont-require-permissions=no name=wlan1_enable owner=prm policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="/inteface wireless enable wlan1"
?

Share this post


Link to post
Share on other sites

Коллега заметил отсутствие буквы r в /inteface wireless disable wlan1 ))))

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this