Перейти к содержимому
Калькуляторы

Vlan в Bridge

День добрый. Есть рабочая сеть , нужно на этой сети поднять Vlan , так что бы работали старые клиенты , и новые через Vlan .

Создаю допустим бридж на микротике , засовываю в него ETH2 где сидят клиенты с IP , и VLAN -и толку нет не какого. Работает только клиенты по IP , Vlan в упор нет . По раздельности с разнымы сетями все работает . Как удружить ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Видимо верно все настроить. Вланы создавать уже на бридже, IP для старых клиентов вешать на бридж, для абонентов на вланах вешать их адреса на влан, не забывать про маску подсетей, если адресация пересекается.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Не совсем понял.  Если не сложно на пальцах. 

 

Как делаю я , создаю подсеть - допустим 192.168.1.1/24 , создаю ВЛАН на этот интерфейс , допустим 3 . Дальше , если присвоить эти адреса на этот интерфейс , то клиенты ок, работают. Если присваивать эти адреса на vlan 3 то опять же работает но через vlan , если же я создаю бридж , вставляю в него интерфейс и vlan 3, присваиваю эту подсеть уже на бридж , то работают только клиенты по айпи , клиенты по влану адресов не получают.

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сначала делаете:

 

/ip dhcp-server network
add address=192.168.100.0/24 dns-server=8.8.8.8 gateway=192.168.100.1

 

Потом добавляете порты абонентов:

 

/interface vlan
add arp=reply-only interface=bridge_vlan name=vlan_2 vlan-id=2

/ip address
add address=192.168.100.1/32 network=192.168.100.2 interface=vlan_2

/ip pool
add name=dhcp_pool_2 ranges=192.168.100.2

/ip dhcp-server
add add-arp=yes address-pool=dhcp_pool_2 disabled=no interface=vlan_2 lease-time=5m name=dhcp_2

/queue simple
add max-limit=15M/30M name=vlan_2 target=192.168.100.2/32

 

Если влана 2 и более, то каждый параметр копируете и увеличиваете порядковый номер. Тут в каждый влан выдается один адрес поштучно. Если у вас цель переводить абонентов во влан оставив им старую адресацию, то можете эту же подсеть, но /24 повесить на бридж, а на вланы выделять IP адреса нужного абонента в своем влане. Однако они не смогут обмениваться данными между собой, если это надо - то на интерфейсе bridge надо включить apr-proxy.

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Получается я тупо поднимаю сеть , делаю дшсп , и вешаю на влан , а где же они обьеденяются тогда ? мне надо с рабочей сети влан что бы была с теми же адресами

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Объединяются на роутере. Только клиенты обычной сети (без влан) не будут знать что запросы в сторону адресов во вланах надо делать на роутер, а не широковещательно, именно по этой причине включается прокси арп. Если у вас задача как-то отделить часть сети то можно так делать. Если вам в один влан надо несколько устройств - можете сделать пул на 10 адресов допустим, на этот влан прописываете 10 этих адресов поштучно, тогда абоненты в этом влане смогут работать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

По данным командам у меня не выходит не чего , выдает ошибки

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Значит, видимо, вам пора выяснять номер карты сбербанка пользователя сааб95

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
19 минут назад, vurd сказал:

Значит, видимо, вам пора выяснять номер карты сбербанка пользователя сааб95

Я считаю что можно эту проблему решить и без номера карты .

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@belokuriha я тоже так считаю google.com работает пока ещё 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 30.06.2018 в 12:02, belokuriha сказал:

По данным командам у меня не выходит не чего , выдает ошибки

Там имя bridge_vlan, переименуйте свой влан или в командах укажите bridge1 если он у вас так называется.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Да и вообще неплохо бы увидеть ошибки, а не услышать о них.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас