Jump to content
Калькуляторы

VLAN через WIFI микротики

Народ помогите решить задачу, не получается "каменный цветок"

Как пробросить VLAN трафик через мосты wifi

Порт в HP V1910 ( в режиме trunk), воткнут RB 2SHPn в режиме ap bridge  

На некотором удалении стоят две RB 2SHPn  обе в режиме stantion bridge

одна подключена к RB2011, другая к RB962

WDS включен..

Цель: пробросить через мосты тегерированный трафик до RB2011 и RB962 и в них  развести по портам (access).

 

Пробовал по всякому не фига не выходит...

 

 

 

Scan.jpg

Share this post


Link to post
Share on other sites
6 часов назад, vmoroz сказал:

WDS включен..

зачем ? 

Share this post


Link to post
Share on other sites

Station wds на клиентах

 

и везде включить wds, можно вручную, можно динамикой положить в Нужный бридж 

Share this post


Link to post
Share on other sites
18 часов назад, vmoroz сказал:

stantion bridge

Этот режим используется для тупиковой терминации канала на CPE, если нужен пропуск данных через него дальше на уровне L2 следует использовать station WDS.

Share this post


Link to post
Share on other sites

На клиентах изменил в station WDS

Нужно ли на базе из транкового порта выделять vlan и гнать их бриджами для каждого vlan в wds интерфейс (как это делается для ethernet интерфейсах), или достаточно такой конфигурации

/interface bridge
add name=bridge1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk eap-methods="" \
    management-protection=allowed mode=dynamic-keys name=ast \
    supplicant-identity="" wpa-pre-shared-key=********** \
    wpa2-pre-shared-key=**********
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no frequency=2462 \
    mode=ap-bridge nv2-cell-radius=10 security-profile=ast ssid=AST_WI \
    wds-default-bridge=bridge1 wds-mode=dynamic wireless-protocol=nv2 \
    wps-mode=disabled
/interface bridge port
add bridge=bridge1 interface=ether1

p.s. естественно в bridge1 динамически попадают интерфейсы WDS клиентов

 

UPD:

Всем спасибо.

Все получилось с одной точкой (вторая отвалилась, нужно топать ручками менять wds и т.д.) , дело было в HP V1910  (разобрался с помощью Torch).

Но предвижу проблему как в этой теме: vlan через wifi bridge когда клиенты флудили между собой

Там решение было заблокировать трафик между клиентами

Quote

На базе в настройках бриджа заблокируйте трафик между клиентами.Для этого создайте правило в Filters где укажите In Bridge и Out Bridge ваш бридж, и поставьте галочку у Out Interface ! Ether1 или какой у вас выходной интерфейс и действие Drop.

Не совсем понятно, т.к. при попытке так прописать, клиент отваливается....

@Saab95  комментарий был Ваш, подскажите как правильно прописать изоляцию между клиентами WDS ?

 

Edited by vmoroz

Share this post


Link to post
Share on other sites

Это на базе надо делать. Тогда если пакет данных идет не на порт Ether1, то он будет отбрасываться. То есть абоненты друг другу данные передавать не смогут. Однако сама БС сможет получить доступ на них.

Share this post


Link to post
Share on other sites
1 hour ago, Saab95 said:

Это на базе надо делать. Тогда если пакет данных идет не на порт Ether1, то он будет отбрасываться. То есть абоненты друг другу данные передавать не смогут. Однако сама БС сможет получить доступ на них.

На базе и делаю... Но после применения в итоге блокируется весь трафик.....

 

drop.jpg

drop2.jpg

Edited by vmoroz

Share this post


Link to post
Share on other sites

В предыдущем сообщении не верно указал - надо указывать и In и Out интерфейсе в правиле блокировки, то есть везде указываете Ether1.

Share this post


Link to post
Share on other sites
15 hours ago, Saab95 said:

В предыдущем сообщении не верно указал - надо указывать и In и Out интерфейсе в правиле блокировки, то есть везде указываете Ether1.

Спасибо.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this