Jump to content
Калькуляторы

SNR-CPE поддержка, опыт эксплуатации, регрессии, результаты тестирования, общие вопросы

какой вредный =)))) sh -x /etc/scripts/pingerz.sh расскажет что ash не нравиться в вашем скрипте.

 

И вообще это:

1) не регрессия, корректно написанные скрипты как исполнялись так и исполняются

2) оффтоп, учить писать и отлаживать скрипты тут никто не обещал, для этого есть другие ресурсы

Share this post


Link to post
Share on other sites
Guest Sterr

да нет, это таки регрессия. но скорее всего не по вашей вине, а по причине повышения версий. раньше на этот скрипт sh не матерился.

он раньше работал, потом с очередным обновлением прошивки со стиранием РВФС был благополучно стерт, и вот сейчас понадобился.

но интересно что пишет то не ошибку в скрипте как по идее должно быть, а not found это то и убивает.

Share this post


Link to post
Share on other sites

Чего чего? Ещё раз грю. Корректно написанные скрипты как выполнялись так и будут выполняться если загружены и корректно права отданы. Нет никаких регрессий тут и быть не может иначе железка бы не запустилась вообще т.к. весь инит скриптовый.

 

Повторяю для невнимательных, это всё тут оффтоп, как дебажить мной подсказанно. Если этого мало идём на сайт бизибокса и читаем там на тему ash.

 

В общем утром снесу в оффтоп.

 

P.S. А not found он может ругаться запросто на то что в заголовке скрипта неверно указан путь в интерпретатору. Но вы ведь советом данным выше ещё не воспользовались, зато своё мнение уже высказали. Давайте в будущем вы будете наоборот поступать? Сначала попробуете - потом отпишитесь?

Share this post


Link to post
Share on other sites
Guest BoJlAHD

Всем привет, есть маршрутизатор SNR-CPE-W4N мне его предоставил провайдер!

Так вот при входе в него стоит прошивка данного провайдера!

Я постарался сбросить его до заводских настроек (нажал на кнопку резет 15 сек), но после сброса не получается войти в настройки, при вводе 192.168.1.1 писал и пароль админ/админ, и тот пароль который давал мне провайдер, не чего не получается не могу зайти!

Я пробовал уже и залить прошивку по этому мануалу: http://shop.nag.ru/article/firmware-recovery-snr-cpe-w4n-revmcpe-md1, вроде все заливается, маршрутизатор перезагружается, но после перезагрузки опять показывает название прошивки данного провайдера. Как мне залить обычную прошивку? Подскажите пожалуйста!!!

Share this post


Link to post
Share on other sites
Guest sterr

да нет, я все поправил и тоже повторюсь, что скрипт работал год назад. в теме про третий светодиод он есть, может конечно не совсем тот, но подобный. и он без изменений лежал на винте вместе с кронтабами. и он работал. а теперь нет. путь правильный. сносите в офф.

Share this post


Link to post
Share on other sites

Всем привет, есть маршрутизатор SNR-CPE-W4N мне его предоставил провайдер!

Так вот при входе в него стоит прошивка данного провайдера!

Я постарался сбросить его до заводских настроек (нажал на кнопку резет 15 сек), но после сброса не получается войти в настройки, при вводе 192.168.1.1 писал и пароль админ/админ, и тот пароль который давал мне провайдер, не чего не получается не могу зайти!

Я пробовал уже и залить прошивку по этому мануалу: http://shop.nag.ru/article/firmware-recovery-snr-cpe-w4n-revmcpe-md1, вроде все заливается, маршрутизатор перезагружается, но после перезагрузки опять показывает название прошивки данного провайдера. Как мне залить обычную прошивку? Подскажите пожалуйста!!!

 

login/pass скорее всего Admin/Admin

Share this post


Link to post
Share on other sites

Здравствуйте, имеется маршрутизатор SNR-CPE-W4G, при подключении к компьютеру не получает IP, Wifi не раздает, индикаторы кроме power на маршрутизаторе не активны. Когда подключаем lan к компьютеру, индикатор загорается и моргает с периодичностью. Пробовали восстановить по инструкции через tftp, результата нет, не конектится с роутером.

Что ещё можно попробовать? Дайте совет.

Share this post


Link to post
Share on other sites

Все возможные вариаты расписаны выше. Если это не помогает - в сервис.

 

А вообще что бы что-то посоветовать нужно знать как вы его в такую позу загали потому как причин дофига в т.ч. аппаратно помер. Не даёте инфы - ну тады сервис.

Share this post


Link to post
Share on other sites

Спасибо все работает отлично с белым айпи. Есть проблема когда адрес за натом. Настроил freedns.afraid.org т.к. dyndns стал платным. Не могу приконектиться через ssh. Там в настройке днс вместо логина и пароля ввел ключ как указано и ввел хост, но соединиться не могу.

 

Так, соединился, проблема была в указании недефолтного порта. Теперь почему то пишет отказано в доступе СКРИН Пароль верный, но зайти не могу

 

 

заходите по ssh на роутер вводите:

 

~ # ether-wake 
BusyBox v1.24.1 () multi-call binary.

Usage: ether-wake [-b] [-i IFACE] [-p aa:bb:cc:dd[:ee:ff]/a.b.c.d] MAC

Send a magic packet to wake up sleeping machines.
MAC must be a station address (00:11:22:33:44:55) or
a hostname with a known 'ethers' entry.

       -b              Broadcast the packet
       -i IFACE        Interface to use (default eth0)
       -p PASSWORD     Append four or six byte PASSWORD to the packet

 

Т.е. ether-wake -i br0 МАК-ПК разбудит его. Доступ к SSH с WAN надо разрешить в misc, желательно сменить порт на какой-нить аля 9245 и использовать сложные пароли.

 

P.S. Проброс WOL пакетов с WAN не поддерживается в силу небезопасности и костыльности сего мероприятия. Так что используем штатные человеческие методы.

Edited by wolfxr

Share this post


Link to post
Share on other sites

Спасибо все работает отлично с белым айпи. Есть проблема когда адрес за натом. Настроил freedns.afraid.org т.к. dyndns стал платным. Не могу приконектиться через ssh. Там в настройке днс вместо логина и пароля ввел ключ как указано и ввел хост, но соединиться не могу.

 

Так, соединился, проблема была в указании недефолтного порта. Теперь почему то пишет отказано в доступе СКРИН Пароль верный, но зайти не могу

 

Ничего не понял куда вы коннектитесь и что сделать пытаетесь? Если адрес за натом извне вы до него не достучитесь, если на желеке которая NAT выполняет не будет сделан портфорвард.

Share this post


Link to post
Share on other sites

Доброго времни суток!

Письмо на wifi@nag.ru осталось без ответа, общение с саппортом долгое, а тут, на форуме может кто ещё подскажет :)

Вопрос по сабжу - что-то много он пишет в логи. Хотел убавить, но не получается. Вроде бы в конфиге уровень логгирования стоит info, но такое ощущение, что оно игнорируется и в лог лезут строки дебага (например DEBUG: cwmp_session_recv_response, DEBUG: http_read_response OK - и т.д.).

Можно ли как-то сократить вывод?

Share this post


Link to post
Share on other sites

Ну да можно. Взять исходники разобраться почему игнорит значение в конфиге, поправить и прислать или не прислать патч.

 

Допил netcwmpd выполнянлся под заказ третьим лицом. Так что не подскажу что и почему там происходит. Если вдруг этому лицу снова оплатят определённые часы - я обязательно озвучу сию проблему.

Share this post


Link to post
Share on other sites

Да эт я понимаю... Пост создан в надежде, что кто-то ещё кроме меня заинтересуется :)

Пока докопал, что конфиг подхватывается, но видимо где-то дальше параметр изменён или поменяна логика. Копаю дальше...

Share this post


Link to post
Share on other sites

Засилье логов побеждено.

 

*** /home/mbg/cwmpd.c   2016-07-28 09:23:23.389872941 +0500
--- /home/mbg/wive-ng-wive-ng-mt_4.4.16/user/netcwmp/cwmpd/src/cwmpd.c  2016-07-28 08:31:24.236084407 +0500
***************
*** 111,116 ****
--- 111,117 ----
         else if (strcasecmp(loglevel,"info") == 0) level = CWMP_LOG_INFO;
         else if (strcasecmp(loglevel,"debug") == 0) level = CWMP_LOG_DEBUG;
         else if (strcasecmp(loglevel,"trace") == 0) level = CWMP_LOG_TRACE;
+         else if (strcasecmp(loglevel,"crit") == 0) level = CWMP_LOG_CRIT;
     }

     cwmp_log_init(NULL, level);

 

*** /home/mbg/wive-ng-wive-ng-mt/user/netcwmp/conf/cwmp.conf    2016-06-30 09:29:33.578684224 +0500
--- /home/mbg/wive-ng-wive-ng-mt_4.4.16/user/netcwmp/conf/cwmp.conf     2016-07-28 08:31:40.546241877 +0500
***************
*** 27,33 ****
 httpd_port=1008
 http_timeout=5000
 notification=0
! log_level=info

 [env]
 DEVNAME=
--- 27,33 ----
 httpd_port=1008
 http_timeout=5000
 notification=0
! log_level=crit

 [env]
 DEVNAME=

Share this post


Link to post
Share on other sites

Ну и если надо обращаться к серверу не постоянно, а например, раз в 10 минут:

*** /home/mbg/wive-ng-wive-ng-mt/user/netcwmp/cwmpd/src/agent.c 2016-07-28 09:53:13.561884314 +0500
--- /home/mbg/wive-ng-wive-ng-mt_4.4.16/user/netcwmp/cwmpd/src/agent.c  2016-07-28 10:12:59.456737407 +0500
***************
*** 372,377 ****
--- 372,378 ----
               {
                       cwmp->new_request = CWMP_YES;
               }
+       sleep(600);
     }//end while(TRUE)
 }

 

Кривокосо конечно, но я к с ожалению, не программист...

Share this post


Link to post
Share on other sites

Спасибо, будет время посмотрим.

 

В чём тайный смысл обращаться раз в 10 минут? Ну максимум там random 1-15 сек что бы при массовом отключении нагрузку размазать и всё.

Share this post


Link to post
Share on other sites

Ну а зачем чаще? Прошивка стабильная, устройства хорошие. Часто дёргать их смысла не вижу. Экономлю трафик :)

Share this post


Link to post
Share on other sites

А компания НАГ случайно не заказывала альтернативную прошивку на продающиеся у них LAVA Telecom LR-25G001 ? А то железо вроде нормальное, а глюки досадные...

Share this post


Link to post
Share on other sites

Что то не нашел тем про установку OpenWRT на роутер с 7620 чипом?

Ибо в стоке нет возможности через веб добавить несколько VPN или создать новый интерфейс. И что по поводу vlan?

Share this post


Link to post
Share on other sites

Вопросы по OpenWrt можно адресовать на форум по WRT или на их wiki и подобные темы.

Vlan доступен в меню Administration - Status

Share this post


Link to post
Share on other sites

mbg

Данное устройство к серии SNR-CPE не относится , и планов таких нет.

Железо там идентичное SNR-CPE-MD1, с той разницей, что в указанной Вами модели присутствует внешний гигабитный коммутатор.

В планах есть гигабитный роутер на MT7621 чипе, именно в рамках проекта SNR-CPE , с софтом Wive-NG-MT

Share this post


Link to post
Share on other sites

Uboot собиратсья должен, или он в комплекте для ознакомления?

Share this post


Link to post
Share on other sites

Он и собирается когда надо и где надо. Но поверьте что вам оно точно не нужно. =) Там лежат уже собранные имиджи - вот их и юзайте от греха по дальше. Вообще на текущих запущенных в производство устройствах обновлять убут смысла нет.

Share this post


Link to post
Share on other sites

Сорри, уже разобрался - компилится, собирается. Мне не для текущих, мне для стороннего :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now