Jump to content
Калькуляторы

Cisco router Не удается выбрать Extended vlan

Всем привет!

Ступор. Информации нигде не нашел.

Просьба откликнуться.

 

Cisco router 7201

при описании class-map не дает выбрать vlan выше 1005

 

class-map match-any NAME_OF_CM

match vlan 14

match vlan 15

match vlan 16

match vlan 17

match vlan ?

<1-1005>

 

Необходимо выбрать vlan из всего диапазона, например 2000, 2075 и т.д.

Находил информацию, о том что в базе vlan на устройстве хранятся только "стандартные" vlan (1-1005), и для того чтобы использовать extended vlan (>1005) - нужно хранить их в отдельном файле.

Кто сталкивался с данной проблемой и знаком с процедурой, просьба откликнуться.

Share this post


Link to post
Share on other sites

vtp mode transparent ?

 

Я подозреваю, что это относится к коммутаторам?

на маршрутизаторе такого нет.

Или я заблуждаюсь?

маршрутизатор ругается, говорит нет такого:

 

ROUTER(config)#vtp ?

% Unrecognized command

Share this post


Link to post
Share on other sites

Это прям издевательство)

Вот оно, на поверхности решение глобальной вопроса, но возникает маленький ньюанс с vlan от 1 до 1005 и все. Ступор.

Как же заставить понимать match vlan выше 1005?

Share this post


Link to post
Share on other sites

vtp mode transparent ?

 

Я подозреваю, что это относится к коммутаторам?

на маршрутизаторе такого нет.

Или я заблуждаюсь?

маршрутизатор ругается, говорит нет такого:

 

ROUTER(config)#vtp ?

% Unrecognized command

я написал не проверяя, помню что на свичах такое было. А вообще - не сталкивался с такой проблемой

Share this post


Link to post
Share on other sites

Находил информацию, о том что в базе vlan на устройстве хранятся только "стандартные" vlan (1-1005), и для того чтобы использовать extended vlan (>1005) - нужно хранить их в отдельном файле.

Кто сталкивался с данной проблемой и знаком с процедурой, просьба откликнуться.

Это как раз касается коммутаторов, когда стандартный диапазон хранится во vlan.dat, а extended - в running-config

Share this post


Link to post
Share on other sites

А что ж с маршрутизаторами?

Vlan 4001 (т.е. выше 1005) отлично ведет себя на интерфейсах данного маршрутизатора.

Но проблема заключается при создании class-map

 

class-map match-any NAME_OF_CM
match vlan 14
match vlan 15
match vlan 16
match vlan 17
match vlan ?
<1-1005>

Share this post


Link to post
Share on other sites

Попробуйте матчить по каким-нибудь другим данным

Share this post


Link to post
Share on other sites

Попробуйте матчить по каким-нибудь другим данным

 

Дело в том, что стоит задача организовать полосу с пропускной способностью в 400 Мб/с для группы vlan, при этом все эти vlan - динамически делят эту полосу.

Вот и было решено, матчить по vlan, и потом и резать скорость на интерфейсе всей это группе, находящейся в class-map.

Share this post


Link to post
Share on other sites

Дело в том, что стоит задача организовать полосу с пропускной способностью в 400 Мб/с для группы vlan, при этом все эти vlan - динамически делят эту полосу.

Не уверен что в class-map можно указать несколько произвольных виланов, скорее всего только один вилан или непрерывный диапазон.

Share this post


Link to post
Share on other sites

7201(config-cmap)#match vlan ?
 <1-4095>  VLAN id

 

7201#show version
Cisco IOS Software, 7200 Software (C7200P-ADVENTERPRISEK9-M), Version 15.2(4)M5, RELEASE SOFTWARE (fc2)

Share this post


Link to post
Share on other sites

На 65 аналогично. Тоже 15 ios

 

7201(config-cmap)#match vlan ?
 <1-4095>  VLAN id

 

7201#show version
Cisco IOS Software, 7200 Software (C7200P-ADVENTERPRISEK9-M), Version 15.2(4)M5, RELEASE SOFTWARE (fc2)

Share this post


Link to post
Share on other sites

Дело в том, что стоит задача организовать полосу с пропускной способностью в 400 Мб/с для группы vlan, при этом все эти vlan - динамически делят эту полосу.

Не уверен что в class-map можно указать несколько произвольных виланов, скорее всего только один вилан или непрерывный диапазон.

 

А я вот, не уверен, что 7201 вытянет 400 мб\с. Мне кажется с таким показателем трафика ограничение можно не делать.

Share this post


Link to post
Share on other sites

А я вот, не уверен, что 7201 вытянет 400 мб\с. Мне кажется с таким показателем трафика ограничение можно не делать.

 

Там на борту NPE-G2, это: 2 Mpps и 1024 Mbps/

Так, что без проблем прожуёт.

Share this post


Link to post
Share on other sites

На 65 аналогично. Тоже 15 ios

 

7201(config-cmap)#match vlan ?
 <1-4095>  VLAN id

 

Возможно дело в версии

у нас

Cisco IOS Software, 7200 Software (C7200P-ADVENTERPRISEK9-M), Version 15.0(1)M, RELEASE SOFTWARE (fc2)

Найти версию (как Ваша) пока не получается(

 

7201#show version
Cisco IOS Software, 7200 Software (C7200P-ADVENTERPRISEK9-M), Version 15.2(4)M5, RELEASE SOFTWARE (fc2)

Share this post


Link to post
Share on other sites

vtp mode transparent ?

 

Я подозреваю, что это относится к коммутаторам?

на маршрутизаторе такого нет.

Или я заблуждаюсь?

маршрутизатор ругается, говорит нет такого:

 

ROUTER(config)#vtp ?

% Unrecognized command

Это не в конфиг режиме надо делать

#vlan database

Share this post


Link to post
Share on other sites

Отписываюсь по тому как удалось решить вопрос.

Скажу сразу, это что-то очень странное. Мы даже и не подозревали, что настроить это можно только через одно место)))

В итоге:

1. Версия IOS 15.0 и 15.1 поддерживают match vlan, но только от 1 до 1005!!!

При этом сконфигурированый map-policy удается повесить на физический интерфейс, без добавлений sub интейфейсов.

2. Версия IOS 15.2 поддерживают match vlan, от 1 до 4095!!!

И все казалось бы хорошо, вопрос закрыт, но не тут то было)))

Повесить такой map-policy на физический интерфейс можно только при наличии sub интерфейса, причем любого, даже не имеющего отношения к тем vlan которые матчим.

Но и тут все не просто, а именно polyci начинает работать только на output. А при удалении sub интерфейса начинает работать и input.

Для того, чтобы изменить map-policy который используется, необходимо обязательно создать любой sub, при этом service-policyc input перестает работать до тех пор, пока не удалить sub.

class-map match-any smid
match vlan  16 106 3040 3045 3050
class-map match-any obl
match vlan  15-16 19 106 3012-3013 3016 3020 3025 3030 3035 3085 3115 3135 3300
class-map match-any okt
match vlan  16 1001 1006-1020 3011 3055 3060 3065 3070 3075 3080 3090 3095 4003 4023
!
policy-map 10
class okt
 police 10000000 1875000 3750000 conform-action transmit  exceed-action drop  violate-action drop
class obl
 police 10000000 1875000 3750000 conform-action transmit  exceed-action drop  violate-action drop
class smid
 police 10000000 1875000 3750000 conform-action transmit  exceed-action drop  violate-action drop
policy-map 40
class okt
 police 40000000 7500000 15000000 conform-action transmit  exceed-action drop  violate-action drop
class obl
 police 40000000 7500000 15000000 conform-action transmit  exceed-action drop  violate-action drop
class smid
 police 40000000 7500000 15000000 conform-action transmit  exceed-action drop  violate-action drop

interface GigabitEthernet0/0
no ip address
ip flow ingress
ip flow egress
no ip route-cache
duplex auto
speed auto
media-type rj45
negotiation auto
service-policy input 40
service-policy output 10
!
connect obl1 GigabitEthernet0/0 GigabitEthernet0/1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this