Jump to content
Калькуляторы

Странное поведение RB951G-2HnD Странное поведение RB951G-2HnD

Добрый день.

 

Есть новый RB951G-2HnD.

Провайдер дает подключение по pppoe. Роутер подключается к провайдеру. Выпускает из локалки наружу на все порты кроме 80-го. Без проблем открывает любой сайт по http на любом порту кроме 80-го. При этом https работает без проблем.

Убирал все правила в фаерволе и mangle. Сбрасывал настройки. Пробовал настраивать и через wizard и в ручную. Результат один и тот же.

 

Где копать?

Share this post


Link to post
Share on other sites

cmd

telnet ya.ru 80

GET

<enter>

<enter>

 

вывод сюда.

Share this post


Link to post
Share on other sites

D:\1>telnet ya.ru 80

Подключение к ya.ru...Не удалось открыть подключение к этому узлу, на порт 80: Сбой подключения

 

 

Сразу предвижу следующий вопрос:

 

D:\1>ping ya.ru

 

Обмен пакетами с ya.ru [213.180.193.3] с 32 байтами данных:

Ответ от 213.180.193.3: число байт=32 время=24мс TTL=56

Ответ от 213.180.193.3: число байт=32 время=24мс TTL=56

Ответ от 213.180.193.3: число байт=32 время=23мс TTL=56

Ответ от 213.180.193.3: число байт=32 время=26мс TTL=56

 

Статистика Ping для 213.180.193.3:

Пакетов: отправлено = 4, получено = 4, потеряно = 0

(0% потерь)

Приблизительное время приема-передачи в мс:

Минимальное = 23мсек, Максимальное = 26 мсек, Среднее = 24 мсек

 

 

D:\1>telnet ya.ru 443

 

^C

TTP/1.1 400 Bad Request

Server: nginx

Date: Mon, 10 Apr 2017 07:48:57 GMT

Content-Type: text/html; charset=utf-8

Content-Length: 166

Connection: close

 

<html>

<head><title>400 Bad Request</title></head>

<body bgcolor="white">

<center><h1>400 Bad Request</h1></center>

<hr><center>nginx</center>

</body>

</html>

 

 

Подключение к узлу утеряно.

Edited by snik_1900

Share this post


Link to post
Share on other sites

Конфиг:

[admin@MikroTik] > /export

# apr/10/2017 12:01:15 by RouterOS 6.34.4

# software id = H13B-GZKV

#

/interface bridge

add name=bridge2

/interface wireless

set [ find default-name=wlan1 ] disabled=no mode=ap-bridge ssid=tipgr wireless-protocol=802.11

/interface pppoe-client

add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 password=Password use-peer-dns=yes user=pppoeXXX

/ip neighbor discovery

set ether1 discover=no

/interface wireless security-profiles

set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=dynamic-keys wpa-pre-shared-key=Password wpa2-pre-shared-key=Password

/ip pool

add name=dhcp ranges=192.168.0.3-192.168.0.254

/ip dhcp-server

add address-pool=dhcp disabled=no interface=bridge2 name=dhcp1

/ppp profile

set *0 use-encryption=no

/interface bridge port

add bridge=bridge2 interface=ether2

add bridge=bridge2 interface=ether3

add bridge=bridge2 interface=ether4

add bridge=bridge2 interface=ether5

add bridge=bridge2 interface=wlan1

/ip address

add address=192.168.0.1/24 interface=ether2 network=192.168.0.0

/ip dhcp-server network

add address=192.168.0.0/24 gateway=192.168.0.1 netmask=24

/ip dns

set servers=8.8.8.8

/ip firewall filter

add chain=input protocol=icmp

add chain=input connection-state=established

add chain=input connection-state=related

add action=drop chain=input disabled=yes in-interface=pppoe-out1

/ip firewall nat

# pppoe-out1 not ready

add action=masquerade chain=srcnat out-interface=pppoe-out1

/system clock

set time-zone-name=Europe/Moscow

/system leds

set 0 interface=wlan1

/system routerboard settings

set protected-routerboot=disabled

/tool mac-server

set [ find default=yes ] disabled=yes

add interface=ether2

add interface=ether3

add interface=ether4

add interface=ether5

add interface=wlan1

/tool mac-server mac-winbox

set [ find default=yes ] disabled=yes

add interface=ether2

add interface=ether3

add interface=ether4

add interface=ether5

add interface=wlan1

[admin@MikroTik] >

Share this post


Link to post
Share on other sites

Провайдера дергайте, достаточно инфы из первого ответа.

Или у вас есть вариант, в котором работает?

 

Я подозреваю, что там какой-нибудь редирект на 80 порту вас ожидать должен, но почему-то не работает.

Share this post


Link to post
Share on other sites

1. RouterBoard 450G работает на ура.

2. У прова действительно редирект с 80го порта. Для не плательщиков. Мы туда вроде бы не должны были попадать (фильтр по IP).

 

Переписали правила у прова и все заработало.

 

Спасибо.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this