Jump to content
Калькуляторы

не работает selective QinQ 2990

Всем привет.

Схема:

клиент ----- клиентский коммутатор -------агрегация-------сеть

На агрегации наблюдаю мак с клиентского и с сети.

На клиентском вижу только мак от клиента, с сети - нет.

Клиентский коммутатор:

#sh ver
 SNR-S2980-24T Device, Compiled on Apr 10 09:07:41 2015
 CPU Mac 00:03:0f:2b:82:71
 Vlan MAC 00:03:0f:2b:82:70
 SoftWare Version 7.0.3.5(B0221.0043)
 BootRom Version 7.0.24
 HardWare Version 2.0
 CPLD Version N/A
 Serial No.:SW026110D312790186
 Copyright (C) 2015 NAG LLC
 All rights reserved
 Last reboot is cold reset.
 Uptime is 11 weeks, 5 days, 1 hours, 25 minutes
#show ven
NAME            LEN          VALUE
------------    -----        ------------------------------
SwitchName      13           SNR-S2980-24T
VersionPre      0
VendNameEn      7            NAG LLC
VendNameBr      3            NAG
VendWWW         18           http://shop.nag.ru
VendLocate      47           Ak.Vonsovskogo str. 1-118, Ekaterinburg, Russia
CopyRight       26           Copyright (C) 2015 NAG LLC
VendContact     14           support@nag.ru
WebLogo         10976
WebLogin        5597
WebFacebd       12701
WebBG           13495
WebLang         2            en
VendorOid       19           1.3.6.1.4.1.40418.7
DeviceOid       29           1.3.6.1.4.1.40418.7.1.1.1.221
KeyNeed         4            0
BaseMac         6            f8 f0 82 10 00 00
CliStyle        3            0
HsrpNeed        4            0
DevType(ID)     4            221
ChassisCard     0
FileVersion     8            10.6.122
IMGPrefix       0
RomPrefix       0
HardWarePre     0
Prompt          0
UserName        5            admin
PassWord        5            admin
ManageIP        4            10.10.10.1
Клиентский порт
#show run int e1/16
!
Interface Ethernet1/16
switchport mode trunk
!
Линк на агрегацию
#show run int e1/6
!
Interface Ethernet1/6
switchport discard packet untag
switchport mode trunk
switchport trunk allowed vlan 845
!
#show mac-address-table vlan 845
Read mac address table....
Vlan Mac Address                 Type    Creator   Ports
---- --------------------------- ------- -------------------------------------
845  d4-ca-6d-1d-eb-b7           DYNAMIC Hardware Ethernet1/16

 

Агрегация

#show ver
 SNR-S2990G-24FX Device, Compiled on Sep 09 14:18:37 2015
 CPU Mac f8:f0:82:73:ba:85
 Vlan MAC f8:f0:82:73:ba:84
 SoftWare Version 7.0.3.5(R0102.0142)
 BootRom Version 7.1.37
 HardWare Version 1.0.1
 CPLD Version N/A
 Serial No.:SW041710F323000219
 Copyright (C) 2015 NAG LLC
 All rights reserved
 Last reboot is cold reset.
 Uptime is 11 weeks, 5 days, 1 hours, 34 minutes
#show ven
NAME            LEN          VALUE
------------    -----        ------------------------------
SwitchName      15           SNR-S2990G-24FX
VersionPre      0
VendNameEn      7            NAG LLC
VendNameBr      3            NAG
VendWWW         18           http://shop.nag.ru
VendLocate      49           Building 57/2,Predelnaya st, Ekaterinburg, Russia
CopyRight       26           Copyright (C) 2015 NAG LLC
VendContact     14           support@nag.ru
WebLogo         4530
WebLogin        11383
WebFacebd       12701
WebBG           13495
WebLang         2            en
VendorOid       19           1.3.6.1.4.1.40418.7
DeviceOid       23           1.3.6.1.4.1.40418.7.234
KeyNeed         4            0
BaseMac         6            f8 f0 82 10 00 00
CliStyle        3            0
HsrpNeed        4            0
DevType(ID)     4            234
ChassisCard     0
FileVersion     9            10.10.246
IMGPrefix       0
RomPrefix       0
HardWarePre     0
Prompt          0
UserName        5            admin
PassWord        5            admin
ManageIP        4            192.168.1.1
NeedLicense     6            NO
#show run int e1/0/21
!
Линк на клиентский коммутатор
Interface Ethernet1/0/21
media-type copper
description ### клиентский комм Ethernet1/6 ###
dot1q-tunnel selective s-vlan 144 c-vlan 845
dot1q-tunnel selective enable
switchport mode hybrid
switchport hybrid allowed vlan 144 untag
!
аплинк
#show run int e1/0/8
!
Interface Ethernet1/0/8
switchport mode hybrid
switchport hybrid allowed vlan 38;144-147;566;766;990;1209;2289 tag
switchport hybrid allowed vlan add 2685 tag
!
#show mac-address-table vlan 144
Read mac address table....
Vlan Mac Address                 Type    Creator   Ports
---- --------------------------- ------- -------------------------------------
144  00-17-94-c9-fe-1c           DYNAMIC Hardware Ethernet1/0/8
144  c4-7d-4f-6b-e8-00           DYNAMIC Hardware Ethernet1/0/8
144  d4-ca-6d-1d-eb-b7           DYNAMIC Hardware Ethernet1/0/21

 

Кто виноват и что делать?

Edited by shvlad1

Share this post


Link to post
Share on other sites

на SNR-S2990G-24FX selective qinq же вроде через policy map настраивается ?

Share this post


Link to post
Share on other sites

и так и так пробовали

в одну сторону маки то есть, значит навешивание второй метки работает

Share this post


Link to post
Share on other sites

А то, что на Interface Ethernet1/0/8, точно с 845 вланом работает?

А если Interface Ethernet1/0/8 в транк вместо гибрида перевести?

Share this post


Link to post
Share on other sites

это аплинк, просто транковый интерфейс

144 вилан передается, проверено

передает-принмает только по верхней метке, 845 не надо

ровно как и все равно, в каком режиме trunk/hybrid работает.

Share this post


Link to post
Share on other sites

Что бы на абонентском коммутаторе в 845 влане были маки от аплинка, со стороны аплинка что-то должно их поместить в двойной 144:845 пакет.

Агрегатор показывает маки в 144 влане. А внутренний тег правильный приходит от аплинка?

Share this post


Link to post
Share on other sites

Получил ответ от ТАКа, применил, вроде работает.

Важно - заработало после.

(config-if-ethernet1/0/21)#no dot1q-tunnel selective enable

 

Добрый день,

Для QinQ на SNR-S2990G-24FX используйте следующую конструкцию:

 

class-map qinq1

match vlan 845

 

policy-map qinq

class qinq1

add s-vid 144

 

 

Interface Ethernet1/0/21

service-policy input qinq

switchport mode hybrid

switchport hybrid allowed vlan 144 untag

 

Share this post


Link to post
Share on other sites

Теперь следите за потреблением TCAM, show tcam usage, каждый match в class-map это 1 entry в каком-либо банке из двух.

Плюс есть совершенно дурацкое ограничение не более 128 entries на порт, то есть если в class-map будет match vlan range x-y, то в таком range должно быть не более 128 CVLAN.

Это если планируете широко использовать функционал.

Share this post


Link to post
Share on other sites

Теперь следите за потреблением TCAM, show tcam usage, каждый match в class-map это 1 entry в каком-либо банке из двух.

Плюс есть совершенно дурацкое ограничение не более 128 entries на порт, то есть если в class-map будет match vlan range x-y, то в таком range должно быть не более 128 CVLAN.

Это если планируете широко использовать функционал.

 

Т.е. SNR-S2990G-24FX не может обрабатывать больше 128 CVLAN в одном SVLAN на одном порту?

Share this post


Link to post
Share on other sites

Теперь следите за потреблением TCAM, show tcam usage, каждый match в class-map это 1 entry в каком-либо банке из двух.

Плюс есть совершенно дурацкое ограничение не более 128 entries на порт, то есть если в class-map будет match vlan range x-y, то в таком range должно быть не более 128 CVLAN.

Это если планируете широко использовать функционал.

 

Т.е. SNR-S2990G-24FX не может обрабатывать больше 128 CVLAN в одном SVLAN на одном порту?

Обновитесь на http://data.nag.ru/SNR%20Switches/Firmware/SNR-S2990G/S2990G-24T%28TX%29%28FX%29%2848T%29_7.0.3.5%28R0102.0152%29.zip

там такого ограничения нет , можно задать диапазон 1-4094

Share this post


Link to post
Share on other sites

Обновитесь на http://data.nag.ru/SNR%20Switches/Firmware/SNR-S2990G/S2990G-24T%28TX%29%28FX%29%2848T%29_7.0.3.5%28R0102.0152%29.zip

там такого ограничения нет , можно задать диапазон 1-4094

То есть аппаратного ограничения нет. Уже хорошо. А то метнулись уже заказ отменять.

Share this post


Link to post
Share on other sites

А количество subvlan в supervlan она заодно не фиксит, а то там тоже 128 : )

Share this post


Link to post
Share on other sites

А количество subvlan в supervlan она заодно не фиксит, а то там тоже 128 : )

нет, количество supervlan осталось прежнее. 128 не хватает ?

Share this post


Link to post
Share on other sites

Не удается по инсрукции http://shop.nag.ru/article/nastrojka-qinq-i-selective-qinq-na-kommutatorah-snr (смотрю для Конфиг для коммутатора S2990G-24FX с организацией selective QinQ с помощтю Policy-map) настроить селектив qinq

 

тут не дает выбрать range , а перечислять сотни вланов не удобно

class-map dachi

match vlan 2000 2001 2002

!

policy-map qinq

class dachi

add s-vid 6

exit

!

 

Interface Ethernet1/0/27

switchport mode hybrid

switchport hybrid allowed vlan 145 tag

switchport hybrid allowed vlan 6 untag

!

 

а при попытке на интерфейс навесить

service-policy input dachi

 

Отвечает

Warning: This card doesn't support dachi bind on Ethernet1/0/27.

 

SNR-S2990G-24TX#show version

SNR-S2990G-24TX Device, Compiled on Jun 20 13:20:34 2014

SoftWare Version 7.0.3.5(R0228.0004)

BootRom Version 7.1.22

HardWare Version 1.0.3

CPLD Version N/A

Serial No.:SW041310E721000224

Copyright © 2014 NAG LLC

All rights reserved

Last reboot is cold reset.

Uptime is 10 weeks, 6 days, 14 hours, 10 minutes

 

возможно стоит обновиться, как понимаю эта долна подойти под мой коммутатор? S2990G-24T(TX)(FX)(48T)_7.0.3.5(R0102.0170).zip новее, но почему тут R0102, а у меня R0228 вроде больще число.

Share this post


Link to post
Share on other sites

У меня так работает:

!

class-map USERS_PPPOE

match vlan range 1001 to 1061

!

 

SoftWare Version 7.0.3.5(R0102.0152)

BootRom Version 7.1.37

HardWare Version 1.0.1

Share this post


Link to post
Share on other sites

не отрабатывает

 

match vlan range 2000 to 2099

^

% Invalid input detected at '^' marker.

 

наверное надо ПО сменить, вот только смущает что текущее R0102.хххх , а у меня R0228.хххх , что это вообще за цифры

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this