Jump to content

Помогите с маршрутизацией Есть два роутера, 2 подсети. Нужно настроить их для правильной работы.

Доброго времени суток!

 

1. R1 и R2 находятся в одной сети - 10.10.10.0/24

 

2. R1 - Является шлюзом для WORK_1-5. А также для Роутера R2

 

3. R2 - Является шлюзом для SERVER_1-3

 

Как сделать, чтобы WORK_1-5 ходили в инет через VPN_1-5?

А SERVER_1-3 ходили в инет через VPN_6?

 

Как правильно прописать NATы на роутерах R1,R2?

 

Нстройки R1:

ether1 - WAN1

ether2 - WAN2

ether3 - WAN3

 

ether5 - LAN to R2

 

Настройки R2:

ether1 - LAN to R1

ether2-5 - SWITCH 10.10.11.1/24

ether1-2 - Bridge

 

Прошу не пинать сильно, в сетях - новичёк. Заранее благодарен за информацию и помощь.

post-128771-065245500 1437990842_thumb.png

Share this post


Link to post
Share on other sites

НАТы вам не надо прописывать, если вам нужно часть потребителей пустить по разным каналам, нужно маркировать маршруты в манглах, и сделать в роутах маршруты с указанием Routing Mark. Если нужно много потребителей пускать по разным каналам, целесообразно держать списки в Address-List.

Share this post


Link to post
Share on other sites

В данный момент R1 работает с такими настройками:

 

/ip address
add address=10.10.100.2/24 interface=WAN1 network=10.10.100.0
add address=10.10.101.2/24 interface=WAN2 network=10.10.101.0
add address=10.10.102.2/24 interface=WAN3 network=10.10.102.0
add address=10.10.10.1/24 interface=HomeLAN network=10.10.10.0

/ip firewall address-list
add address=10.10.10.101 comment="Tuner" list=WAN1_M
add address=10.10.10.102 comment="PHONE" list=WAN2_R
add address=10.10.10.103 comment="PHONE2" list=WAN2_R
add address=10.10.10.104 comment="NOTEBOOK1" list=WAN1_80,443,110,25
add address=10.10.10.105 comment="NOTEBOOK2" list=WAN_ECMP

/ip firewall nat
add action=masquerade chain=srcnat dst-port=80,443,110,25 out-interface=WAN1 protocol=tcp src-address-list=WAN1_80,443,110,25
add action=masquerade chain=srcnat comment=NAT-WAN1 dst-address=!10.10.10.0/24 src-address-list=WAN1_M
add action=masquerade chain=srcnat comment=NAT-WAN2 dst-address=!10.10.10.0/24 src-address-list=WAN2_R
add action=masquerade chain=srcnat comment=NAT-WAN3 dst-address=!10.10.10.0/24 src-address-list=WAN3_L
add action=masquerade chain=srcnat comment=ECMP_Balance src-address-list=WAN_ECMP

/ip firewall mangle
add action=mark-routing chain=prerouting comment=WAN1_80,443,110,25 dst-port=80,443,110,25 new-routing-mark=WAN1_80,443,110,25 passthrough=no protocol=tcp src-address-list=WAN1_80,443,110,25
add action=mark-routing chain=prerouting comment=ROUTE-WAN1 new-routing-mark=ROUTE-WAN1 passthrough=no src-address-list=WAN1_M
add action=mark-routing chain=prerouting comment=ROUTE-WAN2 new-routing-mark=ROUTE-WAN2 passthrough=no src-address-list=WAN2_R
add action=mark-routing chain=prerouting comment=ROUTE-WAN3 new-routing-mark=ROUTE-WAN3 passthrough=no src-address-list=WAN3_L
add action=mark-connection chain=input comment=ECMP_Balance in-interface=WAN1 new-connection-mark=cin_WAN1 src-address-list=WAN_ECMP
add action=mark-connection chain=input comment=ECMP_Balance in-interface=WAN2 new-connection-mark=cin_WAN2 src-address-list=WAN_ECMP
add action=mark-connection chain=input comment=ECMP_Balance in-interface=WAN3 new-connection-mark=cin_WAN3 src-address-list=WAN_ECMP
add action=mark-routing chain=output comment=ECMP_Balance connection-mark=cin_WAN1 new-routing-mark=ECMP_ROUTE_WAN1 passthrough=no
add action=mark-routing chain=output comment=ECMP_Balance connection-mark=cin_WAN2 new-routing-mark=ECMP_ROUTE_WAN2 passthrough=no
add action=mark-routing chain=output comment=ECMP_Balance connection-mark=cin_WAN3 new-routing-mark=ECMP_ROUTE_WAN3 passthrough=no
add action=mark-routing chain=prerouting comment=ECMP_Balance new-routing-mark=ECMP_MIXED src-address-list=WAN_ECMP

/ip route
add comment=WAN1_80,443,110,25 distance=1 gateway=10.10.100.1 routing-mark=WAN1_80,443,110,25
add comment=ROUTE-WAN1 distance=1 gateway=10.10.100.1 routing-mark=ROUTE-WAN1
add comment=ROUTE-WAN2 distance=1 gateway=10.10.101.1 routing-mark=ROUTE-WAN2
add comment=ROUTE-WAN3 distance=1 gateway=10.10.102.1 routing-mark=ROUTE-WAN3
add comment=ECMP_Balance distance=1 gateway=10.10.101.1,10.10.100.1,10.10.102.1 routing-mark=ECMP_MIXED
add check-gateway=ping comment=ECMP_Balance distance=1 gateway=10.10.100.1 routing-mark=ECMP_ROUTE_WAN1
add check-gateway=ping comment=ECMP_Balance distance=1 gateway=10.10.101.1 routing-mark=ECMP_ROUTE_WAN2
add check-gateway=ping comment=ECMP_Balance distance=1 gateway=10.10.102.1 routing-mark=ECMP_ROUTE_WAN3
add comment=DNS2 distance=1 dst-address=8.8.4.4/32 gateway=10.10.100.1
add comment=DNS1 distance=1 dst-address=8.8.8.8/32 gateway=10.10.100.1

 

По статтье в инете настроил ECMP Load Balancing. Не будет ли конфликтов каких-то?

Пока вроде работает и балансировка, и пользователи ходят по своим маршрутам.

 

А если мне нужно, чтобы пользователь 10.10.10.101/24 ходил через VPN на R2?

Как реализовать?

Share this post


Link to post
Share on other sites

а он не ходит? а он не ходит. можно добавить ему в таблицу маршрут до r2, либо в манглах исключить впн с него из маркировки.

Edited by user71

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.