Jump to content
Калькуляторы

PowerBeam M5 и STP очень нужна помощь

Вечер добрый!

Суть в том, что пытаюсь поднять резервный канал с помощью PowerBeam M5.

Основной канал работает по оптоволокну и в случае его падения, включается радиоканал. Использую протокол RSTP.

 

Сеть построена коммутаторами d-link и живут они в теггированном влане. То есть чтобы свичи между собой общались по резервному каналу, я создал на этих PowerBeam нужный vlan. (свичи живут в 196 влане, на power beam-ах пробросил этот влан)

Включаю везде stp и получил кольцо, так как резервный порт не заблокировался.

 

Собрал схему на стенде без радиомоста, все замечательно работает - падает основной линк, поднимается резервный. Дальше также на стенде сделал резервный канал радиомостом и также резервный канал не блочится, а после прослушивания начинает форвардить пакеты, подключаю патчкорд вместо радиомоста, все отрабатывает.

 

Умеют ли эти радиожелезки работать RSTP? Я пробовал собрать на стенде схему без вланов и у меня все отработало, а вот с вланами RSTP не отрабатывает, а радиорезерв нужен. Кто сталкивался или знает что как, очень жду совета и помощи.

Вообще с этой фирмой радиожелезок я работаю давно, также вланы по радио в сети передаются, но вот с stp по радиоканалу во вланах не сталкивался.

Share this post


Link to post
Share on other sites

Не надо нигде включать STP, достаточно включить его на убнт, тогда сам радиоканал отключится, а вот как только пропадет связь с какой-то стороны подключения по кабелю, автоматически произойдет включение радио.

 

Канал на убнт должен работать в режиме WDS.

Share this post


Link to post
Share on other sites

не уверен, но попробуйте прглядеть параметры файла конфигурации на предмет vlan и stp, если vlan были заведены вручную, возмлжно надо вручную stp.enabled=1 прописать.

Share this post


Link to post
Share on other sites

Не надо нигде включать STP, достаточно включить его на убнт, тогда сам радиоканал отключится, а вот как только пропадет связь с какой-то стороны подключения по кабелю, автоматически произойдет включение радио.

 

Канал на убнт должен работать в режиме WDS.

 

Тяжело это представляю на самом деле. Но попробую завтра ан стенде. беда в том, что моя схема работала без вланов, то есть все нормально срабатывало и все работало, а как только собрал полностью рабочую схему - с вланами, то stp перестал отрабатывать. Ведь по логике вещей радиомост просто должен передавать трафик без всяких приблуд и свичи через этот радиомост должны между собой общаться, а у меня получается, что через радиомост не проходят fbpdu от коммутаторов, поэтому порт не блокируется, а продолжает форвардить трафик. Пока что головная боль

 

не уверен, но попробуйте прглядеть параметры файла конфигурации на предмет vlan и stp, если vlan были заведены вручную, возмлжно надо вручную stp.enabled=1 прописать.

 

Вручную в смысле через консоль? Я через веб делал. Сначала создала нужный вланы, потом засовывал их в бридж интерфейс. Вланы то нормально передаются через радиомост, все работает, не работает только stp через радиомост. Просто свичи не обмениваются fbpdu, как писал выше, поэтому порт не блочится. А почему такое происходит пока непонятно

Share this post


Link to post
Share on other sites

Где-то слышал такое, что радиомосты могут не отрабатывать с RSTP, а с STP работают как надо. Завтра это попробую. Если это все выдумки, то просьба поправить)

Share this post


Link to post
Share on other sites

Нет, не через консоль, а сохранив и отредактировав файл конфигурации.

проверьте, что для каждого моста есть запись:

bridge.*.stp.status=enabled

Share this post


Link to post
Share on other sites

Где-то слышал такое, что радиомосты могут не отрабатывать с RSTP, а с STP работают как надо. Завтра это попробую. Если это все выдумки, то просьба поправить)

 

Не радиомосты, а радиомосты на убнт. Это не выдумки а реальный факт. Вам, как я уже и писал, нужно отключить все STP в любых проявлениях на коммутаторах и включить STP на убнт. Для того что бы оно отработало, у вас должно быть физическое кольцо, а ходят по нему вланы, или нет, не важно.

 

Нет, не через консоль, а сохранив и отредактировав файл конфигурации.

проверьте, что для каждого оста есть запись:

bridge.*.stp.status=enabled

 

Это еще что за ковыряние в настройках? Достаточно поставить галочку в нужном окошке и все должно работать. Если на убнт это не так, то его следует заменить на другое оборудование, которое не умеет вышеуказанных недостатков.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this