Jump to content

Proxmox не может запустить виртуальную машину Во время запуска жалуется на видеоадаптер

При запуски появляется ошибка:

kvm: -drive file=/var/lib/vz/images/100/vm-100-disk-1.qcow2,if=none,id=drive-ide0,format=qcow2,aio=native,cache=none,detect-zeroes=on: file system may not support O_DIRECT

kvm: -drive file=/var/lib/vz/images/100/vm-100-disk-1.qcow2,if=none,id=drive-ide0,format=qcow2,aio=native,cache=none,detect-zeroes=on: could not open disk image /var/lib/vz/images/100/vm-100-disk-1.qcow2: Could not open '/var/lib/vz/images/100/vm-100-disk-1.qcow2': Invalid argument

TASK ERROR: start failed: command '/usr/bin/kvm -id 100 -chardev 'socket,id=qmp,path=/var/run/qemu-server/100.qmp,server,nowait' -mon 'chardev=qmp,mode=control' -vnc unix:/var/run/qemu-server/100.vnc,x509,password -pidfile /var/run/qemu-server/100.pid -daemonize -smbios 'type=1,uuid=23f1d264-91c8-408e-bb84-9ac94cf529fc' -name TServer -smp '4,sockets=1,cores=4,maxcpus=4' -nodefaults -boot 'menu=on,strict=on,reboot-timeout=1000' -vga cirrus -cpu kvm64,+lahf_lm,+x2apic,+sep -m 10240 -k en-us -cpuunits 1000 -device 'piix3-usb-uhci,id=uhci,bus=pci.0,addr=0x1.0x2' -device 'usb-tablet,id=tablet,bus=uhci.0,port=1' -device 'virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3' -iscsi 'initiator-name=iqn.1993-08.org.debian:01:5ed3e1eb441e' -drive 'file=/var/lib/vz/template/iso/debian-8.0.0-amd64-DVD-1.iso,if=none,id=drive-ide2,media=cdrom,aio=native' -device 'ide-cd,bus=ide.1,unit=0,drive=drive-ide2,id=ide2,bootindex=200' -drive 'file=/var/lib/vz/images/100/vm-100-disk-1.qcow2,if=none,id=drive-ide0,format=qcow2,aio=native,cache=none,detect-zeroes=on' -device 'ide-hd,bus=ide.0,unit=0,drive=drive-ide0,id=ide0,bootindex=100' -netdev 'type=tap,id=net0,ifname=tap100i0,script=/var/lib/qemu-server/pve-bridge,downscript=/var/lib/qemu-server/pve-bridgedown' -device 'e1000,mac=E6:03:E9:F0:74:81,netdev=net0,bus=pci.0,addr=0x12,id=net0,bootindex=300'' failed: exit code 1

 

В консоле показывает:

root@pve:~# kvm

Could not initialize SDL(No available video device) - exiting

 

root@pve:~# lspci | grep VGA

07:0b.0 VGA compatible controller: ASPEED Technology, Inc. ASPEED Graphics Family (rev 10)

 

Сервер DELL PowerEdge 1100, никто с такой проблемой не сталкивался?

Share this post


Link to post
Share on other sites

kvm: -drive file=/var/lib/vz/images/100/vm-100-disk-1.qcow2,if=none,id=drive-ide0,format=qcow2,aio=native,cache=none,detect-zeroes=on: could not open disk image /var/lib/vz/images/100/vm-100-disk-1.qcow2: Could not open '/var/lib/vz/images/100/vm-100-disk-1.qcow2': Invalid argument

 

Какой адаптер? Он диск найти не может...

Share this post


Link to post
Share on other sites

Напомнило только что прилетевший тикет от клиента:

я новый администратор в компании, подскажите как перезагрузить сервер.

Share this post


Link to post
Share on other sites

Ну что вы так сразу... Тоже не сразу патчить, да компилировать стали... Человек старается, хоть как-то развивается. Пните его просто в нужную сторону.

Share this post


Link to post
Share on other sites

Приветствую !

Сообщение :

 

Parameter verification failed. (400)

 

net1: hotplug problem - VM 1003 qmp command 'netdev_add' failed - Device 'tap' could not be initialized

 

Может быть из - за того что порт сервера eth1 ( в net1) сейчас лежит ?

Share this post


Link to post
Share on other sites

Proxmox не может запустить виртуальную машину

 

Буду очень признателен, если опишете процесс реанимации file system may not support O_DIRECT

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.