Jump to content
Калькуляторы

Нужен скрипт Переподклюсегние PPPOE клиента

Помогите со скриптом

В последнее время провайдер раздает адреса из сети 10.0.0.0/16

Если мой PPPoE-клиент получает такой адрес – никто его не видит, в том числе и NO-IP!

После нескольких переподключений и получении другого белого адреса – все работает!

Задача: Проанализировать полученный адрес от провайдера, и если он из сети 10.0.0.0/16 – то переподключиться – иначе оставить соединение как есть!

Share this post


Link to post
Share on other sites

Купи себе у провайдера белый IP и не мучийся

Share this post


Link to post
Share on other sites

Помогите со скриптом

В последнее время провайдер раздает адреса из сети 10.0.0.0/16

Если мой PPPoE-клиент получает такой адрес – никто его не видит, в том числе и NO-IP!

После нескольких переподключений и получении другого белого адреса – все работает!

Задача: Проанализировать полученный адрес от провайдера, и если он из сети 10.0.0.0/16 – то переподключиться – иначе оставить соединение как есть!

Возможно у провайдера ошибка в настройках. Вопрос провайдеру был почему такая ситуация и ответ на него?

Share this post


Link to post
Share on other sites

После нескольких переподключений и получении другого белого адреса – все работает!

 

Что работает? Опишите подробно

Если появляется интернет то все проще!! Если 8.8.8.8 пингуется при удачном, а при неудачном подключении нет, тогда через tool netwatch

 

/tool netwatch

add comment=reconnect-run down-script="system scheduler set [find comment=reconnect1] disabled=no\r\nsystem scheduler set [find comment=reconnect2] disabled=no" host=8.8.8.8 interval=1s up-script="system scheduler set [find comment=reconnect1] disabled=yes\r\nsystem scheduler set [find comment=reconnect2] disabled=yes\r\ninterface pppoe-client set [find comment=pppoe-1] disabled=no"

 

/system scheduler

add comment=reconnect1 disabled=yes interval=30s name=schedule1 on-event="interface pppoe-client set [find comment=pppoe-1] disabled=yes" start-time=startup

add comment=reconnect2 disabled=yes interval=30s name=schedule2 on-event="interface pppoe-client set [find comment=pppoe-1] disabled=no" start-time=00:00:01

 

Пингуем google host=8.8.8.8, если хотите можно любой другой сервер

В конфиге comment=pppoe-1 это комментарий моего pppoe, у себя напишите свое! У меня в конфигах все по комменту управляется, поэтому комменты, эт обязаловка

 

Итог такой. Если пропадает пинг то ппое выключается на 7с, затем включается на 26с, пинг не появился, заново и т.д. Появился пинг все работает пока не пропадет!!!

Edited by saimon83

Share this post


Link to post
Share on other sites

Помогите со скриптом

В последнее время провайдер раздает адреса из сети 10.0.0.0/16

Если мой PPPoE-клиент получает такой адрес – никто его не видит, в том числе и NO-IP!

После нескольких переподключений и получении другого белого адреса – все работает!

Задача: Проанализировать полученный адрес от провайдера, и если он из сети 10.0.0.0/16 – то переподключиться – иначе оставить соединение как есть!

Возможно у провайдера ошибка в настройках. Вопрос провайдеру был почему такая ситуация и ответ на него?

 

На подобный вопрос с моей стороны к провайдеру, ответили что так и должно быть.

Share this post


Link to post
Share on other sites

Помогите со скриптом

В последнее время провайдер раздает адреса из сети 10.0.0.0/16

Если мой PPPoE-клиент получает такой адрес – никто его не видит, в том числе и NO-IP!

После нескольких переподключений и получении другого белого адреса – все работает!

Задача: Проанализировать полученный адрес от провайдера, и если он из сети 10.0.0.0/16 – то переподключиться – иначе оставить соединение как есть!

Возможно у провайдера ошибка в настройках. Вопрос провайдеру был почему такая ситуация и ответ на него?

 

На подобный вопрос с моей стороны к провайдеру, ответили что так и должно быть.

 

Ну тогда эту проблему не скриптом надо решать,а сменой провайдера.

Share this post


Link to post
Share on other sites

После нескольких переподключений и получении другого белого адреса – все работает!

 

Что работает? Опишите подробно

Если появляется интернет то все проще!! Если 8.8.8.8 пингуется при удачном, а при неудачном подключении нет, тогда через tool netwatch

 

/tool netwatch

add comment=reconnect-run down-script="system scheduler set [find comment=reconnect1] disabled=no\r\nsystem scheduler set [find comment=reconnect2] disabled=no" host=8.8.8.8 interval=1s up-script="system scheduler set [find comment=reconnect1] disabled=yes\r\nsystem scheduler set [find comment=reconnect2] disabled=yes\r\ninterface pppoe-client set [find comment=pppoe-1] disabled=no"

 

/system scheduler

add comment=reconnect1 disabled=yes interval=30s name=schedule1 on-event="interface pppoe-client set [find comment=pppoe-1] disabled=yes" start-time=startup

add comment=reconnect2 disabled=yes interval=30s name=schedule2 on-event="interface pppoe-client set [find comment=pppoe-1] disabled=no" start-time=00:00:01

 

Пингуем google host=8.8.8.8, если хотите можно любой другой сервер

В конфиге comment=pppoe-1 это комментарий моего pppoe, у себя напишите свое! У меня в конфигах все по комменту управляется, поэтому комменты, эт обязаловка

 

Итог такой. Если пропадает пинг то ппое выключается на 7с, затем включается на 26с, пинг не появился, заново и т.д. Появился пинг все работает пока не пропадет!!!

 

Имеется IPSEC туннель.

Адрес из сети 10.0.0.0/16 не дает подняться туннелю IPSEC, нужен белый адрес. А также не доступен извне L2TP сервер.

поэтому и нужно избавляться от такого адреса путем реконнекта интерфейса pppoe.

 

Есть два способа на мой взгляд решить эту проблему не покупая у провайдера Статичейкий белый IP, это:

1- Проанализировать полученный адрес от провайдера, и если он из сети 10.0.0.0/16 – то переподключиться

2- Пинговать локалный адрес удаленного роутера в IPSEC туннуле например 10.10.0.1,если не доступен туннель не поднялся, и нужен реконнект интерфейса pppoe. пытался сделать следующим образом

 

:local hostip 10.10.0.1

:if ([/ping $hostip count=4] = 1) do { /log info "Connect UP"} else {/interface pppoe-client enable pppoe-out1}

 

Результат одинаковый, происходит реконнект интерфейса pppoe и при доступности 10.10.0.1 и при недоступности. прошивка роутера 6,28

Share this post


Link to post
Share on other sites

Помогите со скриптом

В последнее время провайдер раздает адреса из сети 10.0.0.0/16

Если мой PPPoE-клиент получает такой адрес – никто его не видит, в том числе и NO-IP!

После нескольких переподключений и получении другого белого адреса – все работает!

Задача: Проанализировать полученный адрес от провайдера, и если он из сети 10.0.0.0/16 – то переподключиться – иначе оставить соединение как есть!

Возможно у провайдера ошибка в настройках. Вопрос провайдеру был почему такая ситуация и ответ на него?

 

На подобный вопрос с моей стороны к провайдеру, ответили что так и должно быть.

Тут два варианта:-) Или народ глупый или провайдер. Пример, есть вход в здание, шесть дней в неделю в него через проходную можно войти свободно охраны нет, а один день любой стоит охрана и только по пропуску. Вот и у них такая схема или может они про 10 подсеть думают иначе...

Share this post


Link to post
Share on other sites

Сейчас подключение клиентов за NAT при исчерпании белого пула - нормальная практика для многих ISP (а кто-то вообще физиков только за nat вешает), в чем глупость?

Share this post


Link to post
Share on other sites

Да я так и подумал что верно про исчерпание. Ну есть грамотный вариант, всем дать серый, а кому надо в лк могут отключит нат или вообще включить 6 протокол. Пример этому провайдер дом.ру. Основная масса то слова такого не слышала nat, а многие не понимают смысла между динамикой с статикой в сочетании с белым и серым ип.

Edited by dronis3

Share this post


Link to post
Share on other sites

2- Пинговать локалный адрес удаленного роутера в IPSEC туннуле например 10.10.0.1,если не доступен туннель не поднялся, и нужен реконнект интерфейса pppoe

 

/tool netwatch

add comment=reconnect-run down-script="system scheduler set [find comment=reconnect1] disabled=no\r\nsystem scheduler set [find comment=reconnect2] disabled=no" host=10.10.0.1 interval=1s up-script="system scheduler set [find comment=reconnect1] disabled=yes\r\nsystem scheduler set [find comment=reconnect2] disabled=yes\r\ninterface pppoe-client set [find comment=pppoe-1] disabled=no"

 

/system scheduler

add comment=reconnect1 disabled=yes interval=30s name=schedule1 on-event="interface pppoe-client set [find comment=pppoe-1] disabled=yes" start-time=startup

add comment=reconnect2 disabled=yes interval=30s name=schedule2 on-event="interface pppoe-client set [find comment=pppoe-1] disabled=no" start-time=00:00:01

 

Итог такой. Если пропадает пинг 10.10.0.1, то пппое выключается на 7с, затем включается на 26с, пинг не появился, заново и т.д. Появился пинг все работает пока не пропадет!!!

Share this post


Link to post
Share on other sites

Сделал так:

 

:local WANinterface "pppoe-out1"

:local WANip [/ip address get [find interface=$WANinterface] address]

:local shortWANip ( [:pick "$WANip" 0 [:find "$WANip" "." -1]])

:if ($shortWANip = 10) do= {/interface pppoe-client enable pppoe-out1}

} else {/log info "Ne ptinadlegit k seti 10"}}

Share this post


Link to post
Share on other sites

Сделал так:

 

:local WANinterface "pppoe-out1"

:local WANip [/ip address get [find interface=$WANinterface] address]

:local shortWANip ( [:pick "$WANip" 0 [:find "$WANip" "." -1]])

:if ($shortWANip = 10) do= {/interface pppoe-client enable pppoe-out1}

} else {/log info "Ne ptinadlegit k seti 10"}}

Вопрос в другом что многие крупные провайдеры используют провайдерский НАТ где при конекте клиент получает разом белый адрес а разом серый типа 10.ххх.ххх.ххх и сервис NO-IP.com показывает удаленному клиенту это безобразие и надо дергать питание микротику пока тот не поймает белый адрес

Вся проблема в том как автоматизировать этот мозахизм нужен скрипт который бы увидив диапазон безобразия типа 10.ххх.ххх.ххх сам переконекчивал соединения до тех пор пока не будет получен адрес отличный от этого безобразия типа 10.ххх.ххх.ххх и тогда набрав где нибудь в америке (дядя_вася.NO-IP.com)вы с радостью попадете к себе домой.

Share this post


Link to post
Share on other sites

Сделал так:

 

:local WANinterface "pppoe-out1"

:local WANip [/ip address get [find interface=$WANinterface] address]

:local shortWANip ( [:pick "$WANip" 0 [:find "$WANip" "." -1]])

:if ($shortWANip = 10) do= {/interface pppoe-client enable pppoe-out1}

} else {/log info "Ne ptinadlegit k seti 10"}}

 

Вопрос в другом что многие крупные провайдеры используют провайдерский НАТ где при конекте клиент получает разом белый адрес а разом серый типа 10.ххх.ххх.ххх и сервис NO-IP.com показывает удаленному клиенту это безобразие и надо дергать питание микротику пока тот не поймает белый адрес

Вся проблема в том как автоматизировать этот мозахизм нужен скрипт который бы увидив диапазон безобразия типа 10.ххх.ххх.ххх сам переконекчивал соединения до тех пор пока не будет получен адрес отличный от этого безобразия типа 10.ххх.ххх.ххх и тогда набрав где нибудь в америке (дядя_вася.NO-IP.com)вы с радостью попадете к себе домой.

 

 

Ну так вышеприведенный скрипт этим как раз и занимается.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this