Jump to content
Калькуляторы

Не пингуется IP-адрес в общем L2-сегменте Какая-то чертовщика

Есть глобальный VLAN 902, прокинутый по всей сети, который терминируется на Cisco C3750. В этот VLAN подключены IP-камеры.

Используется IP-адресация 10.102.0.0/16, шлюз 10.102.0.250.

В этот VLAN у меня включен ПК для настройки, у него в настройках сетевой карты вручную прописаны IP-адреса 10.102.0.241/16, 192.168.0.241/24 и 192.168.1.241/24. Этот ПК используется для настройки IP-камер; благодаря тому, что он в одном L2-сегменте с камерами, монтажники ставят камеры прямо из коробки (без настройки), я их настраиваю уже после того, как они будут установлены и подключены в коммутатор.

И в принципе эта схема раньше сбоев не давала.

Но сейчас столкнулся с тремя камерами, у которых одна и та же проблема:

1. Камера подключена в порт коммутатора, на порту я вижу ее MAC-адрес.

2. MAC-адрес также виден на C3750, т.е. трафик камеры успешно доходит до ядра.

3. Но с ПК я не могу зайти на камеру по ее заводскому IP-адресу (192.168.1.108), камера не отвечает, в arp-таблице ПК правильной записи не появляется.

4. Я предположил, что возможно на камере другой IP-адрес по какой-то причине. Монтажник с ноутбуком подключился к камере и зашел на нее по 192.168.1.108. С ПК камера по прежнему недоступна.

5. Монтажник прописал на камере IP-адрес 10.102.4.21. Теперь камера пингуется от C3750, доступна из других подсетей (например из офисной). Но из ПК она по прежнему недоступна.

6. К этому коммутатору подключены еще две IP-камеры. Они также не пингуются с ПК, хотя доступны с других подсетей.

7. Но дело не в ПК, поскольку с него нормально работают камеры с других коммутаторов.

 

8. MAC-адрес ПК есть на C3750. Но на конечном коммутаторе его нет.

 

На камере никаких ACL нет. На коммутаторе тоже. Коммутатор, если это важно, QTECH 2900. Остальные две камеры, на которых такая же проблема, тоже подключены к QTECH 2900.

Нет предположений, почему так получается?

Share this post


Link to post
Share on other sites

Одинаковые мак-адреса не нескольких камерах?

Share this post


Link to post
Share on other sites

Одинаковые мак-адреса не нескольких камерах?

Скорее глюк программы, или винды у клиента. Встречал неоднократно на длинках. Решалось включением в их влан, и назначением ip руками. На какую камеру ты попадешь по ИП - неизвестно, но - на какую попал -дай ей ИП иной. И итерация по всем остальным

Share this post


Link to post
Share on other sites

MAC-адреса разные.

Несколько устройств с одним IP не проблема — я просто через arp -s статическую запись делал, пока IP не поменяю на постоянный.

Но в данном случае я на камеру вообще попасть не могу, такое впечатление, что трафик между камерой и ПК не ходит, что-то его блокирует.

Share this post


Link to post
Share on other sites

Да, так и оказалось.

Никакой магии, просто проворонил изоляцию портов в одном месте.

Share this post


Link to post
Share on other sites

Опять чертовщина.

Только на этот раз изоляции портов нет.

 

Есть IP-камера (типа такой, модель чуть другая), у нее заводской IP 192.168.1.2.

В тот же L2-сегмент включен ПК, с которого камера настраивается. На сетевой плате прописаны два IP, 192.168.1.241/24 и 192.168.0.241/24 (без шлюза).

Пингую с этого ПК 192.168.1.2 — не отвечает, то же с telnet и браузером.

Однако при этом в ARP-таблица (arp -a) MAC-адрес камеры появляется. Этот MAC-адрес прописан на этикетке камеры, его же я вижу на порту коммутатора и его же вижу в ARP-таблице.

Еще более интересно — включаю сниффер и вижу ARP-запросы с камеры, которая ищет шлюз (who has 192.168.1.1? tell 192.168.1.2).

То есть трафик ходит (или во всяком случае с камеры до ПК приходит), но камера недоступна.

Я предположил, что возможно камера ответит только 192.168.1.1. Задал на ПК этот IP-адрес — не помогло.

Даже на интерфейсе маршрутизатора (Cisco Catalyst) прописал ip proxy-arp, но камера все равно не отвечает.

 

Нет версий, что этой камере нужно?

Share this post


Link to post
Share on other sites

А с камеры вы себя пингуете или там нету такого инструмента? Точно трафик ходит? Проверьте еще раз настройки порта по которму в этот L2 сегмент включен ПК и порт на камеру (VLAN, изоляцию, ACL, storm control etc), сбросьте winsock и int ip на ПК и назначьте после ребута только 192.168.1.3/24 или шире какой нибудь и уберите все алиясы + очистка arp.

 

Если в этот же момент воткнуть на порт камеры другое устройство ПК\Камеру сразу же его будет видно? Обновите прошивку камеры :)

Edited by hsvt

Share this post


Link to post
Share on other sites

На камере инструментов нет.

Однако когда я на ноутбуке прописал 192.168.1.1 и подключился к камере напрямую, на камеру я зашел.

Сейчас камеру уже настроил на постоянный IP-адрес, тестировать более не на чем.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this