Jump to content

Route Map на MX80

Ребят, есть route-map на циске, выглядит вот так:

 

interface GigabitEthernet0/0.2500
encapsulation dot1Q 2500
ip address 3.3.5.5 255.255.255.252
ip flow ingress
ip flow egress
ip policy route-map test
no cdp enable

ip access-list extended test
permit ip host 2.2.3.2 any
permit ip host 3.3.5.6 any

route-map test permit 10
match ip address test
set ip next-hop 1.2.3.2

 

Все работает, как нужно...

 

Пытаюсь реализовать тоже самое на juniper mx80:

 

run show configuration routing-instances
test {
   instance-type forwarding;
   routing-options {
       static {
           route 0.0.0.0/0 next-hop 6.5.2.2;
       }
   }
}

run show configuration firewall
family inet {
   filter test {
       term test {
           from {
               source-address {
                   9.8.4.6/32;
                   7.6.9.2/32;
               }
           }
           then {
               routing-instance test;
           }
       }
       term default {
           then accept;
       }

run show configuration interfaces ge-0/0/2 unit 2500
vlan-id 2500;
family inet {
   filter {
       input test;
   }
   sampling {
       input;
       output;
   }
   address 9.8.4.5/30;
}

 

Не работает.

 

Намекните, где косяк..

Share this post


Link to post
Share on other sites

Косяк в том, что Можжевельник не умеет set next-hop IP.

Вообще. Никак.

Это делается через rib-group (routing-instance)

 

Если говорить по простому, в качестве next-hop в джунипере можно указать исключительно vrf в котором будут уже какие-то статик роуты.

Share this post


Link to post
Share on other sites

В мануале Juniper почему-то упущено про настройку RIB-groups. Смотрите статью:

http://subnets.ru/blog/?p=2022

 

В KB по джуниперу подробнейшим образом все это расписано.

Share this post


Link to post
Share on other sites

В мануале Juniper почему-то упущено про настройку RIB-groups. Смотрите статью:

http://subnets.ru/blog/?p=2022

 

В учебниках Juniper всё подробно расписано, вроде бы в JNCIS-SP study guide, может быть даже в JNCIA study guide

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.