Jump to content
Калькуляторы

GVRP на HUAWEI

Здравствуйте, уважаемые.

Прошу помощи в следующем вопросе.

Я настроил GVRP между свитчами (HUAWEI S5700). Создал VLAN на первом свитче, этот VLAN появился на втором - всё красиво.

Но я не могу назначить этот VLAN на любой access порт второго свитча:

interface GigabitEthernet 0/0/3
port link-type access
port default vlan 2000

имею ошибку Error: the vlan is a dynamic vlan and cannot be configured

Почитав забугорные форумы понял, что для этого нужно создавать этот же VLAN на втором свитче.

Вопрос: зачем тогда вообще нужен GVRP? или я что-то не так делаю?

Share this post


Link to post
Share on other sites

Чтобы этот VLAN создавался попутно на транзитных коммутаторах.

Share this post


Link to post
Share on other sites

Чтобы этот VLAN создавался попутно на транзитных коммутаторах.

Я чувствую, что вы наверняка правы, но понять до конца пока не могу:

судя по документации, для включения gvrp на требуемом trunk-порту я должен разрешить на этом порту все VLAN (с 1 по 4094):

interface gigabitethernet 0/0/1
port link-type trunk
port trunk allow-pass vlan all

Ну и зачем мне после этого настраивать GVRP, если транзитные свитч и так теперь передаёт фрейм с любым VLAN ID между своими "trunk-all_vlan"??

Share this post


Link to post
Share on other sites

Чтобы не создавать сами влан-ы? Или вы на каждом коммутаторе все 4094 влана объявляете?

Share this post


Link to post
Share on other sites

Ну и зачем мне после этого настраивать GVRP, если транзитные свитч и так теперь передаёт фрейм с любым VLAN ID между своими "trunk-all_vlan"??

Потому что, как отметил уважаемый vurd выше, не смотря на то, что на линке разрешен в ходу весь диапазон VLAN, база данных коммутатора по прежнему пуста (за исключением 1).

Share this post


Link to post
Share on other sites

Чтобы не создавать сами влан-ы? Или вы на каждом коммутаторе все 4094 влана объявляете?

то есть транзит VLAN 2000 не будет работать в таком свитче??:

vlan batch 2 to 10
interface gigabitethernet 0/0/1
port link-type trunk
port trunk allow-pass vlan all
interface gigabitethernet 0/0/2
port link-type trunk
port trunk allow-pass vlan all

Share this post


Link to post
Share on other sites

Я не знаком с синтаксисом хуавея, но если vlan batch 2 to 10 - создать вланы с 2 по 10.

То да, такая конструкция не пропустит 2000 влан между 1 и 2 портами. Чтобы его пропустить, вы должны его объявить, vlan 2000. И вот как раз чтобы на цепочке свитчей не заниматься этим занятием придумали VTP\GVRP.

Share this post


Link to post
Share on other sites

сталкивался с этим на HP 2620,тоже был удивлен изящностью))

type static-vlan vlan "номер влана"

Переводишь из динамик в статик и все гуд

Share this post


Link to post
Share on other sites

type static-vlan vlan "номер влана"

согласен, или сделать:

vlan batch 2000

и тоже будет работать. Но это придётся делать на всех моих свитчах, а я, по неопытности, рассчитывал, что GVRP поможет мне делать это только на одном свитче.

Share this post


Link to post
Share on other sites

Вы кажется так и не поняли базовый принцип.

Вот схема

[клиент 1]-<[свитч 1]-[свитч 2]-[свитч 3]-[свитч 4]->[клиент 2]

У вас задача прокинуть в отдельном влане трафик между [клиент 1] и [клиент 2],

вы разворачиваете на [свитч 1] и [свитч 4] влан, пускай будет, [275], открываете его в режиме access в сторону клиентов, а в сторону магистралей у вас trunk allowed all.

При включенном gvrp на свитчах 2 и 3 будет автоматически создан и пропущен влан 275, он будет считаться динамическим.

Share this post


Link to post
Share on other sites

Вы кажется так и не поняли базовый принцип.

Да нет, я уже понял это.:)

А пишу, что "сделать на всех свитчах", потому что они (свитчи) у меня соединены по принципу звезда.И "транзитных", как таковых, у меня небудет.

Edited by gurlov

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this