Jump to content
Калькуляторы

netmap работает через не стабильно Очень большие задержки при печати.

Это продолжение моей темы, которую я уже давно думал, что закрыл. Ан нет.

 

Кратко:

ethernet3 (192.168.5.1). К нему кабелем (не WiFi) подключен принтер с ip 192.168.5.3.

ethernet5 (192.168.2.252). Подключен к LAN 192.168.2.0/24.

wlan1 (192.168.1.3). Подключен как клиент к сети WiFi 192.168.1.0/24.

 

Надо, чтобы из LAN и из WiFi сети можно было печатать на принтере.

 

Для этого в Mikrotik 951 настроены правила:

/ip firewall nat add chain=dstnat dst-address=192.168.1.3 action=dst-nat to-addresses=192.168.5.3
/ip firewall nat add chain=dstnat dst-address=192.168.2.252 action=dst-nat to-addresses=192.168.5.3

 

Пробовал

/ip firewall nat add chain=dstnat dst-address=192.168.1.3 action=netmap to-addresses=192.168.5.3
/ip firewall nat add chain=dstnat dst-address=192.168.2.252 action=netmap to-addresses=192.168.5.3

 

Идея: если из сети WiFi пингануть (открыть веб-интерфейс/напечатать/другое) на ip 192.168.1.3, то пинги (веб-страница/задание печати/др.) пойдут к принтеру 192.168.5.3. Для сети LAN аналогично.

 

Проблема в том, что вроде бы работает. Но с ужаааасными задержками (до 10-15 минут доходит) идет печать. Печать фото не выходит, принтер печатает отмазки типа I/O Error, syntax error и др. Если подключить принтер напрямую в сеть, все ок. Печатает, весело. Через Mikrotik - опять не стабильно.

 

В iptables все уж разрешил:

[admin@MikroTik] > /ip firewall filter print chain=forward
Flags: X - disabled, I - invalid, D - dynamic 
0    ;;; Drop invalid forward connections
     chain=forward action=drop connection-state=invalid log=no log-prefix="" 

1    ;;; Allow established,related forward connections
     chain=forward action=accept connection-state=established,related log=no log-prefix="" 

2    ;;; Test
     chain=forward action=accept protocol=tcp log=no log-prefix="" 

3    ;;; Test
     chain=forward action=accept protocol=udp log=no log-prefix=""

 

Мне кажется, что где-то теряются пакеты или криво ходят маршруты. Но вроде тут проще уж некуда.

Куда заглянуть еще?

Share this post


Link to post
Share on other sites

Вот заметил, что если отправил на печать задание, он привычно висит, ждет чего-то (на принтере надпись: выполняю задание печати...), и если в этот момент для wlan1 поменять MTU (1500 -> 1400), arp с enabled -> proxy-arp или в обратную сторону, то печатает через минуту (хотя и так долго, вообще говоря). В чем прикол может быть? Совпадение? Или что-то перетряхивается в роутере?

Share this post


Link to post
Share on other sites

Сейчас взял старый добрый (кому как ;)) DLink DP-G321 (это принт-сервер, стаааарый уже). Но! Через USB кабель принтер прекрасно печатает в беспроводной сети, а проводной интерфейс можно подключить в LAN. Т.е. задачу по обеспечению работы принтера в сети я выполнил. Но если вы мне подскажете, что к чему в моем изначальном вопросе, буду рад. Заседание продолжается!

Share this post


Link to post
Share on other sites

Вам надо настроить сеть так, что бы микротик был шлюзом для всех устройств, тогда без пробросов все и так друг на друга попадут. При этом на микротике ничего не придется настраивать или пробрасывать.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this