Jump to content
Калькуляторы

Mikrotik 2 WAN 2 WAN

Не могли бы вы подсказать как правильно настроить что бы часть абонентов шли по первому каналу, а часть по второму.

Подключение абонентов PPPOE (сеть 172.16.0.0/16)

Построено два радиоканала по 100M от одного провайдера.

Ип данные провайдером 212.62.40.77 первый канал,212.62.40.78 второй канал,а шлюз один 212.62.40.113

Будет ли работать с одним шлюзом.Пробую ни как ни получается.

Схема сети примерно вот такая

post-76123-068751100 1416976141_thumb.png

Как правильно реализовать,подскажите.

Share this post


Link to post
Share on other sites

Вам надо поставить 2 микротика для приема каналов оператора. С вашего сервера уже укажете 2 маршрута по IP внутренней сети, тогда и шлюзы будут разные. Раскидать абонентов по каналам можно с помощью маркировки маршрутов, разбив абонентов по IP или через адрес листы.

Share this post


Link to post
Share on other sites

Можешь? показать как выглядят эти каналы в WinBox

Share this post


Link to post
Share on other sites

Можешь? показать как выглядят эти каналы в WinBox

Что именно нужно показать, состояние самих каналов ?

Share this post


Link to post
Share on other sites

Ну, например, в схеме, когда пров дает 1ин шнурок с 4мя данными для PPPoE авторизации (IP получаем динамически) реализовано так:

 

/ip firewall mangle
add action=mark-routing chain=prerouting new-routing-mark=fwd2pppoe1 src-address-list=fwd2pppoe1
add action=mark-routing chain=prerouting new-routing-mark=fwd2pppoe2 src-address-list=fwd2pppoe2
/ip route
add distance=1 gateway=pppoe1 routing-mark=fwd2pppoe1
add distance=1 gateway=pppoe2 routing-mark=fwd2pppoe2

 

Сами интерфейсы:

 

> interface pppoe-client print terse
0  R name=pppoe1 add-default-route=no ...bla-bla-bla...
1  R name=pppoe2 add-default-route=no ...bla-bla-bla...

Т.е. дефолтов даже не принимаю от ISP.

Share this post


Link to post
Share on other sites

Вроде бы всё получилось разбросать по каналам

/ip firewall mangle
add action=add-src-to-address-list address-list=ISP1 chain=prerouting per-connection-classifier=src-address:2/1 src-address=192.168.88.0/24
add action=add-src-to-address-list address-list=ISP2 chain=prerouting per-connection-classifier=src-address:2/0 src-address=192.168.88.0/24
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=to_ISP1 passthrough=no src-address-list=ISP1
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=to_ISP2 passthrough=no src-address-list=ISP2



/ip route
add check-gateway=ping distance=10 gateway=192.168.86.1 routing-mark=to_ISP1
add distance=100 gateway=192.168.85.1 routing-mark=to_ISP1
add check-gateway=ping distance=10 gateway=192.168.85.1 routing-mark=to_ISP2
add distance=100 gateway=192.168.86.1 routing-mark=to_ISP2

 

раскидывает абонов по разным каналам, но теперь нет доступа к админке ,

которая висит на 80 порту , и у абонентов не работает личный кабинет на 443 порту.

Что вы посоветуете , как правильно сделать.

 

Админка и личный кабинет находится за натом

/ip firewall nat
add action=masquerade chain=srcnat src-address=7.7.7.0/28
add action=dst-nat chain=dstnat dst-port=80 protocol=tcp src-address=\
   7.7.7.0/28 to-addresses=10.10.254.2 to-ports=80
add action=masquerade chain=srcnat src-address=172.16.0.0/16
add action=dst-nat chain=dstnat dst-address=212.62.40.77 dst-port=2222 \
   protocol=tcp to-addresses=10.10.254.2 to-ports=22
add action=masquerade chain=srcnat src-address=10.10.254.2
add action=dst-nat chain=dstnat dst-address=212.62.40.77 dst-port=80 \
   protocol=tcp to-addresses=10.10.254.2 to-ports=80
add action=dst-nat chain=dstnat dst-address=212.62.40.77 dst-port=443 \
   protocol=tcp to-addresses=10.10.254.2 to-ports=443

 

подсеть 7.7.7.0/28 для должников

 

Что бы вы посоветовали.

Share this post


Link to post
Share on other sites

Ну так на эту сеть идет перенаправление. Вам надо либо перевести личный кабинет и все другие сети в серую 192.168, либо при маркировке маршрутов использовать адреслисты, в которых укажете все сети (на вкладке advanced). Суть в том, что бы при запросах внутри сети маркировка не производилась.

Share this post


Link to post
Share on other sites

А если сделать так: бондинг балансер rr это не вариант?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this