Jump to content
Калькуляторы

Проблема с портами

Имеем схему подключения типа звезда. В распределении cisco 4500 к ней подключено 8-мь cisco 2960 по гигабиту.

Проблема в следующем на каждом оборудовании имею логи типа:

001152: Sep 15 13:15:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/20, changed state to down

001153: Sep 15 13:15:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/20, changed state to up

001154: Sep 15 13:46:42: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to down

001155: Sep 15 13:46:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to up

 

И так на каждой железке.

Конфига:

WS-C2960-24TC-L (C2960-LANBASE-M), Version 12.2(35)SE5. Да IOS древний как .... буду менять.

 

interface FastEthernet0/11

switchport access vlan 4

switchport mode access

no cdp enable

spanning-tree portfast

spanning-tree bpduguard enable

 

FastEthernet0/11 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 0023.056f.4c8b (bia 0023.056f.4c8b)

Description: INF:Stuff

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 10/100BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:00:01, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

9484084 packets input, 1234156842 bytes, 0 no buffer

Received 38588 broadcasts (0 multicasts)

0 runts, 1 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 29099 multicast, 0 pause input

0 input packets with dribble condition detected

35477917 packets output, 22868054115 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

 

Еще добавлю в сети присутствует VTP + svi в 1-ом влане (НЕ мой огород).

 

+ На одной из железке STP отработало

sh int fa 0/18

FastEthernet0/18 is administratively down, line protocol is down (disabled)

Hardware is Fast Ethernet, address is 0023.05cd.5292 (bia 0023.05cd.5292)

sh spanning-tree

 

VLAN0001

Spanning tree enabled protocol rstp

Root ID Priority 24577

Address 0022.90a5.0600

Cost 4

Port 25 (GigabitEthernet0/1)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

 

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)

Address 0022.be16.8280

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

 

Interface Role Sts Cost Prio.Nbr Type

 

 

 

Склоняюсь к том что, перестраивается STP (как мне решить эту проблему). Возможно нет согласование (но это на каждой железке и на нескольких портах). А самое банальное петля. Нигде на портах не замечал CRC/erro-ов. Буду благодарен советами.

Share this post


Link to post
Share on other sites

Склоняюсь к том что, перестраивается STP

 

spanning-tree logging

чтобы иметь более информативные логи, если это все-таки стп.

Share this post


Link to post
Share on other sites

spanning-tree logging прописал на 2-уж железках. Я так понимаю если беда в STP в логах сразу должно отобразиться ?

Share this post


Link to post
Share on other sites

interface FastEthernet0/11

switchport access vlan 4

switchport mode access

no cdp enable

spanning-tree portfast

spanning-tree bpduguard enable

 

Это какой порт? Аплинк до распределения? Если да, то там не нужен portfast и bpduguard. С обоих сторон.

 

sh int fa 0/18

FastEthernet0/18 is administratively down, line protocol is down (disabled)

Hardware is Fast Ethernet, address is 0023.05cd.5292 (bia 0023.05cd.5292)

sh spanning-tree

 

STP не отключает порт административно.

 

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Root FWD 19        128.1    P2p
Fa0/3            Altn BLK 19        128.3    P2p

 

Если срабатывает bpduguard - то будет errdisable.

FastEthernet0/1 is down, line protocol is down (err-disabled)

И если у Вас cisco - то почему rstp? а не pvstp/rapid-pvstp

 

Топология звезда - откуда там петли и перестроение stp? К 8 портовым коммутаторам что подключается?

Share this post


Link to post
Share on other sites

Это какой порт? Аплинк до распределения?

Нет это на доступе

И если у Вас cisco - то почему rstp? а не pvstp/rapid-pvstp

Да у нас Cisco:

#spanning-tree mode ?

mst Multiple spanning tree mode

pvst Per-Vlan spanning tree mode

rapid-pvst Per-Vlan rapid spanning tree mode

 

и

sh spanning-tree

 

VLAN0001

Spanning tree enabled protocol rstp

Компы не больше ни меньше

Share this post


Link to post
Share on other sites

001152: Sep 15 13:15:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/20, changed state to down

001153: Sep 15 13:15:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/20, changed state to up

001154: Sep 15 13:46:42: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to down

001155: Sep 15 13:46:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to up

 

Если это просиходит на порту, в который включен один комп - то вполне вероятно, что просто сетевая карта отключается из за сбережения энергии. В свойствах сетевой карты "Разрешать отключение этого устройства для экономии энергии".

Share this post


Link to post
Share on other sites

А что мешает исключить vlan из STP если вы его не используете?

Глобально no spanning-tree vlan и список vlan

 

P.S. Если не используете CDP, отключите его глобально no cdp run что бы каждый раз не прописывать на портах

Edited by FATHER_FBI

Share this post


Link to post
Share on other sites

А что мешает исключить vlan из STP если вы его не используете?

Я думаю это решиться отключением VTP, как мне кажется.

Вообщем будем смотреть, что там происходит на концах и принимать меры. А так спасибо

Share this post


Link to post
Share on other sites

А что мешает исключить vlan из STP если вы его не используете?

Я думаю это решиться отключением VTP, как мне кажется.

Вообщем будем смотреть, что там происходит на концах и принимать меры. А так спасибо

А вы можете написать какие у вас вообще требования с cisco? Потому что мы у себя используем cisco на access.

Вот конфиг с моих свичей

version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname *************
!
aaa new-model
aaa authentication login default group tacacs+ local-case
aaa authentication enable default group tacacs+ enable
aaa authorization exec default group tacacs+ local
aaa authorization network default group tacacs+ local
enable secret 5 ********
!
username admin privilege 15 secret 5 ******.
errdisable recovery cause udld
errdisable recovery cause bpduguard
errdisable recovery cause security-violation
errdisable recovery cause channel-misconfig
errdisable recovery cause pagp-flap
errdisable recovery cause dtp-flap
errdisable recovery cause link-flap
errdisable recovery cause psecure-violation
errdisable recovery cause gbic-invalid
errdisable recovery cause dhcp-rate-limit
errdisable recovery cause unicast-flood
errdisable recovery cause vmps
errdisable recovery cause loopback
errdisable recovery interval 30
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
vtp mode transparent
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 4,117,1011
!
!
!
!
vlan 4
name Tupik
!
vlan 117
name u117
!
vlan 1011
name ab1011
!
interface FastEthernet0/1
description IPoE abonents
switchport access vlan 1011
switchport mode access
switchport port-security
switchport port-security maximum 3
switchport port-security violation restrict
ip access-group dhcp_control in
storm-control broadcast level pps 200 150
storm-control multicast level 60.00 30.00
storm-control action shutdown
storm-control action trap
spanning-tree portfast
spanning-tree bpdufilter enable
!
interface FastEthernet0/2
description IPoE abonents
switchport access vlan 1011
switchport mode access
switchport port-security
switchport port-security maximum 3
switchport port-security violation restrict
ip access-group dhcp_control in
storm-control broadcast level pps 200 150
storm-control multicast level 60.00 30.00
storm-control action shutdown
storm-control action trap
spanning-tree portfast
spanning-tree bpdufilter enable
!
!
!
!
interface FastEthernet0/47
description IPoE abonents
switchport access vlan 1011
switchport mode access
switchport port-security
switchport port-security maximum 3
switchport port-security violation restrict
ip access-group dhcp_control in
storm-control broadcast level pps 200 150
storm-control multicast level 60.00 30.00
storm-control action shutdown
storm-control action trap
spanning-tree portfast
spanning-tree bpdufilter enable
!
interface FastEthernet0/48
description Management
switchport trunk allowed vlan 117
switchport mode trunk
!
interface GigabitEthernet0/1
description Downlink
switchport trunk native vlan 4
switchport trunk allowed vlan 117,1011
switchport mode trunk
!
interface GigabitEthernet0/2
description Uplink
switchport trunk native vlan 4
switchport trunk allowed vlan 117,1011
switchport mode trunk
ip dhcp snooping trust
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan117
ip address 172.16.117.172 255.255.255.0
no ip route-cache
!
ip default-gateway 172.16.117.1
no ip http server
logging trap notifications
logging facility local0
logging 172.16.30.55
access-list 100 remark dhcp_control
access-list 100 deny   udp any eq bootps any
access-list 100 permit ip any any
no cdp run
snmp-server community public RO
snmp-server community private RW
snmp-server user private private v1 
snmp-server user private private v2c 
snmp-server host 172.16.30.50 v2c 
snmp ifmib ifalias long
tacacs-server host 172.16.30.57
tacacs-server key 7 13021D07120A0F283222213120281B0D1A0013546241555C000114105D5E595E5557440748
!
line con 0
line vty 5 15
!
!
end

Share this post


Link to post
Share on other sites

VTP то тут как по вашему участвует? :) проблемы на порту доступа - ищите проблему в последней миле.

Edited by DejaVu

Share this post


Link to post
Share on other sites

проблемы на порту доступа - ищите проблему в последней миле.

Начали поиски

Еще такой момент от %C4K_L2MAN-6-INVALIDSOURCEADDRESSPACKET: (Suppressed 2 times)Packet received with invalid source MAC address (00:00:00:00:00:00) вот такой ерунды я так понял поможет или ACl или storm-control ? Кто сталкивался ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this