Jump to content
Калькуляторы

VRF. Проблемы.

Уважаемые гуру, почему такая конфигурация не работает?

 

Интерфейсы Te3/1 и Te4/3 соединены между собой патчкордом.

 

Gateway# sh run int vlan 15
Building configuration...

Current configuration : 88 bytes
!
interface Vlan15
ip vrf forwarding VRF_BGP
ip address 10.0.0.1 255.255.255.252
end

Gateway# sh run int vlan 5 
Building configuration...

Current configuration : 60 bytes
!
interface Vlan5
ip address 10.0.0.2 255.255.255.252
end

Gateway# sh run int Te3/1
Building configuration...

Current configuration : 102 bytes
!
interface TenGigabitEthernet3/1
switchport
switchport access vlan 15
switchport mode access
end

Gateway# sh run int Te4/3
Building configuration...

Current configuration : 116 bytes
!
interface TenGigabitEthernet4/3
switchport
switchport access vlan 5
switchport mode access
no cdp enable
end

Gateway# ping 10.0.0.1 

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Gateway# 

 

ЗЫ: Задача простая необходимо часть трафика между VRF и Global гонять через бридж (DPI).

Share this post


Link to post
Share on other sites

Роут ликинг нафиг не нужен если это физикал луп.

1) Сам VRF создан, ведь так?

2) Знаю что мало вероятно, НО коммутатор точно умеет BIA?

без BIA невзлетит.

3) И да, проверьте, сами вланы то в апе аще?

Edited by myst

Share this post


Link to post
Share on other sites

У вас случайно мак адреса на vlan интерфейсах не совпадают ?

Share this post


Link to post
Share on other sites

Проблема в мак-адресах. Их нужно поменять на обоих vlan-ах.

Share this post


Link to post
Share on other sites

Проблема в мак-адресах. Их нужно поменять на обоих vlan-ах.

Не все коммутаторы это умеют читаем п 2) моего ответа.

Share this post


Link to post
Share on other sites

Gateway# sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------

...

5    VLAN0005                         active    Te4/3

...

15   VLAN0015                         active    Te3/1

...

 

Gateway# sh int Te3/1
TenGigabitEthernet3/1 is up, line protocol is up (connected)
 Hardware is C6k 10000Mb 802.3, address is 0013.c3b6.a3b0 (bia 0013.c3b6.a3b0)
 MTU 1500 bytes, BW 10000000 Kbit/sec, DLY 10 usec, 
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 Keepalive set (10 sec)
 Full-duplex, 10Gb/s
 Transport mode LAN (10GBASE-R, 10.3125Gb/s)
 input flow-control is off, output flow-control is off
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input 3d23h, output 00:00:07, output hang never
 Last clearing of "show interface" counters 2d01h
 Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
    200717 packets input, 14843996 bytes, 0 no buffer
    Received 188349 broadcasts (119845 multicasts)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast, 0 pause input
    0 input packets with dribble condition detected
    2986 packets output, 1278924 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 unknown protocol drops
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 pause output
    0 output buffer failures, 0 output buffers swapped out

Gateway# sh int Te4/3
TenGigabitEthernet4/3 is up, line protocol is up (connected)
 Hardware is C6k 10000Mb 802.3, address is 0012.d944.6422 (bia 0012.d944.6422)
 MTU 1500 bytes, BW 10000000 Kbit/sec, DLY 10 usec, 
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 Keepalive set (10 sec)
 Full-duplex, 10Gb/s
 Transport mode LAN (10GBASE-R, 10.3125Gb/s)
 input flow-control is off, output flow-control is off
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input 00:00:13, output 3w6d, output hang never
 Last clearing of "show interface" counters 2d01h
 Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
    2986 packets input, 1278924 bytes, 0 no buffer
    Received 2986 broadcasts (2976 multicasts)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast, 0 pause input
    0 input packets with dribble condition detected
    200717 packets output, 14843996 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 unknown protocol drops
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 pause output
    0 output buffer failures, 0 output buffers swapped out
Gateway# 

Share this post


Link to post
Share on other sites

sh int vlan 5 & 15

Маки на физ. портах особо не интересны.

Edited by myst

Share this post


Link to post
Share on other sites

Роут ликинг нафиг не нужен если это физикал луп.

1) Сам VRF создан, ведь так?

2) Знаю что мало вероятно, НО коммутатор точно умеет BIA?

без BIA невзлетит.

3) И да, проверьте, сами вланы то в апе аще?

 

1.

 

ip vrf VRF_BGP

rd 48XXX:100

 

Этого хватит?

 

2. Ищю что это такое.

3. Да, всё в UP.

 

sh int vlan 5 & 15

Маки на физ. портах особо не интересны.

 

Gateway# sh int vlan 5
Vlan5 is up, line protocol is up 
 Hardware is EtherSVI, address is 001c.0f5e.c080 (bia 001c.0f5e.c080)
 Internet address is 10.0.0.2/30
 MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec, 
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 Keepalive not supported 
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input 00:00:00, output 00:07:40, output hang never
 Last clearing of "show interface" counters 2d01h
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 340000 bits/sec, 602 packets/sec
 5 minute output rate 341000 bits/sec, 602 packets/sec
 L2 Switched: ucast: 39336667 pkt, 33417412923 bytes - mcast: 25652 pkt, 2250612 bytes
 L3 in Switched: ucast: 805956 pkt, 60051220 bytes - mcast: 0 pkt, 0 bytes mcast
 L3 out Switched: ucast: 819108 pkt, 61030996 bytes mcast: 0 pkt, 0 bytes
    1666823 packets input, 121765705 bytes, 0 no buffer
    Received 38162 broadcasts (483 IP multicasts)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    1684885 packets output, 121625420 bytes, 0 underruns
    0 output errors, 0 interface resets
    0 unknown protocol drops
    0 output buffer failures, 0 output buffers swapped out

Gateway# sh int vlan 15
Vlan15 is up, line protocol is up 
 Hardware is EtherSVI, address is 001c.0f5e.c080 (bia 001c.0f5e.c080)
 Internet address is 10.0.0.1/30
 MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec, 
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 Keepalive not supported 
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input 00:00:05, output 00:07:42, output hang never
 Last clearing of "show interface" counters 2d01h
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
 L2 Switched: ucast: 101 pkt, 8060 bytes - mcast: 353 pkt, 29977 bytes
 L3 in Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes mcast
 L3 out Switched: ucast: 0 pkt, 0 bytes mcast: 0 pkt, 0 bytes
    4357 packets input, 295002 bytes, 0 no buffer
    Received 4354 broadcasts (0 IP multicasts)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    14 packets output, 964 bytes, 0 underruns
    0 output errors, 0 interface resets
    0 unknown protocol drops
    0 output buffer failures, 0 output buffers swapped out
Gateway# 

Share this post


Link to post
Share on other sites

Ну вот вам и ответ.

001c.0f5e.c080

 

Гуглите на предмет uniq bia для вашего коммутатора.

Edited by myst

Share this post


Link to post
Share on other sites

Не все коммутаторы это умеют читаем п 2) моего ответа.

 

Да, я видел :)

У ТС: Hardware is C6k, там это работает.

 

int vlan 1

mac-address 0000.1111.2222

int vlan 2

mac-address 1111.0000.2222

 

Кстати. У меня как-то с включенным MSTP такой финт не прошел. Трафик не ходил и всё. Пока в pvst не переключил, так и не работало. Вот в чем могло быть дело?

Share this post


Link to post
Share on other sites

Не все коммутаторы это умеют читаем п 2) моего ответа.

 

Да, я видел :)

У ТС: Hardware is C6k, там это работает.

 

int vlan 1

mac-address 0000.1111.2222

int vlan 2

mac-address 1111.0000.2222

 

Кстати. У меня как-то с включенным MSTP такой финт не прошел. Трафик не ходил и всё. Пока в pvst не переключил, так и не работало. Вот в чем могло быть дело?

ой ненене, про STP это не ко мне, я их боюс =))

Share this post


Link to post
Share on other sites

Всем большое спасибо. Всё заработало. Тему можно закрывать.

 

ЗЫ: vurd, myst, orlik - реально гуру. (:

Share this post


Link to post
Share on other sites

Не все коммутаторы это умеют читаем п 2) моего ответа.

 

Да, я видел :)

У ТС: Hardware is C6k, там это работает.

 

int vlan 1

mac-address 0000.1111.2222

int vlan 2

mac-address 1111.0000.2222

 

Кстати. У меня как-то с включенным MSTP такой финт не прошел. Трафик не ходил и всё. Пока в pvst не переключил, так и не работало. Вот в чем могло быть дело?

 

Может быть в том, что mstp работает до вланов, а per vlan stp работает внутри вланов ?

 

Ну т.е. mstp пофик на вланы, оно смотрит на хеш вланов и если не совпадает , то начинает работать как common spanning tree, но всё равно до вланских тагов. Таким образом можно накольцевать какие попало порты (по конфигурации) и mstp всёравно должно победить :-).

 

Это предположение.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this