Jump to content
Калькуляторы

Quagga не заносит информацию о маршруте назначения при работе через ebgp-multihop

И так, я пробую поднять ebgp-multihop в quagga. Вроде всё поднялось, однако если посмотреть в системную таблицу маршрутизации, то там видно, что маршрут не добавился правильно. Вот, типичный конфиг:

 

Я:

telnet 127.0.0.1 zebra
enable
configure terminal
interface eth0
ip address 192.168.88.1/32
exit
ip route 0.0.0.0/0 192.168.252.1
exit
exit

 

telnet 127.0.0.1 bgpd
enable
configure terminal
router bgp 6466
network 18.188.18.0/24
neighbor 192.168.252.1 remote-as 1211
neighbor 192.168.252.1 ebpg-moltihop 10
!redistribute ospf
exit
exit

 

Работодатель:

 

(часть конфика скрыта)
router bgp 1211
neighbor 192.168.88.1 remote-as 6466
neighbor 192.168.88.1 ebpg-moltihop 10
exit
exit

 

Теперь смотрим системную таблицу маршрутов работодателя:

ip route show|grep 18.188.18.0/24
18.188.18.0/24 dev tap100

 

По идее должен быть:

18.188.18.0/24 via 192.168.88.1 dev tap100

 

Но, почемуто в системную таблицу маршритизации ip моего интерфейса(via) не поподает.

 

Если хопы в одной сети - то всё нормально.

 

Если смотреть зебру - тоже всё нормально.

 

Баг это или особинность протокола?

 

Кстати, это не у меня одного.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this