Jump to content
Калькуляторы

Nexus 7000 и EoMPLS

Доброго времени суток!

 

Есть пара nexus 7k и нужно настроить между ними EoMPLS.

Всё вроде бы хорошо: LDP есть, "xconnect" проходит, но сам трафик не ходит, по счётчикам видно, что уходят только пакеты, но ничего не приходит по mpls.

 

Ниже представлен конфиг:

 

interface loopback24

ip address x.x.24.2/32

 

interface Ethernet3/23.995

mpls ldp discovery transport-address interface

mpls ip

description mpls-test-vf

mtu 9126

encapsulation dot1q 995

ip address x.x.254.93/30

no shutdown

 

interface Ethernet3/22.58

description c1-mpls

mtu 9216

encapsulation dot1q 58

no shutdown

 

mpls ldp configuration

router-id Lo24 force

 

port-profile type pseudowire cm

encapsulation mpls

vc type ethernet

state enabled

 

l2vpn xconnect context core

member Ethernet3/22.58

member x.x.24.1 58 port-profile cm

 

Выход по команлам:

 

sh mpls ldp nei

Peer LDP Ident: x.x.24.1:0; Local LDP Ident x.x.24.2:0

TCP connection: x.x.24.1.646 - x.x.24.2.32754

State: Oper; Msgs sent/rcvd: 69/97; Downstream

Up time: 00:15:54

LDP discovery sources:

Targeted Hello x.x.24.2 -> x.x.24.1, active, passive

Addresses bound to peer LDP Ident:

 

sh mpls l2 vc 58 deta

 

Local interface: Eth3/22.58 up, Eth VLAN up

Interworking type is Ethernet

Destination address: x.x.24.1, VC ID: 58, VC status: up

Output interface: Ethernet3/23.995, imposed label stack {40}

Preferred path: not configured

Default path: active

Next hop: x.x.254.94

Create time: 1d17h, last status change time: 00:08:51

Last label FSM state change time: 00:08:51

Signaling protocol: LDP, peer x.x.24.1:0 up

Targeted Hello: x.x.24.2(LDP Id) -> x.x.24.1, LDP is UP

Graceful restart: configured and enabled

Non stop routing: not configured and not enabled

Status TLV support (local/remote) : enabled/supported

LDP route watch : enabled

Label/status state machine : established, LruRru

Last local dataplane status rcvd: No fault

Last BFD dataplane status rcvd: Not sent

Last BFD peer monitor status rcvd: No fault

Last local AC circuit status rcvd: No fault

Last local AC circuit status sent: No fault

Last local PW i/f circ status rcvd: No fault

Last local LDP TLV status sent: No fault

Last remote LDP TLV status rcvd: No fault

Last remote LDP ADJ status rcvd: No fault

MPLS VC labels: local 34, remote 40

Group ID: local 0, remote 0

MTU: local 9216, remote 9216

Remote interface description: c2-mpls

Sequencing: receive disabled, send disabled

Control Word: On (configured: autosense)

VC statistics:

transit packet totals: receive 0, send 51

transit byte totals: receive 0, send 3264

transit packet drops: receive 0, seq error 0, send 0

 

Второй сконфигурирован анологично, разница лишь в ip адресах на интерфейсах. Оба устройства соединены на прямую. Не могу понять почему не бегает трафик...

 

На обоих коммутаторах версия NSox : version 6.2(6)

Share this post


Link to post
Share on other sites

Вы это имели ввиду?

 

ping mpls pseudowire x.x.24.1 58

 

Sending 5, 100-byte MPLS Echos to x.x.24.1,

timeout is 2 seconds, send interval is 0 msec:

 

Codes: '!' - success, 'Q' - request not sent, '.' - timeout,

'L' - labeled output interface, 'B' - unlabeled output interface,

'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,

'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,

'P' - no rx intf label prot, 'p' - premature termination of LSP,

'R' - transit router, 'I' - unknown upstream index,

'X' - unknown return code, 'x' - return code 0

 

Type Ctrl-C to abort.

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

Total Time Elapsed 10 ms

Share this post


Link to post
Share on other sites

я конеш нексусы не трогал никогда, но:

1) в манах первым делом предлагают включить "feature evc". включен?

2) на разных концах xconnect'а совпадают vlan? (у вас в примере 58)

Share this post


Link to post
Share on other sites

я конеш нексусы не трогал никогда, но:

1) в манах первым делом предлагают включить "feature evc". включен?

2) на разных концах xconnect'а совпадают vlan? (у вас в примере 58)

1) он включен, но на данной схеме вроде он не особо нужен.

2) вланы совпадают, дальше нексусов идут каталисты, там разрешен только этот влан и поднят l3 интерфейс с vrf.

sh run int gi3/15

Building configuration...

 

Current configuration : 217 bytes

!

interface GigabitEthernet3/15

description mpls-test

switchport trunk allowed vlan 58

switchport mode trunk

mtu 9198

ip device tracking maximum 0

ip access-group 166 in

load-interval 30

no cdp enable

end

 

interface Vlan58

description testmpls2

ip vrf forwarding cm2

ip address 10.0.0.2 255.255.255.252

end

 

 

3) лицензия есть? или они не энфорсятся?

Лицензии включены все, что есть.

install feature-set mpls

allow feature-set mpls

feature-set mpls

feature mpls l3vpn

feature mpls traffic-eng

feature mpls ldp

feature mpls l2vpn

Share this post


Link to post
Share on other sites

а у вас в нексусе случаем не F2 платы стоят? если да, то они mpls не умеют.

Share this post


Link to post
Share on other sites

а у вас в нексусе случаем не F2 платы стоят? если да, то они mpls не умеют.

Собираем на 1g модуле N7K-M148GT-11L - это модуль серии M1. В качестве Fabric card module стоит N7K-C7009-FAB-2.

Share this post


Link to post
Share on other sites

Завели ticket. Cisco спрашивала различную служебную информацию информацию. И тоже молчат.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this