Jump to content
Калькуляторы

mikrotik ospf pptp

есть mikrotik ccr-1036 не нем поднят gre туннели между офисами маршрутизация между офисами осуществляется через ospf так же на нем поднят pptp сервер так вот когда пользователь коннектится через pptp ему выдается ip из сети 10.0.6.0/24 и он не может попасть в другие офисы я так понимаю в ospf не распространяются статические маршруты

> export compact 
/interface ethernet
set [ find default-name=ether2 ] name=lan_eth2
set [ find default-name=ether1 ] name=wan_eth1
/interface gre
add local-address=91.216.x.x mtu=1450 name=ostrovtsy_kdms remote-address=\
   109.206.x.x

/ip address
add address=91.216.x.x/24 comment="default configuration" interface=wan_eth1 \
   network=91.216.x.0
add address=172.16.0.20/16 interface=lan_eth2 network=172.16.0.0
add address=10.0.91.1/30 interface=ostrovtsy_kdms network=10.0.91.0

/ip dns
set allow-remote-requests=yes servers=172.16.0.5,8.8.8.8

/ip firewall nat
add action=masquerade chain=srcnat src-address=10.0.6.0/24
/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set irc disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
/ip route
add distance=1 gateway=91.216.x.x
/ppp secret
add local-address=10.0.6.1 name=test password=pass \
   profile=default-encryption remote-address=10.0.6.2

/routing ospf interface
add cost=100 interface=ostrovtsy_kdms network-type=point-to-point
/routing ospf nbma-neighbor
add address=10.0.90.2 disabled=yes
/routing ospf network
add area=backbone network=10.0.91.0/30
add area=backbone network=172.16.0.0/16
add area=backbone network=10.0.6.0/24

/ip route> print

Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
#      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
0 A S  0.0.0.0/0                          91.216.48.1               1
5 ADC  10.0.6.2/32        10.0.6.1        <pptp-test        0
7 ADo  10.0.8.0/24                        10.0.91.2               110
11 ADo  10.0.9.0/24                        10.0.91.2               110
16  Do  10.0.90.0/30                       10.0.91.2               110
17 ADC  10.0.91.0/30       10.0.91.1       ostrovtsy_kdms            0
19 ADC  10.0.93.0/30       10.0.93.1       tpso-megafon              0
20 ADo  10.0.94.0/30                       10.0.91.2               110
26 ADC  91.216.x.x/24     91.216.x.x     wan_eth1                  0
28 ADC  172.16.0.0/16      172.16.0.20     lan_eth2                  0

это с клиента pptp

tracert 10.0.8.8

Трассировка маршрута к 10.0.8.8 с максимальным числом прыжков 30

 1    72 ms    79 ms    79 ms  10.0.6.1
 2    57 ms    49 ms    49 ms  10.0.91.2
 3     *        *        *     Превышен интервал ожидания для запроса.
 4     *        *        *     Превышен интервал ожидания для запроса.

Share this post


Link to post
Share on other sites

Попробуйте так:

 

routing ospf instance set redistribute-connected=as-type-1

Share this post


Link to post
Share on other sites

нет, у него же статика не распространяется.

 

redistribute-static=as-type-1 конечно же!

Share this post


Link to post
Share on other sites

я на cisco так делал

router ospf 100
router-id 172.16.0.20
redistribute connected subnets route-map vpn
access-list 10 permit 10.0.6.0 0.0.0.255
route-map vpn permit 10
match ip address 10

а вот на microtik не понимаю как это сделать

Share this post


Link to post
Share on other sites

Что бы работало OSPF по любым каналам связи, достаточно выполнить команду:

 

/routing ospf network

add area=backbone network=0.0.0.0/0

 

После чего по всем произойдет обмен маршрутами. Естественно сеть можете указать и меньше, например ту или те, которые используются на устройстве. Если что-то не работает - ищите проблему в другом месте, например по каналам большие пакеты не проходят, или под нат попадают и т.п.

Share this post


Link to post
Share on other sites

в /routing ospf network сеть обявлена

/routing ospf network> print

5 10.0.6.0/24 backbone

 

как я показывал выше это с клиента pptp

там видно что пакет в филиал попал а именно он пришел на тунельный интерфейс а дальше не идет

Share this post


Link to post
Share on other sites

Proxy-arp?

спасибо действительно проблема была в этом

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this