Jump to content
Калькуляторы

Создание тарифа Abills radius,nas,mikrotik,abills

Здравствуйте, имеются вот такие настройки, подскажите что упустил, на микротике при попытке подключения в логах пишет radius timeout.

 

Настройка NAS

IP: IP микротика на котором крутиться pppoe демон и на котором во вкладке radius я указал ip и пароль для доступа к freeradius на этом компьютере

Название (a-ZA-Z0-9_): произвольно

Radius NAS-Identifier: пусто

Описание: NAS Server

Тип: Mikrotik

MAC: пусто

Модель: пусто

Авторизация: пусто

External Accounting: пусто

Alive (sec.): 300

Отключено: галочка не стоит

 

Управление:

IP:PORT: mikrotikip:1700:22

Пользователь: admin_ssh

Пароль: к радиусу который указан в конфиге радиуса(/usr/local/etc/raddb/clietnts.conf) в секции clients { ... }

 

Вот сама секкция в clients.conf с ip nas моего микротика с pppoe.

 

client ipmikrotik {

secret = radsecret

}

 

Планы

Настройка->Интернет->Тарифные планы->Добавить

1. выбрал имя тарифа 5mb к примеру

2. Абонплата за месяц: выбрал 200

3. Radius Parameters: Mikrotik-Rate-Limit="5M 5536k 768k 8 8 5M"

Нажал Изменить.

 

Создание пользователя

Клиенты->Логины->Интернет->Пользователи Добавить

1. вписал имя пользователя и пароль выбрал тариф 5mb.

Нажал Добавить.

 

На микротике где крутиться pppoe демон

/radius add address=192.168.101.17 secret=radsecret service=ppp

/radius incoming set accept=yes port=1700

 

В логах микротика при попытке коннекта пишет:

user ***** authentication failed - radius timeout

Share this post


Link to post
Share on other sites

Все делали по этому руководству? http://abills.net.ua/wiki/doku.php/abills:docs:mikrotik:ru

 

Покажите настройки фаервола тогда.

 

Firewall даже не трогал, все по дефолту, скажите вот эти атрибуты и должны быть в секции после коментариев? или должны быть прям в шапке конфига?

 

# this attribute is unused

 

ATTRIBUTE Mikrotik-Address-List 19 string

ATTRIBUTE Mikrotik-Total-Limit 17 integer

ATTRIBUTE Mikrotik-Total-Limit-Gigawords 18 integer

Share this post


Link to post
Share on other sites

Все делали по этому руководству? http://abills.net.ua/wiki/doku.php/abills:docs:mikrotik:ru

 

Покажите настройки фаервола тогда.

 

Firewall даже не трогал, все по дефолту, скажите вот эти атрибуты и должны быть в секции после коментариев? или должны быть прям в шапке конфига?

 

# this attribute is unused

 

ATTRIBUTE Mikrotik-Address-List 19 string

ATTRIBUTE Mikrotik-Total-Limit 17 integer

ATTRIBUTE Mikrotik-Total-Limit-Gigawords 18 integer

 

Да собственно без разницы вначале или в конце. Главное что эти самые строки не закомментированны.

У Вас проблема в другом. Посмотрите, открыт ли на микротике порт радиуса или нет.

Edited by roma33rus

Share this post


Link to post
Share on other sites

Я немного не пойму, микротик у нас выступает в роли Radius клиента? как на нем могут быть открыты порты? это же не сервер.

 

Abills у меня в /usr/local/abills а в /usr/ у меня просто ссылка с именем abills на /usr/local/abills

конфиг радиуса в котором я вписал ip микротика в роли nas клиента находиться /usr/local/etc/raddb/clients.confadius/

есть еще /usr/local/abills/misc/freeradius/clients.confможет не тот конфиг?

Share this post


Link to post
Share on other sites

Я немного не пойму, микротик у нас выступает в роли Radius клиента? как на нем могут быть открыты порты? это же не сервер.

 

Abills у меня в /usr/local/abills а в /usr/ у меня просто ссылка с именем abills на /usr/local/abills

конфиг радиуса в котором я вписал ip микротика в роли nas клиента находиться /usr/local/etc/raddb/clients.confadius/

есть еще /usr/local/abills/misc/freeradius/clients.confможет не тот конфиг?

 

Да, это мой косяк. Проверить нужно на сервере биллинга запущенность службы и открытость портов.

netstat -nlp | grep 1812 и 1813

 

и покажите логи радиус сервера.

Edited by roma33rus

Share this post


Link to post
Share on other sites

Служба запущена и порты открыты(sockstat -4)

 

а вот что пишет radiusd -X

 

Abills у меня в /usr/local/abills а в /usr/ у меня просто ссылка с именем abills на /usr/local/abills

конфиг радиуса в котором я вписал ip микротика в роли nas клиента находиться /usr/local/etc/raddb/clients.confadius/

есть еще /usr/local/abills/misc/freeradius/clients.conf может не тот конфиг?

Share this post


Link to post
Share on other sites

Служба запущена и порты открыты(sockstat -4)

 

а вот что пишет radiusd -X

 

Abills у меня в /usr/local/abills а в /usr/ у меня просто ссылка с именем abills на /usr/local/abills

конфиг радиуса в котором я вписал ip микротика в роли nas клиента находиться /usr/local/etc/raddb/clients.confadius/

есть еще /usr/local/abills/misc/freeradius/clients.conf может не тот конфиг?

 

скорей всего у вас правильно. так как это путь по умолчанию. логов радиуса не вижу)

Share this post


Link to post
Share on other sites

В предыдущем сообщении не видно логов. У вас радиус-сервер вообще пингуется с микротика? покажите:

правила фаервола на радиус-сервере

ifconfig

на микротике - radius print detail (без паролей)

на микротике - ip address print

Share this post


Link to post
Share on other sites
ping radiushostfrommikrotik
 sent=3 received=3 packet-loss=0% min-rtt=31ms avg-rtt=31ms max-rtt=31ms 

radiusd -X
 FreeRADIUS Version 2.2.0, for host i386-portbld-freebsd9.2, built on Nov  9 2013 at 17:22:58
Copyright (C) 1999-2012 The FreeRADIUS server project and contributors. 
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A 
PARTICULAR PURPOSE. 
You may redistribute copies of FreeRADIUS under the terms of the 
GNU General Public License v2. 
Starting - reading configuration files ...
including configuration file /usr/local/etc/raddb/radiusd.conf
including configuration file /usr/local/etc/raddb/clients.conf
including files in directory /usr/local/etc/raddb/modules/
including configuration file /usr/local/etc/raddb/modules/wimax
including configuration file /usr/local/etc/raddb/modules/always
including configuration file /usr/local/etc/raddb/modules/attr_filter
including configuration file /usr/local/etc/raddb/modules/attr_rewrite
including configuration file /usr/local/etc/raddb/modules/cache
including configuration file /usr/local/etc/raddb/modules/chap
including configuration file /usr/local/etc/raddb/modules/checkval
including configuration file /usr/local/etc/raddb/modules/counter
including configuration file /usr/local/etc/raddb/modules/cui
including configuration file /usr/local/etc/raddb/modules/detail
including configuration file /usr/local/etc/raddb/modules/detail.example.com
including configuration file /usr/local/etc/raddb/modules/detail.log
including configuration file /usr/local/etc/raddb/modules/dhcp_sqlippool
including configuration file /usr/local/etc/raddb/sql/mysql/ippool-dhcp.conf
including configuration file /usr/local/etc/raddb/modules/digest
including configuration file /usr/local/etc/raddb/modules/dynamic_clients
including configuration file /usr/local/etc/raddb/modules/echo
including configuration file /usr/local/etc/raddb/modules/etc_group
including configuration file /usr/local/etc/raddb/modules/exec
including configuration file /usr/local/etc/raddb/modules/expiration
including configuration file /usr/local/etc/raddb/modules/expr
including configuration file /usr/local/etc/raddb/modules/files
including configuration file /usr/local/etc/raddb/modules/inner-eap
including configuration file /usr/local/etc/raddb/modules/ippool
including configuration file /usr/local/etc/raddb/modules/krb5
including configuration file /usr/local/etc/raddb/modules/ldap
including configuration file /usr/local/etc/raddb/modules/linelog
including configuration file /usr/local/etc/raddb/modules/otp
including configuration file /usr/local/etc/raddb/modules/logintime
including configuration file /usr/local/etc/raddb/modules/mac2ip
including configuration file /usr/local/etc/raddb/modules/mac2vlan
including configuration file /usr/local/etc/raddb/modules/mschap
including configuration file /usr/local/etc/raddb/modules/ntlm_auth
including configuration file /usr/local/etc/raddb/modules/opendirectory
including configuration file /usr/local/etc/raddb/modules/pam
including configuration file /usr/local/etc/raddb/modules/pap
including configuration file /usr/local/etc/raddb/modules/passwd
including configuration file /usr/local/etc/raddb/modules/perl
including configuration file /usr/local/etc/raddb/modules/policy
including configuration file /usr/local/etc/raddb/modules/preprocess
including configuration file /usr/local/etc/raddb/modules/radrelay
including configuration file /usr/local/etc/raddb/modules/radutmp
including configuration file /usr/local/etc/raddb/modules/realm
including configuration file /usr/local/etc/raddb/modules/redis
including configuration file /usr/local/etc/raddb/modules/rediswho
including configuration file /usr/local/etc/raddb/modules/replicate
including configuration file /usr/local/etc/raddb/modules/smbpasswd
including configuration file /usr/local/etc/raddb/modules/smsotp
including configuration file /usr/local/etc/raddb/modules/soh
including configuration file /usr/local/etc/raddb/modules/sql_log
including configuration file /usr/local/etc/raddb/modules/sqlcounter_expire_on_login
including configuration file /usr/local/etc/raddb/modules/sradutmp
including configuration file /usr/local/etc/raddb/modules/unix
including configuration file /usr/local/etc/raddb/modules/acct_unique
including configuration file /usr/local/etc/raddb/policy.conf
including configuration file /usr/local/etc/raddb/sites-enabled/abills_default
main {
user = "freeradius"
group = "freeradius"
allow_core_dumps = no
}
including dictionary file /usr/local/etc/raddb/dictionary
main {
name = "radiusd"
prefix = "/usr/local"
localstatedir = "/var"
sbindir = "/usr/local/sbin"
logdir = "/var/log"
run_dir = "/var/run/radiusd"
libdir = "/usr/local/lib/freeradius-2.1.6"
radacctdir = "/var/log/radacct"
hostname_lookups = no
max_request_time = 30
cleanup_delay = 5
max_requests = 512000
pidfile = "/var/run/radiusd/radiusd.pid"
checkrad = "/usr/local/sbin/checkrad"
debug_level = 0
proxy_requests = no
log {
stripped_names = no
auth = no
auth_badpass = no
auth_goodpass = no
}
security {
max_attributes = 200
reject_delay = 1
status_server = yes
}
}
radiusd: #### Loading Realms and Home Servers ####
radiusd: #### Loading Clients ####
client localhost {
ipaddr = 127.0.0.1
require_message_authenticator = no
secret = "radsecret"
nastype = "other"
}
client IPМОЕГОМИКРОТИКАСPPPOEСЕРВЕРОМ {
require_message_authenticator = no
secret = "radsecret"
}
radiusd: #### Instantiating modules ####
instantiate {
Module: Linked to module rlm_exec
Module: Instantiating module "exec" from file /usr/local/etc/raddb/modules/exec
 exec {
wait = no
input_pairs = "request"
shell_escape = yes
 }
Module: Linked to module rlm_expiration
Module: Instantiating module "expiration" from file /usr/local/etc/raddb/modules/expiration
 expiration {
reply-message = "Password Has Expired  "
 }
Module: Linked to module rlm_logintime
Module: Instantiating module "logintime" from file /usr/local/etc/raddb/modules/logintime
 logintime {
reply-message = "You are calling outside your allowed timespan  "
minimum-timeout = 60
 }
}
radiusd: #### Loading Virtual Servers ####
server { # from file /usr/local/etc/raddb/radiusd.conf
modules {
 Module: Creating Auth-Type = Perl
 Module: Creating Post-Auth-Type = REJECT
Module: Checking authenticate {...} for more modules to load
Module: Linked to module rlm_pap
Module: Instantiating module "pap" from file /usr/local/etc/raddb/modules/pap
 pap {
encryption_scheme = "auto"
auto_header = no
 }
Module: Linked to module rlm_mschap
Module: Instantiating module "mschap" from file /usr/local/etc/raddb/modules/mschap
 mschap {
use_mppe = yes
require_encryption = no
require_strong = no
with_ntdomain_hack = no
allow_retry = yes
 }
Module: Linked to module rlm_perl
Module: Instantiating module "perl" from file /usr/local/etc/raddb/modules/perl
 perl {
module = "/usr/abills/libexec/rlm_perl.pl"
func_authorize = "authorize"
func_authenticate = "authenticate"
func_accounting = "accounting"
func_preacct = "preacct"
func_checksimul = "checksimul"
func_detach = "detach"
func_xlat = "xlat"
func_pre_proxy = "pre_proxy"
func_post_proxy = "post_proxy"
func_post_auth = "post_auth"
func_recv_coa = "recv_coa"
func_send_coa = "send_coa"
 }
Module: Checking authorize {...} for more modules to load
Module: Linked to module rlm_preprocess
Module: Instantiating module "preprocess" from file /usr/local/etc/raddb/modules/preprocess
 preprocess {
huntgroups = "/usr/local/etc/raddb/huntgroups"
hints = "/usr/local/etc/raddb/hints"
with_ascend_hack = no
ascend_channels_per_line = 23
with_ntdomain_hack = no
with_specialix_jetstream_hack = no
with_cisco_vsa_hack = no
with_alvarion_vsa_hack = no
 }
reading pairlist file /usr/local/etc/raddb/huntgroups
reading pairlist file /usr/local/etc/raddb/hints
Module: Linked to module rlm_files
Module: Instantiating module "files" from file /usr/local/etc/raddb/modules/files
 files {
usersfile = "/usr/local/etc/raddb/users"
acctusersfile = "/usr/local/etc/raddb/acct_users"
preproxy_usersfile = "/usr/local/etc/raddb/preproxy_users"
compat = "no"
 }
reading pairlist file /usr/local/etc/raddb/users
reading pairlist file /usr/local/etc/raddb/acct_users
reading pairlist file /usr/local/etc/raddb/preproxy_users
Module: Checking preacct {...} for more modules to load
Module: Checking accounting {...} for more modules to load
Module: Checking post-auth {...} for more modules to load
} # modules
} # server
radiusd: #### Opening IP addresses and Ports ####
listen {
type = "auth"
ipaddr = *
port = 0
Failed binding to authentication address * port 1812: Address already in use 
/usr/local/etc/raddb/radiusd.conf[120]: Error binding to port for 0.0.0.0 port 1812



ifconfig
 rl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=2008<VLAN_MTU,WOL_MAGIC>
ether ac:f1:df:40:25:3d
inet МОЙВНЕШНИЙБЕЛЫЙIP netmask 0xff000000 broadcast X.255.255.255
inet6 fe80::aef1:dfff:fe40:253d%rl0 prefixlen 64 scopeid 0x2 
nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
re0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
ether 74:d0:2b:2a:5a:66
nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
media: Ethernet autoselect (none)
status: no carrier
plip0: flags=8810<POINTOPOINT,SIMPLEX,MULTICAST> metric 0 mtu 1500
nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
inet6 ::1 prefixlen 128 
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x6 
inet 127.0.0.1 netmask 0xff000000 
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>


ipfw show
 ipfw: getsockopt(IP_FW_GET): Protocol not available


[admin@MikroTik] > radius print detail
Flags: X - disabled 
0   service=ppp called-id="" domain="" address=ip компьютера с радиусом secret="пароль" 
    authentication-port=1812 accounting-port=1813 timeout=300ms 
    accounting-backup=no realm=""



[admin@MikroTik] > ip address print
Flags: X - disabled, I - invalid, D - dynamic 
#   ADDRESS            NETWORK         INTERFACE                              
0   ;;; default configuration
    192.168.2.1/24     192.168.2.0     bridge-local                           
1   192.168.0.10/24    192.168.0.0     ether1-gateway                         

Share this post


Link to post
Share on other sites

Failed binding to authentication address * port 1812: Address already in use

/usr/local/etc/raddb/radiusd.conf[120]: Error binding to port for 0.0.0.0 port 1812

 

Вот проблема описана в логе.

Share this post


Link to post
Share on other sites

с этим разрьрался уже вроде.... cокет уже занят запущенным радиусом, он у меня в автозапуске просто.... останавливаю и перезапускаю с -X пишет вот что

 

rlm_perl: Added pair NAS-IP-Address = 192.168.0.10
rlm_perl: Added pair NAS-Port-Id = bridge-local
rlm_perl: Added pair Reply-Message = Unknow server '192.168.0.10'

 

Микротик за nat у меня и внешний ip у него другой в настройках радиуса на микротике в src.address указал 192.168.0.10 (его внутренний ip)

 

 

В /usr/local/etc/raddb/clients.conf у меня секции (это хоть тот конфиг?)

 

client 192.168.0.10 {

secret = radsecret

}

 

client внешнийipмикротика {

secret = radsecret

}

 

с этим разрьрался уже вроде.... cокет уже занят запущенным радиусом, он у меня в автозапуске просто.... останавливаю и перезапускаю с -X пишет вот что

 

rlm_perl: Added pair NAS-IP-Address = 192.168.0.10
rlm_perl: Added pair NAS-Port-Id = bridge-local
rlm_perl: Added pair Reply-Message = Unknow server '192.168.0.10'

 

Микротик за nat у меня и внешний ip у него другой в настройках радиуса на микротике в src.address указал 192.168.0.10 (его внутренний ip)

 

 

В /usr/local/etc/raddb/clients.conf у меня секции (это хоть тот конфиг?)

 

client 192.168.0.10 {

secret = radsecret

}

 

client внешнийipмикротика {

secret = radsecret

}

Share this post


Link to post
Share on other sites

с этим разрьрался уже вроде.... cокет уже занят запущенным радиусом, он у меня в автозапуске просто.... останавливаю и перезапускаю с -X пишет вот что

 

rlm_perl: Added pair NAS-IP-Address = 192.168.0.10
rlm_perl: Added pair NAS-Port-Id = bridge-local
rlm_perl: Added pair Reply-Message = Unknow server '192.168.0.10'

 

Микротик за nat у меня и внешний ip у него другой в настройках радиуса на микротике в src.address указал 192.168.0.10 (его внутренний ip)

 

 

В /usr/local/etc/raddb/clients.conf у меня секции (это хоть тот конфиг?)

 

client 192.168.0.10 {

secret = radsecret

}

 

client внешнийipмикротика {

secret = radsecret

}

 

с этим разрьрался уже вроде.... cокет уже занят запущенным радиусом, он у меня в автозапуске просто.... останавливаю и перезапускаю с -X пишет вот что

 

rlm_perl: Added pair NAS-IP-Address = 192.168.0.10
rlm_perl: Added pair NAS-Port-Id = bridge-local
rlm_perl: Added pair Reply-Message = Unknow server '192.168.0.10'

 

Микротик за nat у меня и внешний ip у него другой в настройках радиуса на микротике в src.address указал 192.168.0.10 (его внутренний ip)

 

 

В /usr/local/etc/raddb/clients.conf у меня секции (это хоть тот конфиг?)

 

client 192.168.0.10 {

secret = radsecret

}

 

client внешнийipмикротика {

secret = radsecret

}

 

Не пойму. У Вас прямая связь между сервером радиуса и микротиком есть? или только через НАТ???

Share this post


Link to post
Share on other sites

с этим разрьрался уже вроде.... cокет уже занят запущенным радиусом, он у меня в автозапуске просто.... останавливаю и перезапускаю с -X пишет вот что

 

rlm_perl: Added pair NAS-IP-Address = 192.168.0.10
rlm_perl: Added pair NAS-Port-Id = bridge-local
rlm_perl: Added pair Reply-Message = Unknow server '192.168.0.10'

 

Микротик за nat у меня и внешний ip у него другой в настройках радиуса на микротике в src.address указал 192.168.0.10 (его внутренний ip)

 

 

В /usr/local/etc/raddb/clients.conf у меня секции (это хоть тот конфиг?)

 

client 192.168.0.10 {

secret = radsecret

}

 

client внешнийipмикротика {

secret = radsecret

}

 

с этим разрьрался уже вроде.... cокет уже занят запущенным радиусом, он у меня в автозапуске просто.... останавливаю и перезапускаю с -X пишет вот что

 

rlm_perl: Added pair NAS-IP-Address = 192.168.0.10
rlm_perl: Added pair NAS-Port-Id = bridge-local
rlm_perl: Added pair Reply-Message = Unknow server '192.168.0.10'

 

Микротик за nat у меня и внешний ip у него другой в настройках радиуса на микротике в src.address указал 192.168.0.10 (его внутренний ip)

 

 

В /usr/local/etc/raddb/clients.conf у меня секции (это хоть тот конфиг?)

 

client 192.168.0.10 {

secret = radsecret

}

 

client внешнийipмикротика {

secret = radsecret

}

 

Не пойму. У Вас прямая связь между сервером радиуса и микротиком есть? или только через НАТ???

через nat только

Share this post


Link to post
Share on other sites

с этим разрьрался уже вроде.... cокет уже занят запущенным радиусом, он у меня в автозапуске просто.... останавливаю и перезапускаю с -X пишет вот что

 

rlm_perl: Added pair NAS-IP-Address = 192.168.0.10
rlm_perl: Added pair NAS-Port-Id = bridge-local
rlm_perl: Added pair Reply-Message = Unknow server '192.168.0.10'

 

Микротик за nat у меня и внешний ip у него другой в настройках радиуса на микротике в src.address указал 192.168.0.10 (его внутренний ip)

 

 

В /usr/local/etc/raddb/clients.conf у меня секции (это хоть тот конфиг?)

 

client 192.168.0.10 {

secret = radsecret

}

 

client внешнийipмикротика {

secret = radsecret

}

 

с этим разрьрался уже вроде.... cокет уже занят запущенным радиусом, он у меня в автозапуске просто.... останавливаю и перезапускаю с -X пишет вот что

 

rlm_perl: Added pair NAS-IP-Address = 192.168.0.10
rlm_perl: Added pair NAS-Port-Id = bridge-local
rlm_perl: Added pair Reply-Message = Unknow server '192.168.0.10'

 

Микротик за nat у меня и внешний ip у него другой в настройках радиуса на микротике в src.address указал 192.168.0.10 (его внутренний ip)

 

 

В /usr/local/etc/raddb/clients.conf у меня секции (это хоть тот конфиг?)

 

client 192.168.0.10 {

secret = radsecret

}

 

client внешнийipмикротика {

secret = radsecret

}

 

Не пойму. У Вас прямая связь между сервером радиуса и микротиком есть? или только через НАТ???

через nat только

 

тогда подозреваю, что вам надо настраивать проброс портов на радиус сервере.

Share this post


Link to post
Share on other sites

Все сделал, пользователи на радусе авторизацию проходят, подскажите как верно создать тарифные планы?

Share this post


Link to post
Share on other sites

Все сделал, пользователи на радусе авторизацию проходят, подскажите как верно создать тарифные планы?

 

Все так как описано на сайте разработчика. http://abills.net.ua/wiki/doku.php/abills:docs:modules:dv:ru#tarif_plans

Share this post


Link to post
Share on other sites

Где должен находится этот скрипт? на микротике или на сервере где установлен ABills? после чего он должен загружаться на миротик посредством этого скрипта(/usr/abills/libexec/billd checkspeed mikrotik)

 

/ip firewall mangle add chain=forward action=mark-packet new-packet-mark=ALLOW_TRAFFIC_CLASS_141_in 
 passthrough=yes src-address-list=CLIENTS_141 dst-address=0.0.0.0/0

/ip firewall mangle add chain=forward action=mark-packet new-packet-mark=ALLOW_TRAFFIC_CLASS_141_out 
 passthrough=yes src-address=0.0.0.0/0 dst-address-list=CLIENTS_141

/queue type add name="TP_141_in_global_speed" kind=pcq 
 pcq-rate=262144 pcq-classifier=src-address

/queue type add name="TP_141_out_global_speed" kind=pcq 
 pcq-rate=262144 pcq-classifier=dst-address

/queue tree add name="TP_141_in_global" parent=global-out queue="TP_141_in_global_speed" 
 packet-mark=ALLOW_TRAFFIC_CLASS_141_in priority=5 burst-limit=0 burst-threshold=0 burst-time=0s

/queue tree add name="TP_141_out_global" parent=global-out queue="TP_141_out_global_speed" 
 packet-mark=ALLOW_TRAFFIC_CLASS_141_out priority=5 burst-limit=0 burst-threshold=0 burst-time=0s

Share this post


Link to post
Share on other sites

Где должен находится этот скрипт? на микротике или на сервере где установлен ABills? после чего он должен загружаться на миротик посредством этого скрипта(/usr/abills/libexec/billd checkspeed mikrotik)

 

/ip firewall mangle add chain=forward action=mark-packet new-packet-mark=ALLOW_TRAFFIC_CLASS_141_in 
 passthrough=yes src-address-list=CLIENTS_141 dst-address=0.0.0.0/0

/ip firewall mangle add chain=forward action=mark-packet new-packet-mark=ALLOW_TRAFFIC_CLASS_141_out 
 passthrough=yes src-address=0.0.0.0/0 dst-address-list=CLIENTS_141

/queue type add name="TP_141_in_global_speed" kind=pcq 
 pcq-rate=262144 pcq-classifier=src-address

/queue type add name="TP_141_out_global_speed" kind=pcq 
 pcq-rate=262144 pcq-classifier=dst-address

/queue tree add name="TP_141_in_global" parent=global-out queue="TP_141_in_global_speed" 
 packet-mark=ALLOW_TRAFFIC_CLASS_141_in priority=5 burst-limit=0 burst-threshold=0 burst-time=0s

/queue tree add name="TP_141_out_global" parent=global-out queue="TP_141_out_global_speed" 
 packet-mark=ALLOW_TRAFFIC_CLASS_141_out priority=5 burst-limit=0 burst-threshold=0 burst-time=0s

 

Это мне думается команды для самого микротика, для выполнения в его терминале. Если не ошибаюсь. в микротике особо не силен.

Edited by roma33rus

Share this post


Link to post
Share on other sites

Где должен находится этот скрипт? на микротике или на сервере где установлен ABills? после чего он должен загружаться на миротик посредством этого скрипта(/usr/abills/libexec/billd checkspeed mikrotik)

 

/ip firewall mangle add chain=forward action=mark-packet new-packet-mark=ALLOW_TRAFFIC_CLASS_141_in 
 passthrough=yes src-address-list=CLIENTS_141 dst-address=0.0.0.0/0

/ip firewall mangle add chain=forward action=mark-packet new-packet-mark=ALLOW_TRAFFIC_CLASS_141_out 
 passthrough=yes src-address=0.0.0.0/0 dst-address-list=CLIENTS_141

/queue type add name="TP_141_in_global_speed" kind=pcq 
 pcq-rate=262144 pcq-classifier=src-address

/queue type add name="TP_141_out_global_speed" kind=pcq 
 pcq-rate=262144 pcq-classifier=dst-address

/queue tree add name="TP_141_in_global" parent=global-out queue="TP_141_in_global_speed" 
 packet-mark=ALLOW_TRAFFIC_CLASS_141_in priority=5 burst-limit=0 burst-threshold=0 burst-time=0s

/queue tree add name="TP_141_out_global" parent=global-out queue="TP_141_out_global_speed" 
 packet-mark=ALLOW_TRAFFIC_CLASS_141_out priority=5 burst-limit=0 burst-threshold=0 burst-time=0s

 

Это мне думается команды для самого микротика, для выполнения в его терминале. Если не ошибаюсь. в микротике особо не силен.

 

 

можно просто с консоли запустить /usr/abills/libexec/billd checkspeed mikrotik

 

а на сайте пример как после работы скрипта должны выглядить правила.

Специально поставил так как по 20 раз в день спрашивают как долны выглядеть правила после работы скрипта

Share this post


Link to post
Share on other sites
можно просто с консоли запустить /usr/abills/libexec/billd checkspeed mikrotik

Запустил? скрипт пошел на микротик.. что он там будет создавать? с какими аргументами?

Share this post


Link to post
Share on other sites

Не понятно, что там у вас не работает. На чем вы щас остановились?

 

Для чего предназначен этот скрипт и какие аргументы ему передавать написано на странице http://abills.net.ua/wiki/doku.php/abills:docs:mikrotik:ru#upravlenie_shejperom

 

Код этого скрипта можно прочесть, открыв файл в текстовом редакторе. Там будет Perl код. Начинается где-то с "sub check_speed_mikrotik {"

 

Рекомендую вам воспользоваться платной технической поддержкой этого биллинга - http://abills.net.ua/contacts/.

Share this post


Link to post
Share on other sites

можно просто с консоли запустить /usr/abills/libexec/billd checkspeed mikrotik

Запустил? скрипт пошел на микротик.. что он там будет создавать? с какими аргументами?

 

 

 

повторюсь второй раз

 

на сайте пример как после работы скрипта должны выглядить правила.

 

Специально поставил так как по 20 раз в день спрашивают как долны выглядеть правила после работы скрипта

 

обясняю специально показано что происходит после работы скрипат и какие правила он добавляет чотыб не было вопросов а что он делает

Share this post


Link to post
Share on other sites

Не понятно, что там у вас не работает. На чем вы щас остановились?

 

Для чего предназначен этот скрипт и какие аргументы ему передавать написано на странице http://abills.net.ua/wiki/doku.php/abills:docs:mikrotik:ru#upravlenie_shejperom

 

Код этого скрипта можно прочесть, открыв файл в текстовом редакторе. Там будет Perl код. Начинается где-то с "sub check_speed_mikrotik {"

 

Рекомендую вам воспользоваться платной технической поддержкой этого биллинга - http://abills.net.ua/contacts/.

 

Не понятно, что там у вас не работает. На чем вы щас остановились?

Не могу создать правила шейпера на микротике с нужными мне ограничениями по скорости, и как их привязать к нужному тарифу в abills(может я не совсем корректно спрашиваю)?

 

Для чего предназначен этот скрипт и какие аргументы ему передавать написано на странице

 

Прочитал,но у меня осталось много вопросов, настраиваю первый раз.

 

Код этого скрипта можно прочесть, открыв файл в текстовом редакторе

 

Как прочитать тело скрипта знаю, в Perl я не особо силен, общий алгоритм возможно пойму, но у меня задача удостоверится что я все сделал по порядку и ничего не пропускаю или недопонимаю.

 

Рекомендую вам воспользоваться платной технической поддержкой этого биллинга

 

Про тех поддержку в курсе, но буду пробовать разбираться сам.

 

 

Можно пример действий увидеть для добавления шейпера на mk и создание тарифных планов?

Edited by Neznaika

Share this post


Link to post
Share on other sites

я елси чесно не знаю что тут сказать

 

1 на сайте етсь видеоролик как создавать ТП

2 написано какой командой загрузить правила на микротик

3 и написано как проверить правила на микротике

 

и это я повторно еще 2 раза написал тут

 

думаю стоит найти вам человека который будет Вам пересказывать содержимое документации так чтоы Вы могли понять

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this