Jump to content
Калькуляторы

переадресация на страницу напоминалку Помогите с правилами

Хочу сделать чтобы за 2-3 дня до окончания месяца, один раз в день, у абонентов выскакивала страничка с напоминанием, что месяц заканчивается. Алгоритм вроде понимаю: всех кто идет на порт 80 перенаправлять на страницу-напоминалку(лежит в интернете)(веб-прокси микротика занят блокировкой неплательшиков), и тех кто перешел на эту страницу добавлять в адрес-лист "OZNAKOMLENI" на сутки. Кто подскажет как это реализовать на микротике?

Edited by nicolenkoe

Share this post


Link to post
Share on other sites

На микротике надо включить веб-прокси, создать в нем одно запрещающее правило и перенаправлять всех на него при определенном условии.

 

Тут будет перенаправление, если адрес добавлен в список, и запрос не идет на внутренние адреса сети, в примере 192.168.0.0/16.

 

/ip firewall address-list

add address=10.10.10.10 list=balance_negative

/ip firewall filter

add action=drop chain=forward dst-address=!192.168.0.0/16 src-address-list=balance_negative

/ip firewall nat

add action=redirect chain=dstnat dst-address=!192.168.0.0/16 protocol=tcp src-address-list=balance_negative to-ports=8123

/ip proxy

set enabled=yes port=8123

/ip proxy access

add action=deny redirect-to=http://yandex.ru

Share this post


Link to post
Share on other sites

Подредактировал тему(выделил важное), попытался выделить ньюансы. Как быть в моем случае?

Share this post


Link to post
Share on other sites

Подредактировал тему(выделил важное), попытался выделить ньюансы. Как быть в моем случае?

 

Установить биллинговую систему.

Share this post


Link to post
Share on other sites

Подскажите как сделать чтобы перенаправление шло не отдельную внешнюю страничку, а на html файлик который лежит в микротике?

Share this post


Link to post
Share on other sites

Подскажите как сделать чтобы перенаправление шло не отдельную внешнюю страничку, а на html файлик который лежит в микротике?

 

http://www.mikrotik.by/index.php?showtopic=403

Share this post


Link to post
Share on other sites

Это пробовал сразу. Роутер генерит файл а не берет error

Share this post


Link to post
Share on other sites

В общем всем у кого не работает, в файлик error нужно вставить следующий код

 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

<html><head><meta http-equiv="Content-Type" content="text/html; charset=windows-1251">

<title>Доступ запрещен</title></head>

<body>

$(if error)

 

Ваш код html страницы (к примеру "<p> Свяжитесь с администратором. </p>" )

 

$(endif)

</body></html>

Share this post


Link to post
Share on other sites

Ну так это понятно, что в пустом error информация 0)

Вот тут http://mikrotik.ru/forum/viewtopic.php?f=13&t=4008 возьмите красивый error и будет еще приятнее абоненту читать информацию!

Share this post


Link to post
Share on other sites

Помогите точно так же сделать только редирект должен перенаправлять на локальный сервер, который является DNS сервером и биллингом.

Имею следующее:

Есть адрес листы, на основе которых режется скорость и в группе которых есть блок внутренних адресов. Есть адрес листа типа TARIF_4MB, в него входят "N" количество абонентов. И все кто находятся в этом адрес листе попадают под свою очередь в дереве очередей. Нужно сделать что бы при отключении абона, в микротике помещались в группу типа "drop_users" и на самом же тике сделать редирект на кабинет пользователя.

Делал что-то на подобе такого без создания адрес листа типа"drop_users". Кто не попадает под свой адрес лист, тот заворачивается на кабинет пользователя. Но никак не могу добить, как сделать.

Это правило отказывается работать.

 

ip firewall nat add chain=dstnat protocol=tcp dst-port=80 src-address-list=!T:100 content=http://stat.isp action=dst-nat to-addresses=10.0.6.100 to-ports=80

 

Кабинет пользователя находиться по адресу stat.isp

Edited by haxprox

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this