Jump to content
Калькуляторы

Проблема с вай-фай мостом NanoBridge M5

Дано:

Подключение к провайдеру через вай-фай мост по такой схеме

Свитч провайдера(Воля) <-> точка доступа 1 <=> точка доступа 2 <-> компьютер

<-> витая пара

<=> радиоканал

точка 1 - NanoBridge M5 в режиме Access Point WDS

точка 2 - NanoBridge M5 в режиме Station WDS

Шифрование WPA2 AES

 

Все летает, все работает, но...

 

Проблема:

Частенько канал до точки 2 грузится неведомым трафиком (на комп этот траф не попадает, пакеты не принимаются).

В это время точка 1 недоступна через точку 2, пинг 150-300 мс (норма 1-2), инет 10-20 кб\с (норма 50-60 мб\с)

Во время проблемы трафик выглядит так:

 

post-114408-084348300 1372942613_thumb.jpg

 

Восстановление нормальной работы:

 

post-114408-058932400 1372942625_thumb.jpg

 

Такие периоды нерегулярны и непредсказуемы, иногда пол-дня "мерцает", иногда день-два все отлично.

Мак-и прописаны

На 5 ггц вижу одну постороннюю точку с очень слабым сигналом, и точно знаю что она не при чем (сам ее настраивал и выключать пробовали)

 

 

Что делал:

Купил новую точку и менял обе по-очереди.

Менял ПоЕ (БП).

Витую пару от ПоЕ до точки 1 и полностью на клиентской стороне.

Воткнули кабель в другой свитч.

Никаких изменений.

 

Люди добрые, помогите чем сможете, уже мозг сломал...

Share this post


Link to post
Share on other sites

а если отрубить провайдера такая же фигня?

Share this post


Link to post
Share on other sites

а если отрубить провайдера такая же фигня?

Не пробовал. Не буду же я пялится на вебморду несколько часов? :)

Перепрошил сейчас на v5.5.6, если проблема исчезнет, значит это был "глюк прошивки 5.3.5" (нашел такой на форуме)

Share this post


Link to post
Share on other sites

На 5 ггц вижу одну постороннюю точку с очень слабым сигналом, и точно знаю что она не при чем (сам ее настраивал и выключать пробовали)

С чего ты взял что в данном диапазоне работает всего 2 точки.

Эфир необходимо сканировать по очереди на всей ширине в 5,8,10,20,25 мгц, возможно на ширине 40 мгц ты сам создаёшь проблемы другим радио-линкам.

Share this post


Link to post
Share on other sites
Частенько канал до точки 2 грузится неведомым трафиком (на комп этот траф не попадает, пакеты не принимаются).

Ну так и просниьте трафик(в ЭирОс есть tcpdump), а также прошивку обновите.

Share this post


Link to post
Share on other sites

На 5 ггц вижу одну постороннюю точку с очень слабым сигналом, и точно знаю что она не при чем (сам ее настраивал и выключать пробовали)

С чего ты взял что в данном диапазоне работает всего 2 точки.

Эфир необходимо сканировать по очереди на всей ширине в 5,8,10,20,25 мгц, возможно на ширине 40 мгц ты сам создаёшь проблемы другим радио-линкам.

Так и делал

Точки стоят в 6 дБ, антенны направленные, по осям 14-этажка, сзади река, помех создавать некому.

 

Ну так и просниьте трафик(в ЭирОс есть tcpdump), а также прошивку обновите.

 

tcpdump "не видит" этого трафика

Прошивку обновил вчера(выше писал). Пока "не единого разрыва".

Edited by lucky_news

Share this post


Link to post
Share on other sites
tcpdump "не видит" этого трафика

Если чего-то tcpdump не видит -- значит его там нет, можете для проверки в разрыв поставить свитч, и с него снимать

Share this post


Link to post
Share on other sites

Перепрошивка не помогла. Теперь базовая точка(1) при появлении паразитного трафа самостоятельно ежеминутно перезагружается(что не помогает).

С утра читаю форум community.ubnt.com. Там десяток тем с этой проблемой (может и больше - вглубь не лез). Фирмачи невнятно огрызаются, проблема НЕ РЕШЕНА. Похоже большая партия бракованных девайсов.

Думаю, что делать: брать микротики (и похоронить 360 баксов - 3 NanoBridge), или взять еще одну точку в надежде, что на этот раз повезет? :(

Share this post


Link to post
Share on other sites
или взять еще одну точку в надежде, что на этот раз повезет? :(

заменить по гарантии.

Случай явно таковой.

 

Но для начала -- выясните, есть ли на самом деле этот трафик, или это глюк?

Share this post


Link to post
Share on other sites
или взять еще одну точку в надежде, что на этот раз повезет? :(

заменить по гарантии.

Случай явно таковой.

 

Но для начала -- выясните, есть ли на самом деле этот трафик, или это глюк?

Выяснил. Этот трафик - попытки аутентификации от базы к клиенту.

STA dc:9f:db:e0:89:cc WPA: received EAPOL-Key msg 2/4 in invalid state (10) - dropped

Вот таким весь лог базы забит. (у буржуев то же самое). Я до этого только лог клиента смотрел (протупил что-то). Что интересно, если отключить шифрование и фильтры МАС ничего не меняется.

Оба продавца с гарантии красиво "съехали", требуют заключения СЦ, причем сертифицированного, у нас такой за 700 км есть, но заключения давать отказался (по телефону), да и сомневаюсь, что в СЦ кто-то будет вообще заморачиваться такой неявной поломкой\браком.

 

ps. Хотел попробовать старые прошивки, но моложе 5.3.5 не нашел. Может у кого завалялась?

Edited by lucky_news

Share this post


Link to post
Share on other sites
Выяснил. Этот трафик - попытки аунтефикации от базы к клиенту.

Кстати отрубите syslogd, у него был один нехороший глюк....

Edited by NewUse

Share this post


Link to post
Share on other sites

ЭирМакс отключать пробовали?

Алгоритм DataRate менять пробовали?

Share this post


Link to post
Share on other sites

Алгоритм DataRate менять пробовали?

что это даст ? не совсем понимаю как оно работает

Share this post


Link to post
Share on other sites

lucky_news Вам в руки BackTrack 5...и глядеть уязвимости-прогоните на локалке и затем по воздуху с стрестестами...сдается что железо Ваше на ботах трудится...у самого благо пара сеток у буржуев зацепленно под это дело на ...

Хотя возможно что и по MDK3 кто-то с Вами играется...Все одно-глядите что BT5 скажет...

Edited by Jess

Share this post


Link to post
Share on other sites

ЭирМакс отключать пробовали?

Алгоритм DataRate менять пробовали?

1 Да

2 Стоит в Авто

 

Вчера с 18 до 24 база была практически в дауне.

С утра все идеально.

Как поставить старую прошивку на новую?

Обычным путем не получается.

 

lucky_news Вам в руки BackTrack 5...и глядеть уязвимости-прогоните на локалке и затем по воздуху с стрестестами...сдается что железо Ваше на ботах трудится...у самого благо пара сеток у буржуев зацепленно под это дело на ...

Хотя возможно что и по MDK3 кто-то с Вами играется...Все одно-глядите что BT5 скажет...

 

Я под вин.

Вы думаете базу кто-то ломает в активном режиме, подменив мак на мой?

Как это отловить и пресечь?

Рядом такой же мост знакомого вообще с открытыми вебмордами и паролем на шифрование "123", за год не одной проблемы...

 

зы. у меня стоит ограничение форума на кол-во постов в день, поэтому отвечаю редко и не вовремя. Очевидно нужная фича.:)

Share this post


Link to post
Share on other sites
Рядом такой же мост знакомого вообще с открытыми вебмордами и паролем на шифрование "123", за год не одной проблемы...

Частоты минимум на 100МГц разнесли?

DFS должен быть выключен.

Логирование выключали?

Share this post


Link to post
Share on other sites
Рядом такой же мост знакомого вообще с открытыми вебмордами и паролем на шифрование "123", за год не одной проблемы...

Частоты минимум на 100МГц разнесли?

DFS должен быть выключен.

Логирование выключали?

Вообще отключать пробовали, да и линк там узко-направленный, я только его базу с клиента вижу с уровнем -90 дБ

А при чем тут DFS? Проблема в базовой точке, которая (внезапно) не видит клиента.

Вот лог базы при проблеме:

 

May 28 18:44:49 hostapd: ath0: STA хх:хх:хх:хх:хх:хх WPA: received EAPOL-Key msg 2/4 in invalid state (10) - dropped
May 28 18:44:49 hostapd: ath0: STA хх:хх:хх:хх:хх:хх WPA: pairwise key handshake completed (RSN)
May 28 18:44:49 hostapd: ath0: STA хх:хх:хх:хх:хх:хх WPA: received EAPOL-Key msg 4/4 in invalid state (11) - dropped

(хх:хх:хх:хх:хх:хх - мас клиентской точки)

Share this post


Link to post
Share on other sites
А при чем тут DFS? Проблема в базовой точке, которая (внезапно) не видит клиента.

При том, что база может перейти на одну частоту, а клиент может и не начать перестраиваться.

 

Логи отрубать пробовали? Был баг именно в системе логирования, она конфликтовала с радиомодулем....

Share this post


Link to post
Share on other sites

ДФС выключен и был выключен.

Логи выключены и были выключены. (включал на время)

Как поставить старую прошивку на новую?

Обычным путем не получается.

 

upd

Теперь вообще чудеса:

базу видно с клиента, пингуется отлично, интернет есть, вебморда не открывается, спидтест не проходит...

Edited by lucky_news

Share this post


Link to post
Share on other sites

lucky_news У Вас флешки нету?-запишите дестрибутив любого линя-лучше тот же самый BackTrack 5 и грузитесь на нем-там все будет видно...возможно на вашем компе проблемы...

Share this post


Link to post
Share on other sites
Теперь вообще чудеса:

базу видно с клиента, пингуется отлично, интернет есть, вебморда не открывается, спидтест не проходит...

 

по ssh коннектится?

скорее всего -- вирь.

посмотрите /etc/persistent на наличие файлов rc.*

Share this post


Link to post
Share on other sites

На ноуте то же самое.

Проблема с NanoBridge M5, а не компом...

Share this post


Link to post
Share on other sites
Теперь вообще чудеса:

базу видно с клиента, пингуется отлично, интернет есть, вебморда не открывается, спидтест не проходит...

 

по ssh коннектится?

скорее всего -- вирь.

посмотрите /etc/persistent на наличие файлов rc.*

Я под вин.

по SSH тоже фейл. Вечером перегрузят, но это ненадолго... я в печали. Раздарил д-линковские точки, теперь бы пригодились

Share this post


Link to post
Share on other sites

ucky_news Уж стока времени прошло и народ весь рекомендует свою сеть глянуть как оная выглядит...-ерпенчитяете-тада Вам и флаги вруки...-зачем совета спрашивать-вопрос...?Дос атаки кагда учиняли с под 98го?-у Вас система живет своей жизнью-смотрите правила-и правьте как Вам нужно на данный момент..

Edited by Jess

Share this post


Link to post
Share on other sites

ucky_news Уж стока времени прошло и народ весь рекомендует свою сеть глянуть как оная выглядит...-ерпенчитяете-тада Вам и флаги вруки...-зачем совета спрашивать-вопрос...?Дос атаки кагда учиняли с под 98го?-у Вас система живет своей жизнью-смотрите правила-и правьте как Вам нужно на данный момент..

Я вообще не понимаю о чем вы.

Вирус ГДЕ?

В операцонке?

Между системой и точкой НЕТ трафика. Вообще. Никакого.

Весь трафик ТОЛЬКО между базой и клиентом.

я грузился с лайв-сиди, подключал ноут, грузился с флешки - все то же самое, характерный "заборчик" аутентификации от базы к клиенту

Вирус в точке?

Это возможно?

Подобный глюк описан в теме

http://www.lan23.ru/forum/showthread.php?t=9814&highlight=

и тут

http://www.lan23.ru/forum/showthread.php?t=7540&highlight=

 

в обоих случаях причина осталась неясной

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this