Jump to content
Калькуляторы

Загрузка CPU AirGrid процессом ksoftirqd падает

Здравствуйте, уважаемые.

На AirGrid M5HP (v5.5.3) через ethernet регулярно увеличиваются пинги с 10 до 400-500 мс., а ещё через время и вовсе отваливается, как и всё за ним. Настроен как station. Один раз перед отвалом удалось увидеть такую картину - весь проц кушает процесс ksoftirqd - что это такое и как с ним бороться?

 

Mem: 24536K used, 4988K free, 0K shrd, 3404K buff, 9976K cached
CPU:   0% usr   0% sys   0% nice   5% idle   0% io   2% irq  90% softirq
Load average: 3.11 1.59 0.69
 PID  PPID USER     STAT   VSZ %MEM %CPU COMMAND
   3     2 admin    RW       0   0%  44% [ksoftirqd/0]
   4     2 admin    SW       0   0%  27% [events/0]
1376  1309 admin    S     1996   7%   8% /bin/dropbear -F -d /etc/persistent/d
1411  1408 admin    R     1972   7%   4% top
1308     1 admin    R     4216  14%   4% /bin/lighttpd -D -f /etc/lighttpd.con
  52     2 admin    SW       0   0%   4% [bdi-default]
1159     1 admin    S <   1964   7%   3% /bin/watchdog -t 1 /dev/watchdog
1304     1 admin    S     6272  21%   0% /bin/infctld -m -c -d
1309     1 admin    S     1940   7%   0% /bin/dropbear -F -d /etc/persistent/d
1305     1 admin    S     1968   7%   0% /bin/syslogd -n -S
   1     0 admin    S     1976   7%   0% init
1408  1376 admin    S     1976   7%   0% -sh
 944     1 admin    S     1976   7%   0% init
1306     1 admin    S     1500   5%   0% /usr/bin/iwevent -s
1307     1 admin    S     1392   5%   0% /sbin/ntpclient -n -s -c 0 -l -h 192.
 492     1 admin    S     1140   4%   0% /sbin/hotplug2 --persistent --set-rul
 165     2 admin    SW       0   0%   0% [mtdblockd]
  50     2 admin    SW       0   0%   0% [sync_supers]
   5     2 admin    SW       0   0%   0% [khelper]
   2     0 admin    SW       0   0%   0% [kthreadd]

 

Заранее благодарю за подсказки.

Share this post


Link to post
Share on other sites

pps какой через железячку?

Share this post


Link to post
Share on other sites

pps какой через железячку?

Хз, как узнать? Проводом устройство включено в роутер, который показывает в это время около 1000 pps. И этот station, о котором речь образует 5 ГГц мост с AP. Так вот на AP такого не наблюдается. А там дальше куча клиентов-физиков, торренты и т.п. - да.

И, к слову, она не всегда падает. Иногда просто могут подскочить пинги до 400 мс. и поднятся загрузка cpu до 100% минут на пять, а потом отпустить. И, как правило, вечером.

Share this post


Link to post
Share on other sites

Обычно это случается из-за пакетной перегрузки. Может что-то еще, но другие причины мне не известны. Постарайтесь последить за pps, как со стороны LAN так и со стороны WLAN. Фаервол/шейпер запущены?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this