Jump to content
Калькуляторы

pause frame на абонентском порту

На коммутаторе SNR-2960-48G в портах пары абонентов растет счетчик pause frame, за неделю порядка 10 тыс наматывает. Это я так понимаю чтото от flow-control? У других трех десятков за то же время натекает от 0 до 7 таких пакетов.

Какова может быть причина роста этих пакетов? :)

Share this post


Link to post
Share on other sites

#sh ver
 SNR-S2960-48G Device, Compiled on Jul 01 10:54:35 2011
 SoftWare Version 6.2.128.0
 BootRom Version 4.10.2
 HardWare Version R01
 CPLD Version 0.5
 Device serial number AC23013845
 Copyright (C) 2011 NAG LLC
 All rights reserved
 Last reboot is cold reset.
 Uptime is 1 weeks, 4 days, 22 hours, 27 minutes

 

#sh run
!
no service password-encryption

!
!
clock timezone Ekb add 6 0
!
!
ip dhcp snooping enable
!
!
!
!
!
!
!
!
vlan 1
!
vlan 2
name users
!
vlan 3
name Manage
!
Interface Ethernet0/0/1
switchport access vlan 2
loopback-detection specified-vlan 2
loopback-detection control block
!
Interface Ethernet0/0/2
switchport access vlan 2
loopback-detection specified-vlan 2
loopback-detection control block
!
.....
!
Interface Ethernet0/0/48
switchport access vlan 2
loopback-detection specified-vlan 2
loopback-detection control block
!
Interface Ethernet0/0/49
!
Interface Ethernet0/0/50
!
Interface Ethernet0/0/51
!
Interface Ethernet0/0/52
switchport mode trunk
ip dhcp snooping trust
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
shutdown
!
interface Vlan3
description Manage
ip address 192.168.xx.yy 255.255.255.0
!
ip default-gateway 192.168.xx.254
!
sntp server 192.168.33.1
!
no login
!
!
end

Share this post


Link to post
Share on other sites

Добрый день!

 

На коммутаторах SNR-S3650G-48S растут счётчики pause frame.

 

Пример:

Сделан сброс счётчиков на порту Ethernet1/0/11.

За 4 часа значение input счётчика Pause frame увеличилось с 0 до 2072.

Скорость передачи трафика на порту не поднималась выше 1,4 мбит/с (см. скрин во вложении)

 

Конфиг порта:

Interface Ethernet1/0/11
bandwidth control 307200 both
switchport mode trunk
switchport trunk allowed vlan 1;406;805

 

О коммутаторе:

 #sh ver
 SNR-S3650G-48S Device, Compiled on Nov 03 10:13:33 2014
 CPU Mac f8:f0:82:10:1c:0d
 Vlan MAC f8:f0:82:10:1c:0c
 SoftWare Version 7.0.3.5(B0207.0019)
 BootRom Version 7.1.5
 HardWare Version 1.0.1
 CPLD Version N/A
 Serial No.:SW032610D610000187
 Copyright (C) 2014 NAG LLC
 All rights reserved
 Last reboot is warm reset.
 Uptime is 29 weeks, 5 days, 2 hours, 43 minutes

 

Интерфейс

#sh interface Ethernet1/0/11
Interface brief:
 Ethernet1/0/11 is up, line protocol is up
 Ethernet1/0/11 is layer 2 port, alias name is test, index is 11
 Hardware is SFP, address is f8-f0-82-10-1c-0d
 PVID is 1
 MTU 1500 bytes, BW 1000000 Kbit
 Time since last status change:2w-4d-3h-43m-5s  (1568585 seconds)
 Encapsulation ARPA, Loopback not set
 Auto-duplex: Negotiation full-duplex, Auto-speed: Negotiation 1G bits
 FlowControl is off, MDI type is auto
Transceiver info:
 SFP found in this port, manufactured by OEM, on (null) 00 0.
 Type is 1000BASE-LX.  Serial number is SK130930130051.
 Link length is 3000 m for Single Mode Fiber.
 Nominal bit rate is 1300 Mb/s.
 Laser wavelength is 1310 nm.
Statistics:
 5 minute input rate 1672 bits/sec, 0 packets/sec
 5 minute output rate 8428 bits/sec, 12 packets/sec
 The last 5 second input rate 150 bits/sec, 0 packets/sec
 The last 5 second output rate 7914 bits/sec, 13 packets/sec
 Input packets statistics:
   90950 input packets, 10269217 bytes, 0 no buffer
   88698 unicast packets, 180 multicast packets, 0 broadcast packets
   0 input errors, 0 CRC, 0 frame alignment, 0 overrun, 0 ignored,
   0 abort, 0 length error, 2072 pause frame
 Output packets statistics:
   303433 output packets, 339803505 bytes, 0 underruns
   235756 unicast packets, 30487 multicast packets, 37190 broadcast packets
   0 output errors, 0 collisions, 0 late collisions, 0 pause frame

 

С Ethernet1/0/11 по оптике запущен DGS-1100-06/ME на котором Flow control отключён.

 

Есть и другие клиенты на чьих портах при аналогичной схеме подключения input счётчики Pause frame, у некоторых увеличиваются, а у некоторых остаются неизменными либо как у топикстартера незначительно увеличиваются.

post-71214-093394800 1434891262_thumb.jpg

Edited by alexdirty

Share this post


Link to post
Share on other sites

alexdirty

Может с другой стороны flow control включен, либо кто-то на хабре писал что на некоторых железках чип коммутации так разгружал свою маленькую буферную память - слал pause frame на линейную карту.

Share this post


Link to post
Share on other sites

Добрый день, alexdirty!

 

Есть и другие клиенты на чьих портах при аналогичной схеме подключения input счётчики Pause frame, у некоторых увеличиваются, а у некоторых остаются неизменными либо как у топикстартера незначительно увеличиваются.

 

Под аналогичной схемой имеете в виду транзитный DGS-1100-06/ME?

Проблема носит косметический характер (просто растут счетчики) или имеется явная деградация качества предоставляемых сервисов на данных портах?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this