Jump to content
Калькуляторы

Juniper SRX100

Всем привет!

 

Настраиваю pppoe соединение на сабжевом девайсе уже хз в который раз, но оно не устанавливается, попытки установить соединение есть.

Где могу ошибаться, подскажите пожалуйста:

 

root# run show configuration
## Last commit: 2013-02-22 22:33:40 UTC by root
version 11.2R4.3;
system {
   root-authentication {
       encrypted-password "$1$QFOpf3sm$dKCb6Y9t7BzBGtzp8HfxF/"; ## SECRET-DATA
   }
   services {
       ssh;
       telnet;
       xnm-clear-text;
       web-management {
           http {
               interface vlan.0;
           }
           https {
               system-generated-certificate;
               interface vlan.0;
           }
       }
       dhcp {
           router {
               192.168.1.1;
           }
           pool 192.168.1.0/24 {
               address-range low 192.168.1.2 high 192.168.1.254;
           }
           propagate-settings fe-0/0/0.0;
       }
   }
   syslog {
       archive size 100k files 3;
       user * {
           any emergency;
       }
       file messages {
           any critical;
           authorization info;
       }
       file interactive-commands {
           interactive-commands error;
       }
   }
   max-configurations-on-flash 5;
   max-configuration-rollbacks 5;
   license {
       autoupdate {
           url https://ae1.juniper.net/junos/key_retrieval;
       }
   }
}
interfaces {
   fe-0/0/0 {
       unit 0;
   }
   fe-0/0/1 {
       unit 0 {
           family ethernet-switching {
               vlan {
                   members vlan-trust;
               }
           }
       }
   }
   fe-0/0/2 {
       unit 0 {
           family ethernet-switching {
               vlan {
                   members vlan-trust;
               }
           }
       }
   }
   fe-0/0/3 {
       unit 0 {
           family ethernet-switching {
               vlan {
                   members vlan-trust;
               }
           }
       }
   }
   fe-0/0/4 {
       unit 0 {
           family ethernet-switching {
               vlan {
                   members vlan-trust;
               }
           }
       }
   }
   fe-0/0/5 {
       unit 0 {
           family ethernet-switching {
               vlan {
                   members vlan-trust;
               }
           }
       }
   }
   fe-0/0/6 {
       unit 0 {
           family ethernet-switching {
               vlan {
                   members vlan-trust;
               }
           }
       }
   }
   fe-0/0/7 {
       unit 0 {
           encapsulation ppp-over-ether;
       }
   }
   pp0 {
       traceoptions {
           flag all;
       }
       unit 0 {
           point-to-point;
           ppp-options {
               pap {
                   local-name 35445gbsz3;
                   local-password "$9$5z/dfeFDScKWLEhgoJUHkIEhyvW"; ## SECRET-DATA
                   passive;
               }
           }
           pppoe-options {
               underlying-interface fe-0/0/7.0;
               idle-timeout 0;
               auto-reconnect 10;
               client;
           }
           family inet {
               mtu 1492;
               negotiate-address;
           }
       }
   }
   vlan {
       unit 0 {
           family inet {
               address 192.168.1.1/24;
           }
       }
   }
}
routing-options {
   static {
       route 0.0.0.0/32 {
           next-hop pp0.0;
           metric 0;
       }
   }
}
protocols {
   stp;
}
security {
   screen {
       ids-option untrust-screen {
           icmp {
               ping-death;
           }
           ip {
               source-route-option;
               tear-drop;
           }
           tcp {
               syn-flood {
                   alarm-threshold 1024;
                   attack-threshold 200;
                   source-threshold 1024;
                   destination-threshold 2048;
                   timeout 20;
               }
               land;
           }
       }
   }
   nat {
       source {
           rule-set trust-to-untrust {
               from zone trust;
               to zone untrust;
               rule source-nat-rule {
                   match {
                       source-address 0.0.0.0/0;
                   }
                   then {
                       source-nat {
                           interface;
                       }
                   }
               }
           }
       }
   }
   policies {
       from-zone trust to-zone untrust {
           policy trust-to-untrust {
               match {
                   source-address any;
                   destination-address any;
                   application any;
               }
               then {
                   permit;
               }
           }
       }
   }
   zones {
       security-zone trust {
           host-inbound-traffic {
               system-services {
                   all;
               }
               protocols {
                   all;
               }
           }
           interfaces {
               vlan.0;
           }
       }
       security-zone untrust {
           screen untrust-screen;
           host-inbound-traffic {
               system-services {
                   all;
               }
           }
           interfaces {
               fe-0/0/0.0 {
                   host-inbound-traffic {
                       system-services {
                           dhcp;
                           tftp;
                       }
                   }
               }
               fe-0/0/7.0;
               pp0.0;
           }
       }
   }
}
vlans {
   vlan-trust {
       vlan-id 3;
       l3-interface vlan.0;
   }
}

 

Заранее благодарен!

Share this post


Link to post
Share on other sites

Вот лог статистики pppoe

root# run show pppoe statistics
Active PPPoE sessions: 0
 PacketType                       Sent         Received
   PADI                             24                0
   PADO                              0                0
   PADR                              0                0
   PADS                              0                0
   PADT                              0                0
   Service name error                0                0
   AC system error                   0                0
   Generic error                     0                0
   Malformed packets                 0                0
   Unknown packets                   0                0
 Timeout
   PADI                              4
   PADO                              0
   PADR                              0
 Receive Error Counters
   PADI                              0
   PADO                              0
   PADR                              0
   PADS                              0

Share this post


Link to post
Share on other sites

Ни кто не подсказал :( Хотя бы понять в чем проблема, в настройках или в чем то другом...

Делал по мануалу с сайта кб джунипер.

Share this post


Link to post
Share on other sites

Разверните pppoe сервер и поглядите его логи.

Спасибо! Уже разобрался. В офис была заведена оптика, конечное оборудование медиаконвертор к медиаконвертору цеплялся джунипер, а на другой стороне оказывается порт был настроен как транковый.

Вот теперь другой вопрос, порт сейчас сконфигурирован с такими параметрами:

root# show interfaces fe-0/0/7
unit 0 {
   family ethernet-switching {
       port-mode trunk;
       vlan {
           members [ pppoe vpn ];
       }

 

Для настройки pppoe надо прописать encapsulation ppp-over-ether на физическом интерфейсе, сейчас порт с таким параметром ethernet-switching. С указанием двух параметров, настройки не применяются. Вот не могу понять, теперь этот параметр encapsulation ppp-over-ether применять к какому интерфейсу? Я думал может его указать интерфейсу vlan, через который и работает pppoe соединение.

Edited by garmonik

Share this post


Link to post
Share on other sites

Хотя бред написал. Просто pppoe соединение не умеет работать через транковый порт. Собственно транковому порту указал нативный vlan, но как теперь привязать pppoe соединение к этому порту?

Вот конфиг с сайта джунипер:

interfaces {
   fe-0/0/5 {
       unit 0 {
           encapsulation ppp-over-ether;
       }
   }
   pp0 {
       unit 0 {
           ppp-options {
               pap {
                   access-profile ppp-profile;
                   local-password "dkwoxslxqpz";##SECRET-DATA
                   local-name "username";
                   passive;
               }
           }
           pppoe-options {
               underlying-interface fe-0/0/5.0;
               auto-reconnect 10;
               client;
               idle-timeout 0;
           }
           family inet {
               negotiate-address;
               mtu 1492;
           }
       }
   }
}     

 

Т.е. в режиме транка ,порт нельзя сконфигурировать так, чтобы через него работало pppoe соединение?

Share this post


Link to post
Share on other sites

Судя по всему, в транке вам надо выделить некоторый сабинтерфейс и в нем поднимать уже PPPoE. То есть не в интерфейсе, а в конкретном сабинтерфейсе.

Share this post


Link to post
Share on other sites

вы не различаете понятия коммутатор и маршрутизатор.

port mode trunk это попытка обозвать некий физ интерфейс портом коммутатора, у которого могет быть только один сабинтрефейс unit 0

вам надо узнать у провайдера можно ли поменять ppoe на прямой ip тем более если оптика. Далее если транком, то подразумевается, что подают несколько виланов.

edit interfaces fe-0/0/0

set vlan-tagging

set unit 999 \\номер тега который дал провайдер\\ vlan-id 999 \\а тут уже пишете вашу инкапсуляцию\\

неплохо бы добавить вилану скажем

edit vlans ppoe

set l3-interfaces fe-0/0/0.999 \\как-то так\\

vlan-id 999

ах да безопастность

set security zones security-zone untrust \\или че там у вас\\ fe-0/0/0.999

и будет вам счастье

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this