Jump to content
Калькуляторы

Фильтрация multicast групп

Всем привет. Мы отдаем своим партнерам ряд ТВ каналов посредством multicast. Подскажите, как отдавать только определенные группы каналов? Если я повешу acl на интерфейс и укажу нужные группы, не подскочит ли загрузка ЦПУ (у меня C3750)? Как идеологически правильно это делать?

Share this post


Link to post
Share on other sites

Это зависит о того как вы им сейчас отдаете multicast. Вы льете потоки от всех каналов непрерывно или отдаете динамически по запросу(IGMP, PIM etc)?

Share this post


Link to post
Share on other sites

Это зависит о того как вы им сейчас отдаете multicast. Вы льете потоки от всех каналов непрерывно или отдаете динамически по запросу(IGMP, PIM etc)?

 

отдаем через PIM-SM. Порт в сторону партнера в среднем загружен на 500 Мбит/c

Share this post


Link to post
Share on other sites

отдаем через PIM-SM. Порт в сторону партнера в среднем загружен на 500 Мбит/c

 

если бы было просто IGMP, то можно было было бы использовать "ip igmp profile". Но в данном случае только acl на интерфейсе поможет, как уже писали. К сожалению на 3750 не удастся отфильтровать только PIM join сообщения.

Share this post


Link to post
Share on other sites

Working primer:

1/0/1 - VID 10 - mcast net

1/0/2 - VID 20 - output VLAN

1/0/3 - VID 20 - link to another

 

1/0/1 - 1/0/2 - make link with cable (firewall and remap vlan)

----------------------------------------------------------

 

access-list 2201 permit ip any host 233.2.2.1

 

interface GigabitEthernet1/0/1

switchport access vlan 10

ip access-group 2201 in

 

interface GigabitEthernet1/0/2

switchport access vlan 20

ip access-group 2201 in

 

interface GigabitEthernet1/0/3

description Link_to_ZZZ

switchport access vlan 20

 

ip igmp snooping vlan 10 static 233.2.2.1 interface Gi1/0/1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.