Jump to content
Калькуляторы

Востановление загрузчика или IOS на Cisco 1700 Как прошить или востановить?

Всем привет!

Коллега настраивал циску и чтото намудрил, умерла она говорит после того как он пытался сохранить сонфигурацию, теперь она грузиться до определенного момента и встает, сейчас подробностей описать немогу, циска у меня но сонсольного шнурка нет под рукой.

Ткните куда копать и что делать, IOS переставлять или может както загрузчик перезалить возможно?

Share this post


Link to post
Share on other sites

Вот что говорит консоль

System Bootstrap, Version 12.2(1r)XE1, RELEASE SOFTWARE (fc1)
C1700 platform with 131072 Kbytes of main memory

device does not contain a valid magic number
loadprog: error - on file open
boot: cannot load "flash:c1700-advsecurityk9-mz.124-25d.bin"

device does not contain a valid magic number
boot: cannot open "flash:"
boot: cannot determine first file name on device "flash:"

device does not contain a valid magic number
boot: cannot open "flash:"
boot: cannot determine first file name on device "flash:"

После этого уходит в rommon

Вот что дает команда dir flash:

rommon 6 > dir flash:
device does not contain a valid magic number
dir: cannot open device "flash:"

 

Насколько я понимаю кошка не видит флеш?

В чем дело и как поправить, помогите друзья

Share this post


Link to post
Share on other sites

Или помер сам чип флеши или просто разрушилась его структура. Если последнее, то воспользоваться тебе надо командой tftpdnld для образа перезаливки, йунный падаван.Или долгой xmodem, бутром твой стар если. Или проапгрейдь бутром из статьи моей http://nag.ru/articles/article/20398/dopayka-pamyati-v-cisco-1751.html прорамматор под рукой имеешь если.

Share this post


Link to post
Share on other sites

спасибо sol

Я хотел востановит без потери конфигурации, но понял что не получится и стал перешивать, пробовал и через консольник и по tftp, вот что говорит tftp

File reception completed.
TFTP flash copy: Invalid file header, copy terminated.
Reason: Wrong target platform OR corrupt file.

У меня что получается прошивка битая?

У меня такая c1700-advsecurityk9-mz.124-25d.bin, если есть поделитесь

Железка Cisco 1751V

Share this post


Link to post
Share on other sites

написано-же: некорректный заголовок файла, копирование прервано. Причина - прошивка не от этой платформы или поврежденный файл.

 

Прошивкой делюсь: http://rutracker.org/forum/viewtopic.php?t=2989354

 

Конфиг, к стати, у ей в другой памяти живет, не во флеши. Так что, если конфиг принципильно жив, то он проявится после залива ИОСа.

Share this post


Link to post
Share on other sites

Спасибо sol, уже нашел и прошил,

извините, вроде потихоньку разобрался

Edited by l-servise2

Share this post


Link to post
Share on other sites

Огромное человеческое спасибо sol, в личной переписке помог мне с моими вопросами!

Переписку решили выложить в ветку, мелочь но возможно кому и поможет

-----------------------

какой командой сохранять конфигурацию?

copy running-config startup-config не помогает

sol

Конфиг сохраняется как раз copy running-config startup-config или у этой команды есть псевдоним ( альяс ) write или, короче, wr
В целях экономии флеши образ сжат алгоритмом pkzip. А в начале образа находится разжимальщик в формате ELF.
Первая строчка относится к тому, что содержимое флеши успешно перемещено в оперативную память, 
контрольные суммы корректны, размер его 0xd15980 = 13 719 936 байт, по адресу 0x80008000 находится 
точка входа в декомпрессор и управление передано ему.
Вторая строчка говорит о том, что декомпрессор ожил, проверил контрольные суммы сжатого образа и начал 
разжимать его в оперативной памяти. ###### разжимает-разжимает. ОК - все разжал, контрольные суммы разжатого 
корректны, управление передано самой IOS.
Конфиг может не "не сохраняться", а "не читатся". Есть такая штука, как конфигурационный регистр. 
Это темное наследие _больших_ машин, на которых учились программированию Лонард Босак и Сандра Лернер.
Отдельные его биты отвечают за хренову тучу всего. http://www.cisco.com...08022493f.shtml Вот полное описание. 
Его шестой бит отвечает за игнорирование начального конфига. Посему, надо узнать его текущее содержимое, запустить виндовый калькулятор, 
переключить его в режим "инженерный", в Хекс виде забить туда значение конфрега и переключить его в бинарный режим. 
И посмотреть по битам, что там включено а что выключено.

Тут разобрался все сохранил, спасибо за подробное объяснение и ценные совет. в общем все настройки вбил, осталось NAT настроить, провайдер выдал 172.16.122.6 255.255.255.252, шлюз 172.16.122.5, наша подсеть 192.168.1.0/24(DNS прописываем на самих машинках)

настроил так, выкладываю конфиг

Current configuration : 1281 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot system flash:c1700-advsecurityk9-mz.124-25d.bin
boot-end-marker
!
logging buffered 52000 informational
no logging console
enable secret 5 $1$aueA$R
!
no aaa new-model
memory-size iomem 15
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
username test password 0 test
!
!
!
!
!
!
interface Ethernet0/0
ip address 172.16.122.6 255.255.255.252
ip nat outside
ip virtual-reassembly
half-duplex
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
ip nat inside
ip virtual-reassembly
speed auto
!
interface Ethernet1/0
no ip address
shutdown
half-duplex
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.4.250
ip route 0.0.0.0 0.0.0.0 172.16.122.5
!
no ip http server
no ip http secure-server
ip nat pool telecom 172.16.122.5 172.16.122.5 netmask 255.255.255.252
ip nat inside source list 101 pool telecom overload
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
!

Смущает строчка

ip route 0.0.0.0 0.0.0.0 192.168.4.250

не пойму откуда взялась

Что посоветуешь?

И попутно как удалить ту строчку и как вообще допустим сбросить конфигурацию на ноль?

sol

ip route 0.0.0.0 0.0.0.0 192.168.4.250 - Указывает Last Resort Gateway . Он-же "маршрут по умолчанию", он-же "дефолт/дефаулт", 
он-же "шлюз по умолчанию", он-же "Default gateway". Убрать ее просто. Нужно предварить ее префиксом no. 
Вот так: no ip route 0.0.0.0 0.0.0.0 192.168.4.250

Вообще сбросить конфиг - erase startup-config и перезагрузится.

ДНС не надо прописывать на машинах. В качестве ДНС надо указать саму кошку. 
На ней работает DNS Proxy если включить ip name-server <ХХ.ХХ.ХХ.ХХ> и ip dns server

На интерфейсе, который смотрит к прову - ip nat outside на том, который вовнутрь - ip nat inside

На самой кошке ip nat inside source list <список доступа, кого натить, кого нет> interface <интерфейс, через который ходим в мир> overload

ip access-list extended <кого натим>
permit ip 192.168.1.0 0.0.0.255 any

Спасибо sol, выручил, все получилось.

Слушай, есть еще такой вопросик, сложно ли на циске развернуть ip атс, схема такая:

5 ip телефонов, нужно по короткие внутренние номера заворачивать по ip на АТС в головном офисе,

а при наборе городского номера перенаправляла на модуль куда подключены аналоговые линии,

на кошке модуль для подключения аналоговых линий имеется

Насколько сложно такое реализовать?

sol

IP ATC на циске реализовать можно, но не нужно. Это не ее функция. Хотя, можно, в общем-то...
Кроме модуля FXO надо, что-бы в ней был модуль кодеков. sh diag в помощь.

Share this post


Link to post
Share on other sites

Извиняюсь за офтоп, но решил здесь написать, вопрос последовательный просто

Посоветуйте тогда что использовать в качестве мини IP АТС, если астериск то какую плату с FXO или шлюз посоветуете для выхода на PSTN? С учетом цена/качество

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this