Перейти к содержимому
Калькуляторы

H-VPLS не взлетает

Есть работающее ядро на 7600-х. в ядре поднят VPLS, к ядру приходят кольца из свитчей с терминацией вланов по 802,1Q.

Пришел ME3600x, надо подружить его с VPLS. Подняли линк к одному из роутеров ядра.

Конфиги,

7600:

 

interface Loopback0

ip address 10.1.208.50 255.255.255.255

 

interface TenGigabitEthernet2/4 // порт карты ES+

mtu 1600

ip address 10.21.0.1 255.255.255.252

mpls ip

mpls label protocol ldp

 

l2 vfi vl950 manual

vpn id 950

neighbor 10.1.208.51 encapsulation mpls

neighbor 10.1.208.52 encapsulation mpls

neighbor 10.11.12.13 encapsulation mpls no-split-horizon //коннект к ME3600х

 

interface Vlan950

ip address 10.0.52.233 255.255.255.0

xconnect vfi vl950

 

router ospf 15

log-adjacency-changes

passive-interface default

no passive-interface TenGigabitEthernet2/2

no passive-interface TenGigabitEthernet2/3

no passive-interface TenGigabitEthernet2/4

network 10.20.0.4 0.0.0.3 area 1

network 10.20.0.8 0.0.0.3 area 1

network 10.21.0.0 0.0.0.3 area 1

network 10.1.208.50 0.0.0.0 area 1

 

ME3600x

 

interface Loopback0

ip address 10.11.12.13 255.255.255.255

 

interface TenGigabitEthernet0/1

no switchport

mtu 1600

ip address 10.21.0.2 255.255.255.252

mpls ip

 

interface Vlan950

no ip address

xconnect 10.1.208.50 950 encapsulation mpls

 

interface GigabitEthernet0/2

switchport access vlan 950

spanning-tree portfast

 

router ospf 15

passive-interface default

no passive-interface TenGigabitEthernet0/1

network 10.11.12.13 0.0.0.0 area 1

network 10.21.0.0 0.0.0.3 area 1

 

 

самое интересное, что OSPF поднимается, LDP тоже, xconnect тоже

 

ME3600#sh xconnect int vl 950 det

XC ST Segment 1 S1 Segment 2 S2

------+---------------------------------+--+---------------------------------+--

UP pri ac Vl950:950(Eth VLAN) UP mpls 217.19.208.50:950 UP

Interworking: ethernet Local VC label 18

Remote VC label 57

 

ME3600#sh mpls l2transport vc 950 det

Local interface: Vl950 up, line protocol up, Eth VLAN 950 up

Interworking type is Ethernet

Destination address: 10.1.208.50, VC ID: 950, VC status: up

Output interface: Te0/1, imposed label stack {57}

Preferred path: not configured

Default path: active

Next hop: 10.21.0.1

Create time: 00:46:16, last status change time: 00:36:23

Signaling protocol: LDP, peer 217.19.208.50:0 up

Targeted Hello: 10.11.12.13(LDP Id) -> 10.1.208.50, LDP is UP

Status TLV support (local/remote) : enabled/supported

LDP route watch : disabled

Label/status state machine : established, LruRru

Last local dataplane status rcvd: No fault

Last BFD dataplane status rcvd: Not sent

Last BFD peer monitor status rcvd: No fault

Last local AC circuit status rcvd: No fault

Last local AC circuit status sent: No fault

Last local LDP TLV status sent: No fault

Last remote LDP TLV status rcvd: No fault

Last remote LDP ADJ status rcvd: No fault

MPLS VC labels: local 18, remote 57

Group ID: local 0, remote 0

MTU: local 1500, remote 1500

Remote interface description:

Sequencing: receive disabled, send disabled

Control Word: On (configured: autosense)

Dataplane:

SSM segment/switch IDs: 4099/12290 (used), PWID: 3

VC statistics:

transit packet totals: receive 1372, send 538

transit byte totals: receive 118162, send 44907

transit packet drops: receive 0, seq error 0, send 0

 

С другой стороны все так же.

Но на 7600-й не видно маков в 950 влане с ME3600x, а на ME3600x я вижу такую картину:

 

ME3600#sh mac add vl 950

Mac Address Table

-------------------------------------------

 

Vlan Mac Address Type Ports

---- ----------- -------- -----

All 0100.0000.0000 STATIC CPU

All 0100.0ccc.cccc STATIC CPU

All 0100.0ccc.cccd STATIC CPU

All 0100.0ccc.ccce STATIC CPU

All 0100.0ccd.cdd0 STATIC CPU

All 0100.0cdd.dddd STATIC CPU

All 0180.c200.0000 STATIC CPU

All 0180.c200.0001 STATIC CPU

All 0180.c200.0002 STATIC CPU

All 0180.c200.0003 STATIC CPU

All 0180.c200.0004 STATIC CPU

All 0180.c200.0005 STATIC CPU

All 0180.c200.0006 STATIC CPU

All 0180.c200.0007 STATIC CPU

All 0180.c200.0008 STATIC CPU

All 0180.c200.0009 STATIC CPU

All 0180.c200.000a STATIC CPU

All 0180.c200.000b STATIC CPU

All 0180.c200.000c STATIC CPU

All 0180.c200.000d STATIC CPU

All 0180.c200.000e STATIC CPU

All 0180.c200.000f STATIC CPU

All 0180.c200.0010 STATIC CPU

All ffff.ffff.ffff STATIC CPU

950 0080.3782.5c5a DYNAMIC 0.0.0.0, 0

950 0080.3782.5d6d DYNAMIC 0.0.0.0, 0

950 0080.3782.769b DYNAMIC 0.0.0.0, 0

950 1cc1.dea0.2760 DYNAMIC Gi0/2

950 8843.e1df.1580 DYNAMIC 0.0.0.0, 0

 

Т.е. маки с 7600 приходят (и я даже вижу броадкаст от них на порту G0/2), но как-то странно пишется порт, откуда они пришли (0.0.0.0, 0)

А вот на 7600 мака 1cc1.dea0.2760 не видно, хотя он постоянно пытается пинговать узлы за VPLS.

 

Да, версии софта:

 

ME3600#sh ver

Cisco IOS Software, ME360x Software (ME360x-UNIVERSAL-M), Version 15.2(2)S1, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright © 1986-2012 by Cisco Systems, Inc.

Compiled Tue 22-May-12 21:21 by prod_rel_team

 

ROM: Bootstrap program is WHALES boot loader

BOOTLDR: ME360x Boot Loader (ME360X-HBOOT-M), Version 12.2 [sourdutt-loader_release_ledfix 100]

 

Switch uptime is 1 hour, 8 minutes

System returned to ROM by power-on

System image file is "flash:/me360x-universal-tar.152-2.S1/me360x-universal-mz.152-2.S1/me360x-universal-mz.152-2.S1.bin"

Last reload reason: Unknown reason

 

 

License Level: AdvancedMetroIPAccess

License Type: Permanent

Next reload license Level: AdvancedMetroIPAccess

 

cisco ME-3600X-24FS-M (PowerPC8572) processor (revision A0) with 1015808K/32760K bytes of memory.

Processor board ID FOC1614V1JB

Last reset from power-on

3 Virtual Ethernet interfaces

25 Gigabit Ethernet interfaces

2 Ten Gigabit Ethernet interfaces

The password-recovery mechanism is enabled.

 

1536K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address : 2C:36:F8:B2:05:00

Motherboard assembly number : 73-12693-07

Motherboard serial number : FOC16110YCH

Model revision number : A0

Motherboard revision number : B0

Model number : ME-3600X-24FS-M

System serial number : FOC1614V1JB

Top Assembly Part Number : 800-32951-01

Top Assembly Revision Number : B0

Version ID : V01

CLEI Code Number : IPML500KRA

 

Configuration register is 0xF

 

7600#sh ver

Cisco IOS Software, c7600rsp72043_rp Software (c7600rsp72043_rp-ADVENTERPRISEK9-M), Version 12.2(33)SRE3, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright © 1986-2011 by Cisco Systems, Inc.

Compiled Tue 25-Jan-11 11:09 by prod_rel_team

 

ROM: System Bootstrap, Version 12.2(33r)SRB4, RELEASE SOFTWARE (fc1)

BOOTLDR: Cisco IOS Software, c7600rsp72043_rp Software (c7600rsp72043_rp-ADVENTERPRISEK9-M), Version 12.2(33)SRE3, RELEASE SOFTWARE (fc1)

 

CORE-U uptime is 1 year, 15 weeks, 5 days, 2 hours, 55 minutes

Uptime for this control processor is 1 year, 15 weeks, 5 days, 29 minutes

System returned to ROM by power cycle (SP by power on)

System restarted at 14:06:35 MET Wed Mar 2 2011

System image file is "bootdisk:/c7600rsp72043-adventerprisek9-mz.122-33.SRE3.bin"

Last reload type: Normal Reload

 

 

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

 

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

 

If you require further assistance please contact us by sending email to

export@cisco.com.

 

Cisco CISCO7604 (M8500) processor (revision 2.0) with 1900544K/131072K bytes of memory.

Processor board ID FOX1420H5QQ

BASEBOARD: RSP720

CPU: MPC8548_E, Version: 2.0, (0x80390020)

CORE: E500, Version: 2.0, (0x80210020)

CPU:1200MHz, CCB:400MHz, DDR:200MHz,

L1: D-cache 32 kB enabled

I-cache 32 kB enabled

 

Last reset from power-on

161 Virtual Ethernet interfaces

28 Gigabit Ethernet interfaces

8 Ten Gigabit Ethernet interfaces

3964K bytes of non-volatile configuration memory.

 

500472K bytes of Internal ATA PCMCIA card (Sector size 512 bytes).

Configuration register is 0x2102

 

Уже замучился. Может это софтовый баг, или я что-то не так наконфигурил??

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

для начала надо сделать area 0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

да как бы не помогло. я ж говорил, что OSPF работает без проблем

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну хорошо, надо начать проверять все по порядку:

Во-первых, поддерживает такую конфигурацию ваша 3600 или нужна доп. Лицензия или еще чего :)

Во-вторых, точно такие же симптомы наблюдаются если сделать xconnect без es+ карт. См. Пункт первый :).

Ну и я ничего нового не скажу, если предложу проверить хождения трафика по меткам хоп за хопом.

Также нужно поснифать трафик на линках, приходят ли к вам пакетики через псевдопровод и совпадает ли там кол-во тегов dot1q ;)

 

Ну и я бы проверил сначала xconnect c 76 прямо в порт 3600. За одно и трафик поснифать получится.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

На me3600 в интерфейс-влане пропишите platform rewrite imposition tag push 1 symmetric

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

командочка не помогла.

броадкастовый трафик из влана 950 приходит на 3600, маки в таблице я вижу. а вот на 7600 я маков, которые за 3600 находятся, не вижу.

пробовал делать xconnect на порт, та же ситуация, на порту броадкаст есть, а за роутер в обратную сторону ничего не проходит

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот тут в презентации, вроде всё чётко http://www.cisco.com/application/pdf/en/us/guest/tech/tk891/c1482/ccmigration_09186a00801ed3ea.pdf

Настройки тоже вроде верные. Но может на что-то наведёт =)

А вот тут все варианты разобраны

http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/es20lc/baldcfg.htm

Изменено пользователем triam

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Другие neighbor в vfi как работают? Точнее Interworking type у них какой? А то 76-я в vfi умеет только одинаковые типы, а если тип vlan, то и тэги одинаковые должны быть.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

в сторону других нейборов тоже Interworking type is Ethernet

я уж и vfi пробовал поднимать с ME3600, все равно не взлетает, 76-я не видит маков из-за 3600 хоть ты тресни!!!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

drovorub

Если мне память не изменяет, ваша лицензия позволяет писать service instance на 3600

Попробуй вот так:

interface GigabitEthernet0/2

no switchport

service instance 11 ethernet

encapsulation untagged

xconnect 10.1.208.50 950 encapsulation mpls

mtu 1500

 

И ещё одна "хрень" за 76-й водится - если удалённая сторона на xconnect сначала прописана неправильно, а потом прописывается правильно, на 76-й надо всё убить и создать заново, чтобы заработало.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

спасибо за совет! в понедельник попробую.

если не получится - буду обновлять софт на 7600. почему-то думается что проблема именно в 7600.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Я тут с похожей задачей. Только вместо 7600 у меня ASR1002

Пока решил не лепить похожую схему, официально ASR умеет VPLS, а 3600 - нет.

 

xconnect тут конечно все ясно и понятно, но вот будет ли работать - засомневался.

Кстати, что из имиджей gns умеет vpls ? :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

3600 в 15 ветке софта умеет VPLS. правда пока не знаю насколько надежно работает, но на тестовом стенде все ОК.

но мне VPLS в 3600 и не нужен пока. VPLS поднят в ядре на 7600, а оттуда будут xconnect в вланы на 3600, т.е. получается VPLS с доступом по MPLS (H-VPLS). Но как я писал выше, пока не получается стык с 7600, хотя на тестовом стенде я поднял на 3600 vpls и оттуда кинул xconnect на другую 3600 и все работало. думаю все-таки косяк с софтом на 7600. попробую поставить на 7600 софт из 15-й ветки, авось поможет.

на GNS не видел девайсов, которые поддерживают VPLS. 7200 поддерживает обычный MPLS, на ней можно и потренироваться, она есть в GNS.

Изменено пользователем drovorub

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Да с MPLS на 7200 я и тренируюсь. По поводу 15 ветки спасибо, фичанафигатор по этой теме промолчал :(

Ок, попробуем-с

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас