Перейти к содержимому
Калькуляторы

Настройка LinkSys spa3102 для звонков из Line1->PSTN Выдается сигнал занято :(

Уважаемые профессионалы, пожалуйста, подскажите как настроить Linksys SPA 3102?

 

Нужно добиться следующего: чтобы всегда 3102 звонил через PSTN. (В дальнейшем он будет настроен для звонков через VoIP, для начала хотябы через PSTN)

 

Казалось бы, что все решается заданием заданием DialPlan вида: (xx. <:@gw0>).

Это не работает. После набора всегда идут гудки занято. На VoIP можно звонить без проблем.

Прошивка последняя.

Чтение форумов подсказало, что можно получить логи с аппарата. Вот кусок лога:

 

Jun  9 00:28:09 linksys Calling: 2555499@127.0.0.1:5061
Jun  9 00:28:09 linksys [0: 0]AUD ALLOC CALL (port=16456)
Jun  9 00:28:09 linksys [0: 0]RTP Rx Up
Jun  9 00:28:09 SDP RTPMAP 100 --> 134
Jun  9 00:28:09 SDP RTPMAP 101 --> 136
Jun  9 00:28:09 linksys AUD: Stop PSTN Tone
Jun  9 00:28:09 linksys [0]FM Alert Stop RxTx (c=0024e22c;a=0)
Jun  9 00:28:09 linksys [0: 0]AUD Rel Call
Jun  9 00:28:09 linksys CC: Failed w/ Calling
Jun  9 00:28:09 Sess Terminated 
Jun  9 00:28:12 linksys [0]On Hook
Jun  9 00:28:45 linksys CC: Clean Up
Jun  9 00:28:45 linksys --- OBJ POOL STAT ---
Jun  9 00:28:45 linksys OP: RTPRXB =  96 ( 96  192)   
Jun  9 00:28:45 linksys OP: RTPREB =  40 ( 40   48)
Jun  9 00:28:45 linksys OP: RTPTXB =  64 ( 64  108)   
Jun  9 00:28:45 linksys OP: TIMEOU = 111 (120   52)
Jun  9 00:28:45 linksys OP: SIPCOR =   0 (  1   28)   
Jun  9 00:28:45 linksys OP: SIPCTS =  32 ( 32  580)
Jun  9 00:28:45 linksys OP: SIPSTS =  32 ( 32 6064)   
Jun  9 00:28:45 linksys OP: SIPAUS =   7 (  8  588)
Jun  9 00:28:45 linksys OP: SIPDLG =  10 ( 10  148)   
Jun  9 00:28:45 linksys OP: SIPSES =  12 ( 12 8192)
Jun  9 00:28:45 linksys OP: SIPREG =   3 (  4  468)   
Jun  9 00:28:45 linksys OP: SIPLIN =   0 (  2  140)
Jun  9 00:28:45 linksys OP: SUBDLG =   2 (  2 6444)   
Jun  9 00:28:45 linksys OP: STUNTS =  16 ( 16   68)
Jun  9 00:28:45 linksys  

 

Опытные товарищи предлагали поменять настройки напряжения Line Voltage для PSTN, но это, к сожалению, ничего не дало.

 

Одна надежда на вас...

 

Благодарю!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

1) выключить питания линксиса. FXS автоматом за'failover'ится на FXO

2) Питание линксиса включить, выставить опцию failover to pstn в yes и выдернуть ethernet.

3) не выставлять настройки voip-ной части.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

DialPlan в студию :-)

по умолчанию должен звонить без всяких манипуляций

если у вас уже два канала PSTN и VoIP,добавте префиксы в диалплан

что то типа S:4, (P9|<9:>,x.<:@gw0>|<0:>xxx.)

9-город, 0-воайпи

Изменено пользователем koffin

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

1) выключить питания линксиса. FXS автоматом за'failover'ится на FXO

2) Питание линксиса включить, выставить опцию failover to pstn в yes и выдернуть ethernet.

 

Спасибо.

Сейчас эта опция включена и питание выключено. Смысла в постоянно выключенном 3102 нет :)

Что я хочу добиться - сделать так, чтобы все звонки, за исключением звонков на Москву, шли через PSTN, а на Москву шли через VoIP.

 

DialPlan в студию :-)

по умолчанию должен звонить без всяких манипуляций

 

DialPlan вида: (xx. <:@gw0>)

А без префисков (9,0) нельзя обойтись?

Был такой диалплан:

(x.<:@gw0>|<#:>xx.) - на VoIP все работало с префиксом, на PSTN - нет.

На PSTN при попытке набрать номер - сигнал занято :(

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Диалплан

 

(8495xxxxxxx|8499xxxxxxx|xxxxxxx|x.<:@gw0>)

 

Звонки с кодами 8-495 и 8-499, содержащие после кода 7 цифр, а также любые 7-ми значные номера будут уходить через VoIP. Всё остальное будет уходить через провод.

Изменено пользователем Alteron

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо, попробую.

 

Все же странно, что не работает диалплан: (x.<:@gw0>). По умолчанию он должен все перекидывать на PTSN.

Как протестирую - отпишусь.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А без префисков (9,0) нельзя обойтись?

 

Префикс, как мне видится, удобнее:

набрал 9-ку и любой номер пошел черег медь

набрал 0 и любой номер пошел через VoIP

и не нужно никаких дополнительныз правил придумывать.

кстати префикс # - в IP-телефонии как правило показывает устройству что дольше цифры вводиться не будут можно без дальшейшего ожидания (как правило от 3сек.) дозваниваться.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо, попробую.

 

Все же странно, что не работает диалплан: (x.<:@gw0>). По умолчанию он должен все перекидывать на PTSN.

Как протестирую - отпишусь.

Я ненаю, но вышеприведённое скопировал с работающего 3102. У меня, конечно, не Москва, но я по аналогии поправил. Могу прямо свой диал-план выложить с коментариями.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

DialPlan в студию :-)

по умолчанию должен звонить без всяких манипуляций

если у вас уже два канала PSTN и VoIP,добавте префиксы в диалплан

что то типа S:4, (P9|<9:>,x.<:@gw0>|<0:>xxx.)

9-город, 0-воайпи

никуда он звонить не должен без всяких манипуляций. c FXS порта приоритет всегда на SIP, и только в случае косяков с SIP, failover на fxo.

все что в dialplan c gw0 - это когда звонок приходит со стороны SIP.

Изменено пользователем rover-lt

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ничего не получилось. Попробовал разные диалпланы, но все равно после набора номера возникают сигналы "занято" :(

Пытался колдовать с Line-Voltage, как советовали на иностранных форумах. Результатов это не принесло. Какие есть еще идеи у коллективного разума?

 

никуда он звонить не должен без всяких манипуляций. c FXS порта приоритет всегда на SIP, и только в случае косяков с SIP, failover на fxo.

все что в dialplan c gw0 - это когда звонок приходит со стороны SIP.

 

UPDATE:

(x.<:@gw0>) - это насильное перенаправление на PSTN, которое указывается в диалплане. Кроме того, может сложиться ситуация, когда надо звонить в экстренные службы, и если проблемы с SIP - то должно идти сразу перенаправление на PSTN. Кроме того, есть много людей, которые заморчились такой проблемой и по отзывам многих у них все работает. У меня же проблема - что после перенаправления на gw0 выдается сигнал "занято", то есть оно теоретически должно работать, а вот практически - по ходу даже не снимает трубу на PSTN.

Изменено пользователем mailex

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

На Ixbt есть тема, где диал-план разжёвывается по шагам, остаётся только прочесть и применить у себя...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

у вас сейчас я так понимаю настроен sip воткнут провод сетевой? а если сетевой провод выдернуть и попробовать позвонить что дает?

А еще лучше, сбросте все настройки, оставьте только линию ГТС и телефон и попробуйте позвонить будет работать?

 

Да, кстати, диалплан где прописываете? в закладке Line1?

Изменено пользователем koffin

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Как написать диалплан - мне ясно, вопрос не совсем в нем. Вопрос в том, почему есть сигнал "занято" при перенаправлении на PSTN.

Ясно, что перенаправление идет (см.ниже лог.)

Jun  9 00:28:09 linksys Calling: 2555499@127.0.0.1:5061
Jun  9 00:28:09 linksys [0: 0]AUD ALLOC CALL (port=16456)
Jun  9 00:28:09 linksys [0: 0]RTP Rx Up

Перенаправление идет на собственный адрес(localhost) и порт 5061. Танцы с бубном и заменой IP порта результатов тоже не принесли.

 

Диалплан прописываю в Line1. Насчет провода ethernet - действительно, надо вытащить и попробовать. Спасибо за рекомендацию.

Изменено пользователем mailex

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

вот еще гляньте, момеж чем поможет, про диалплан расписано хорошо http://wiki.sipnet.ru/index.php/Dialplan_в_Linksys

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ничего не получилось. Попробовал разные диалпланы, но все равно после набора номера возникают сигналы "занято" :(

Набери номер и сделай скриншот статусной страницы.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Привожу скриншоты страницы info.

Танцы с бубнами вокруг diaplan ничего не принесли.

Чуть было не повезло при настройке других параметров.В какой-то момент, после замены одного из параметров вида Enable IP Dialing (см.Интерфейс)

случилось чудо и вся конструкция заработала. На радостях я даже сохранил файл конфигурации config.xml. Но при перезагрузке все пропало :(

 

Откат на предыдущую версию прошивки 5.1.7 ничего не дал. Какие будут мнения у экспертов?

post-103141-024331500 1339748160_thumb.png

post-103141-039357600 1339748174_thumb.png

post-103141-098537700 1339748181_thumb.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

вкладка PSTN Line

раздел VoIP-To-PSTN Gateway Setup

 

смотреть параметры

One Stage Dialing:

Line 1 VoIP Caller DP:

VoIP Caller Default DP:

 

ну и в дополнение не забыть там же в разделе Proxy and Registration параметр Ans Call Without Reg: разрешить (возможно, уже не помню).

 

P.S. примерно так давным-давно настраивал, в Administration Guidge примеры даже есть корявые слегка, но понять какие настройки крутить - вполне можно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

UPDATE:

(x.<:@gw0>) - это насильное перенаправление на PSTN,

 

Еще раз прочитайте мое сообщение. Если не нравится простой русский язык, читайте непонятный английский http://www.cisco.com/en/US/docs/voice_ip_comm/csbpvga/ata/administration/guide/ATA_AG_v3_NC-WEB.pdf

и не танцуйте с бубнами - не поможет :)

Изменено пользователем rover-lt

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

смотреть параметры

One Stage Dialing:

Line 1 VoIP Caller DP:

VoIP Caller Default DP:

ну и в дополнение не забыть там же в разделе Proxy and Registration параметр Ans Call Without Reg: разрешить (возможно, уже не помню).

В этих параметрах стоят диалпланы №1.

 

Line 1 VoIP Caller DP:

VoIP Caller Default DP:

 

Ans Call Without Reg: разрешено

 

Пока что безуспешно :(

Изменено пользователем mailex

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

UPDATE:

(x.<:@gw0>) - это насильное перенаправление на PSTN,

 

Еще раз прочитайте мое сообщение. Если не нравится простой русский язык, читайте непонятный английский http://www.cisco.com/en/US/docs/voice_ip_comm/csbpvga/ata/administration/guide/ATA_AG_v3_NC-WEB.pdf

и не танцуйте с бубнами - не поможет :)

 

никуда он звонить не должен без всяких манипуляций. c FXS порта приоритет всегда на SIP, и только в случае косяков с SIP, failover на fxo.

все что в dialplan c gw0 - это когда звонок приходит со стороны SIP.

 

Согласно Вашей трактовки, получается, что перенаправить с FXS на FXO невозможно. Это может произойти если SIP, к примеру, недоступен.

Тогда получается, что просто не указывая УЗ на SIP-сервере в SP3102 - он должен переводить звонки на FXO. Может это и происходит - только после набора номера на телефоне

у меня в телефоне сигнал "длинный гудок" и звонок, к примеру, на мобильный, не идет.

 

К тому же: у меня местные звонки через PTSN могут быть удобнее для меня чем, через VoIP. И мне не нужно все звонки отправлять в SIP.

Уверен, что я не одинок в этом.

 

Я не думаю, что в CISCO сидят ребята, которые это не учитывают. Сделав кучу настроек, не учесть такую простую вещь - трудно (на мой взгляд). Но я могу и ошибаться.

А звонок с FXS на FXO идет только тогда когда аппарат выключен (это равносильно тому что его попросту нет).

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ans Call Without Reg: там не нужен, по доке на внутренний звонок это не влияет.

Для линии 1 параметр Make Call Without Reg для внутренних звонков нужен.

 

в документации - начиная со стр.93 - How VoIP-To-PSTN Calls Work, для начала я бы предложил включить двухстадийный режим, а после получения гудка от линии и нормального набора номера туда, уже исключал бы остальное.

 

согласно скриншотам у вас сработал звонок согласно VoIP Fallback to PSTN (смотри last called number - там указано fallback@gw0)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сработать то сработал. Но в PSTN не ушел. Не было звонка.

 

Я каким-то странным образом переключил звонки сразу на PSTN, но теперь с PSTN они не приходят...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сработать то сработал. Но в PSTN не ушел. Не было звонка.

 

Я каким-то странным образом переключил звонки сразу на PSTN, но теперь с PSTN они не приходят...

 

не приходят: не звонит трубка или поднимаете трубку голоса нету?

на закладке PSTN Line параметр "PSTN Ring Thru Line 1:" должен быть yes

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

<PSTN_Ring_Thru_Line_1_2_>Yes</PSTN_Ring_Thru_Line_1_2_>

 

Это из файла конфигурации XML. Параметр включен, но что-то не работает.

Для меня совершенно неясный прибор этот SPA. Уже пожалел что его купил :(

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Давай сначала... Сбрось его полностью, подключи только телефон, линию и позвони.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас