Jump to content
Калькуляторы

Сбор информации с модемом Docsis Не отображается Upstream/Downstream Power

UBR'ы не получают информацию о Upstream Power и Downstream Power от модемов. Старожилы в конторе говорят, что раньше работало. При мне настройки касающиеся конкретно части Docsis не менялись.

 

Вывод show cable modem <mac> verbose

MAC Address                         : <mac>
IP Address                          : 10.5.0.179
Prim Sid                            : 181
QoS Profile Index                   : 5
Interface                           : C1/0/U0
sysDescr                            :
Upstream Power                      : 0.00 dBmV (SNR = 28.26 dBmV)
Downstream Power                    : 0.00 dBmV (SNR = ----- dBmV)
Timing Offset                       :  996
Initial Timing Offset               : 996
Received Power                      : !25.00
MAC Version                         : DOC2.0
QoS Provisioned Mode                : DOC1.0
Enable DOCSIS2.0 Mode               : Y
Phy Operating Mode                  : tdma
Capabilities                        : {Frag=N, Concat=Y, PHS=N, Priv=BPI}
Sid/Said Limit                      : {Max Us Sids=0, Max Ds Saids=0}
Optional Filtering Support          : {802.1P=N, 802.1Q=N}
Transmit Equalizer Support          : {Taps/Symbol= 1, Num of Taps= 24}
Number of CPE IPs                   : 2(Max CPE IPs = 255)
CFG Max-CPE                         : 255
Flaps                               : 4(Apr 5  01:55:55)
Errors                              : 0 CRCs, 0 HCSes
Stn Mtn Failures                    : 0 aborts, 0 exhausted
Total US Flows                      : 1(1 active)
Total DS Flows                      : 1(1 active)
Total US Data                       : 67005412 packets, 1800666036 bytes
Total US Throughput                 : 99 bits/sec, 0 packets/sec
Total DS Data                       : 96753702 packets, 2974097705 bytes
Total DS Throughput                 : 93 bits/sec, 0 packets/sec
Active Classifiers                  : 0 (Max = NO LIMIT)
DSA/DSX messages                    : permit all
Total Time Online                   : 23h42m

 

Настройка UBR'a:

cable config-file modemboot_all
frequency 378000000
service-class 2 max-upstream 2048
service-class 2 guaranteed-upstream 16
service-class 2 max-downstream 32768
service-class 2 max-burst 1800
cpe max 255
timestamp

!DHCP для модемов
ip dhcp pool CableInternet
  network 10.5.0.0 255.255.0.0
  bootfile modemboot_all
  next-server 10.5.255.254
  default-router 10.5.255.254
  option 128 ip 10.5.255.254
  option 4 ip 10.5.255.254
  option 11 ip 10.5.255.254
  option 10 ip 10.5.255.254
  option 7 ip 10.5.255.254
  option 2 hex 0000.2a30
  option 66 ip 10.5.255.254
  option 150 ip 10.5.255.254
  option 43 hex 0803.0000.0c80.0669.6f73.2e63.66
  dns-server <dns>
  lease 14

!DHCP для клиентов
ip dhcp pool pcs-c4
  network 10.19.0.0 255.255.0.0
  next-server 10.19.255.254
  default-router 10.19.255.254
  option 128 ip 10.19.255.254
  option 4 ip 10.19.255.254
  option 11 ip 10.19.255.254
  option 10 ip 10.19.255.254
  dns-server <dns>
  lease 14

interface Cable1/0
ip address 10.19.255.254 255.255.0.0 secondary
ip address 10.5.255.254 255.255.0.0
ip access-group acl_cable_in in
cable tftp-enforce
no cable packet-cache
cable sync-interval 5
cable downstream rate-limit
cable downstream annex A
cable downstream modulation 256qam
cable downstream frequency 378000000
cable downstream channel-id 0
no cable downstream rf-shutdown
cable downstream rf-power 49
cable upstream 0 spectrum-group 5
cable upstream 0 channel-width 3200000
cable upstream 0 minislot-size 2
cable upstream 0 power-level 25
cable upstream 0 power-adjust threshold 2
cable upstream 0 power-adjust continue 3
cable upstream 0 power-adjust noise 20
cable upstream 0 unfrag-slot-jitter limit 8000
cable upstream 0 differential-encoding
cable upstream 0 modulation-profile 1
cable upstream 0 admission-control 1000
cable upstream 0 equalization-coefficient
no cable upstream 0 shutdown
cable upstream 1 spectrum-group 2
cable upstream 1 channel-width 3200000
cable upstream 1 minislot-size 2
cable upstream 1 power-level 25
cable upstream 1 power-adjust threshold 2
cable upstream 1 power-adjust continue 3
cable upstream 1 power-adjust noise 20
cable upstream 1 unfrag-slot-jitter limit 8000
cable upstream 1 differential-encoding
cable upstream 1 modulation-profile 1
cable upstream 1 admission-control 1000
cable upstream 1 equalization-coefficient
no cable upstream 1 shutdown
cable upstream 2 spectrum-group 3
cable upstream 2 channel-width 3200000
cable upstream 2 minislot-size 2
cable upstream 2 power-level 25
cable upstream 2 power-adjust threshold 2
cable upstream 2 power-adjust continue 3
cable upstream 2 power-adjust noise 20
cable upstream 2 unfrag-slot-jitter limit 8000
cable upstream 2 differential-encoding
cable upstream 2 modulation-profile 1
cable upstream 2 admission-control 1000
cable upstream 2 equalization-coefficient
no cable upstream 2 shutdown
cable upstream 3 spectrum-group 4
cable upstream 3 channel-width 3200000
cable upstream 3 minislot-size 2
cable upstream 3 power-level 25
cable upstream 3 power-adjust threshold 2
cable upstream 3 power-adjust continue 3
cable upstream 3 power-adjust noise 20
cable upstream 3 unfrag-slot-jitter limit 8000
cable upstream 3 differential-encoding
cable upstream 3 modulation-profile 1
cable upstream 3 admission-control 1000
cable upstream 3 equalization-coefficient
no cable upstream 3 shutdown
cable arp filter request-send 3 2
cable arp filter reply-accept 3 2
no cable ip-multicast-echo
cable dhcp-giaddr policy
pppoe enable group global
no arp arpa
hold-queue 4096 in
hold-queue 4096 out

ip access-list extended acl_cable_in
permit ip 10.0.0.0 0.255.255.255 host 10.19.255.254
permit ip 10.0.0.0 0.255.255.255 host 10.5.255.254
permit ip 10.0.0.0 0.255.255.255 host <dns>
permit ip host 0.0.0.0 host 255.255.255.255
deny   ip any any

Share this post


Link to post
Share on other sites

Когда-то на sysadmins.ru я отвечал на такой вопрос. Можете посикать. Кратко суть в следующем: на модеме могут быть фильтра для snmp (задается комьюнити и откуда с этой комьюнити можно работать) и распространённая ошибка в том, что в последствии ip узла опрашивающего модемы может меняться, а вот в конфигах об этом никто не позаботился. Или же комьюнити не совпадает.

 

В вашем же случае, когда конфиг модема творит сама cmts, самым простым решением проблемы - самому опросить модем по snmp, снять с него всю информацию о фильтрах, и дальше думать.

 

P.S. На гуру DOCSIS'а не претендую, но есть ли особый философский смысл в том, чтобы отдавать на модем 2М в отдаче, тогда как дефолтный профайл модуляции от силы выжимает 3.5-4М на апстрим.

 

 

Edited by passer

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this