Jump to content
Калькуляторы

cisco и Shaping Нарезка канала

Всем здравствуйте!

Есть cisco 7201 к нему примерно будет подключено около 2к+ пользователей!

Router#sh ver
Cisco IOS Software, 7200 Software (C7200P-ADVIPSERVICESK9-M), Version 12.4(4)XD12, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Mon 04-May-09 11:33 by tinhuang

ROM: System Bootstrap, Version 12.4(12.2r)T, RELEASE SOFTWARE (fc1)
BOOTLDR: Cisco IOS Software, 7200 Software (C7200P-KBOOT-M), Version 12.4(15)T14, RELEASE SOFTWARE (fc2)

 

начал тут разбираться с этим шейпингом... мне не понравилось как он делит скорость! задумка была такая...

 

interface GigabitEthernet0/0
   traffic-shape group 101 512000 7936 7936 1000
   traffic-shape group 102 1000000 7936 7936 1000
   traffic-shape group 103 2000000 7936 7936 1000

ip nat inside source list 101 interface GigabitEthernet0/1 overload
ip nat inside source list 102 interface GigabitEthernet0/1 overload
ip nat inside source list 103 interface GigabitEthernet0/1 overload

access-list 101 remark ==========> Polzovateli 0.5 Mb/c
access-list 101 permit ip host 172.29.0.160 any
access-list 101 permit ip host 172.29.0.161 any
access-list 101 deny   ip any any

access-list 102 remark ==========> Polzovateli 1 Mb/c
access-list 102 permit ip host 172.29.0.163 any
access-list 102 permit ip host 172.29.0.164 any
access-list 102 deny   ip any any
…

 

думал сразу создать ACL для 3 групп пользователей по скоростям (512Мб, 1Мб, 2Мб), прописать сразу правила шейпинга для этих групп, прописать nat, и в последующем спомощью билинга и скриптов добовлять и убирать строки из ACL... но я наткнулся на подводный камень который сразу не увидел... не знал я что выдается 1 канал с размером Х на весь ACL вот теперь и ломаю над этим голову.... Подскажите как можно организовать данную задумку? Т.е. как правильно резать скорость для 3 групп пользователей чтобы у каждого пользователя была его личная скорость?

Edited by subal

Share this post


Link to post
Share on other sites

У вас все которые попадут в 512 разделят 1 полосу 512 и тп.

Кроме того надо в 2 стороны обычно шейпить....

Edited by dignity

Share this post


Link to post
Share on other sites
У вас все которые попадут в 512 разделят 1 полосу 512 и тп.

дак я о чем и говорю что одна полоса скажем таже 512 получается делится на всю группу.. это неправильно... вот я и прошу помощи как правильность организовать задуманное?

 

Кроме того надо в 2 стороны обычно шейпить....

в 2 стороны шейпить как я понимаю не получится... т.к. внешний всего 1 ip из-за чего нат и используется!

Edited by subal

Share this post


Link to post
Share on other sites

вот я и прошу помощи как правильность организовать задуманное?

1) PPPoE+Radius Attributes

2) Общий policy-map на интерфейс + на каждого абонента class-map+acl

 

в 2 стороны шейпить как я понимаю не получится... т.к. внешний всего 1 ip из-за чего нат и используется!

Ну так надо шейпить до ната серые адреса.

Share this post


Link to post
Share on other sites

ACL то тоже не резиновые тут придется в каждый ACL отделный ip прописывать... или что то путаю? можно пример реализации?

 

Router(config)#access-list ?
 <1-99>            IP standard access list
 <100-199>         IP extended access list
 <1100-1199>       Extended 48-bit MAC address access list
 <1300-1999>       IP standard access list (expanded range)
 <200-299>         Protocol type-code access list
 <2000-2699>       IP extended access list (expanded range)
 <700-799>         48-bit MAC address access list
 compiled          Enable IP access-list compilation
 dynamic-extended  Extend the dynamic ACL absolute timer
 rate-limit        Simple rate-limit specific access list

Share this post


Link to post
Share on other sites

ACL то тоже не резиновые тут придется в каждый ACL отделный ip прописывать... или что то путаю? можно пример реализации?

 

Router(config)#access-list ?
 <1-99>            IP standard access list
 <100-199>         IP extended access list
 <1100-1199>       Extended 48-bit MAC address access list
 <1300-1999>       IP standard access list (expanded range)
 <200-299>         Protocol type-code access list
 <2000-2699>       IP extended access list (expanded range)
 <700-799>         48-bit MAC address access list
 compiled          Enable IP access-list compilation
 dynamic-extended  Extend the dynamic ACL absolute timer
 rate-limit        Simple rate-limit specific access list

 

Ну во первых так:

cisco(config)#ip access-list standard ?

<1-99> Standard IP access-list number

<1300-1999> Standard IP access-list number (expanded range)

WORD Access-list name

 

Во вторых точное ограничение на кол-во acl не скажу, но да, подозреваю что оно не бесконечное.

 

Есть пример реализации для небольшого (<100 пользователей) кол-ва.

Share this post


Link to post
Share on other sites

melmaxnvk ну да насчет "WORD Access-list name" я согласен... но все таки как то некрасиво получается... :( 2к+ пользователь это в среднем... поидее если брать по максимуму то пользователей до 5к

 

ну разве нету другой возможности нарезки канала? а то как то глупо все получается...

Share this post


Link to post
Share on other sites

неужто в данном случае нужно ставит сервер перед Cisco с UNIX и на нем шейпить? зачем тогда нужна эта железка за 400т.р ?

Share this post


Link to post
Share on other sites

ну для Корпоративных клиентов она вполне хороша, вы учитывайте, что она все равно больше 1G дуплекса у вас вряд-ли прожует. Я не очень в теме касательно BRAS Cisco, но там вроде есть ISG и ей кошерно все делать)

http://wiki.sirmax.noname.com.ua/index.php/ISG#.D0.90.D0.BF.D0.BF.D0.B0.D1.80.D0.B0.D1.82.D0.BD.D0.B0.D1.8F_.D0.BF.D0.BB.D0.B0.D1.82.D1.84.D0.BE.D1.80.D0.BC.D0.B0

Edited by dignity

Share this post


Link to post
Share on other sites

как насчет isg + policing ? 7201 по части isg очень хорошо регулирует полосу per-subscriber ;)

Share this post


Link to post
Share on other sites

isg не разу не практиковал... сижу пытаюсь понять как это работает и как это реализовать... спс за подсказку по итогам отпишусь...

 

сижу изучаю:

http://wiki.sirmax.noname.com.ua/index.php/ISG#.D0.90.D0.BF.D0.BF.D0.B0.D1.80.D0.B0.D1.82.D0.BD.D0.B0.D1.8F_.D0.BF.D0.BB.D0.B0.D1.82.D1.84.D0.BE.D1.80.D0.BC.D0.B0

http://old.ciscoexpo.ru/moscow/2008/download/pdf/Cisco_ISG_segusaro.pdf

http://www.lanbilling.ru/cisco_radius.html

http://www.bog.pp.ru/work/ios_aaa.html

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this