Jump to content
Калькуляторы

Cisco 1760, не видит пиров нормально.

Всем привет.

Очень странно ведёт себя циска, купили Б.У. грешу на железо, но 100% уверенности нет. Странность в том что она не выбирает нормально пиры pots при входящих с SIP, т.е. отбивает по 1, если хистори в звонках глянуть. При этом тест в консоли показывает, что не найден пир для исхода в ISDN

 

Router# show dialplan number 1502565656

Macro Exp.: 1502565656

No match, result=-1

 

Хотя "щастье" есть в конфиге

 

Это вход воипа

! 
dial-peer voice 2 voip 
preference 3 
incoming called-number 1502......$ 
session protocol sipv2 
session target sip-server 
dtmf-relay rtp-nte 
codec g711alaw 
fax rate 9600 
fax nsf 000000 
fax protocol t38 ls-redundancy 5 hs-redundancy 2 fallback pass-through g711alaw 
no vad 
! 

 

А вот этот выходы потсовый, ни разу не видит

! 
dial-peer voice 6 pots 
voice cut-through alert 
translation-profile outgoing World 
preference 1 
destination-pattern 1502......$ 
progress_ind setup enable 3 
progress_ind progress enable 8 
no digit-strip 
direct-inward-dial 
port 0/0:15 
! 

 

Поток поднят

Router#show interface Serial0/0:15
Serial0/0:15 is up, line protocol is up (spoofing)
 Hardware is DSX1
 MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation HDLC, loopback not set
 Last input never, output 00:00:04, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    496256 packets output, 1488768 bytes, 0 underruns
    0 output errors, 0 collisions, 2 interface resets
    0 output buffer failures, 0 output buffers swapped out
    1 carrier transitions
 Timeslot(s) Used:16, SCC: 0, Transmitter delay is 0 flags

 

DSP присутствует, звоню по g.711alaw, точно ресов на один вызов хватить должно.

Router#show diag
Slot 0:
       C1760 1FE VE 4SLOT DV Mainboard Port adapter, 2 ports
       Port adapter is analyzed
       Port adapter insertion time unknown
       EEPROM contents at hardware discovery:
       Hardware Revision        : 2.0
       PCB Serial Number        : FOC07100SJ9
       Part Number              : 73-7167-02
       Board Revision           : C0
       Deviation Number         : 0-47975
       Fab Version              : 04
       Product (FRU) Number     : CISCO1760
       EEPROM format version 4
       EEPROM contents (hex):
         0x00: 04 FF 40 03 16 41 02 00 C1 8B 46 4F 43 30 37 31
         0x10: 30 30 53 4A 39 82 49 1B FF 02 42 43 30 80 00 00
         0x20: BB 67 02 04 FF FF FF FF FF FF FF FF FF FF FF FF
         0x30: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
         0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
         0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
         0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
         0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

       Packet Voice DSP Module Slot 0:
       Hardware Revision        : 3.2
       Part Number              : 73-3691-02
       Board Revision           : A0
       Deviation Number         : 0-0
       Fab Version              : 02
       PCB Serial Number        : VIC104700FV
       RMA Test History         : 00
       RMA Number               : 0-0-0-0
       RMA History              : 00
       Processor type           : 02
       Number of DSP's          : 3
       DSP memory size(in kwords): 192
       Type of DSP              : TMS320C549
       Product (FRU) Number     : PVDM-12=
       EEPROM format version 4
       EEPROM contents (hex):
       0x00:   04 FF 40 01 5C 41 03 02 82 49 0E 6B 02 42 41 30
       0x10:   80 00 00 00 00 02 02 C1 8B 56 49 43 31 30 34 37
       0x20:   30 30 46 56 03 00 81 00 00 00 00 04 00 09 02 FF

       Packet Voice DSP Module Slot 1:
       Hardware Revision        : 3.2
       Part Number              : 73-6731-01
       Board Revision           : A0
       Deviation Number         : 0-0
       Fab Version              : 03
       PCB Serial Number        : ICP072313X1
       RMA Test History         : 00
       RMA Number               : 0-0-0-0
       RMA History              : 00
       Processor type           : 02
       Number of DSP's          : 2
       DSP memory size(in kwords): 256
       Type of DSP              : TMS320C549
       Product (FRU) Number     : PVDM-256K-8=
       EEPROM format version 4
       EEPROM contents (hex):
       0x00:   04 FF 40 02 AD 41 03 02 82 49 1A 4B 01 42 41 30
       0x10:   80 00 00 00 00 02 03 C1 8B 49 43 50 30 37 32 33
       0x20:   31 33 58 31 03 00 81 00 00 00 00 04 00 09 02 FF

       WIC/VIC Slot 0:
       E1 (1 port) Multi-Flex Trunk WAN daughter card
       Hardware revision 1.0   Board revision B0
       Serial number     0032288794    Part number    800-04475-03
       FRU Part Number   WIC/VIC-E1=

       Test history      0x00          RMA number     00-00-00
       Connector type    PCI
       EEPROM format version 1
       EEPROM contents (hex):
       0x20:   01 21 01 00 01 EC B0 1A 50 11 7B 03 00 00 00 00
       0x30:   58 00 00 00 02 12 23 00 FF FF FF FF FF FF FF FF

 

Вот DSP.

Router#sh voice dsp

DSP  DSP             DSPWARE CURR  BOOT                         PAK     TX/RX
TYPE NUM CH CODEC    VERSION STATE STATE   RST AI VOICEPORT TS ABORT  PACK COUNT
==== === == ======== ======= ===== ======= === == ========= == ===== ============

Active Voice Call details


Current total analog signalling channels: 0
Current max allowed digital timeslot for voice: 30
Current number of DSP group: 1
Group 0:
Current allocated analog signalling channels: 0
Current free analog signalling channels: 0
Current allocated digital signalling channels: 30
Current free digital signalling channels: 0
Port(s) served: 0/0
Current Available MIPS: 500
SPMM  DSPRM  State   Image     D-sig  D-sig     A-sig  A-sig  Mips Voice/Xcode
 Dsp   Dsp                  allocate   free  allocate   free  Free     Chan
 0/0     0      UP   FLEX6         6      0         0      0   100        0
 0/1     1      UP   FLEX6         6      0         0      0   100        0
 0/2     2      UP   FLEX6         6      0         0      0   100        0
 1/0     3      UP   FLEX6         6      0         0      0   100        0
 1/1     4      UP   FLEX6         6      0         0      0   100        0

 

 

И конфиг в целом, выкладываю сразу, потому что ну должно работать всё.

 

Building configuration...

Current configuration : 5528 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 00000000000000000000000
!
tdm clock E1 0/0 both export line
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
voice-card 0
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
isdn switch-type primary-net5
!
!
voice hunt user-busy
voice call send-alert
voice call disc-pi-off
voice rtp send-recv
!
voice service pots
!
voice service voip
h323
sip
!
!
!
!
!
!
!
!
voice translation-rule 1
rule 1 /^1502/ //
!
!
voice translation-profile World
translate called 1
!
!
username cisco privilege 15 password 0 DkflWbcrf
!
!
controller E1 0/0
framing NO-CRC4
pri-group timeslots 1-31
!
!
!
interface FastEthernet0/0
ip address 192.168.111.200 255.255.255.0
speed auto
!
interface Serial0/0:15
no ip address
no logging event link-status
isdn switch-type primary-net5
isdn overlap-receiving
isdn not-end-to-end 64
isdn incoming-voice voice
isdn T309-enable
isdn T306 60000
isdn T310 60000
isdn send-alerting
isdn negotiate-bchan
isdn bchan-number-order descending round-robin
isdn sending-complete
no keepalive
no fair-queue
no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.111.1
no ip http server
!
no cdp run
!
voice-port 0/0:15
input gain -3
output attenuation -4
no non-linear
no vad
no comfort-noise
cptone RU
timeouts wait-release 3
bearer-cap 3100Hz
!
!
dial-peer cor custom
!
!
!
dial-peer voice 1 voip
huntstop
preference 3
incoming called-number .T
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711alaw
fax rate 9600
fax nsf 000000
fax protocol t38 ls-redundancy 5 hs-redundancy 2 fallback pass-through g711alaw
no vad
!
dial-peer voice 2 voip
preference 3
incoming called-number 1502......$
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711alaw
fax rate 9600
fax nsf 000000
fax protocol t38 ls-redundancy 5 hs-redundancy 2 fallback pass-through g711alaw
no vad
!
dial-peer voice 3 voip
huntstop
preference 3
incoming called-number 1502...$
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711alaw
fax rate 9600
fax protocol t38 ls-redundancy 5 hs-redundancy 2 fallback pass-through g711alaw
no vad
!
dial-peer voice 4 voip
huntstop
preference 3
incoming called-number 1502.....$
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711alaw
fax rate 9600
fax protocol t38 ls-redundancy 5 hs-redundancy 2 fallback pass-through g711alaw
no vad
!
dial-peer voice 5 pots
voice cut-through alert
translation-profile outgoing World
preference 3
destination-pattern 8.T
progress_ind setup enable 3
progress_ind progress enable 8
no digit-strip
port 0/0:15
!
dial-peer voice 6 pots
voice cut-through alert
translation-profile outgoing World
preference 1
destination-pattern 1502......$
progress_ind setup enable 3
progress_ind progress enable 8
no digit-strip
direct-inward-dial
port 0/0:15
!
dial-peer voice 7 pots
voice cut-through alert
translation-profile outgoing World
preference 3
destination-pattern 1502...$
progress_ind setup enable 3
progress_ind progress enable 8
no digit-strip
port 0/0:15
!
dial-peer voice 8 pots
voice cut-through alert
translation-profile outgoing World
preference 3
destination-pattern 1502.....$
progress_ind setup enable 3
progress_ind progress enable 8
no digit-strip
port 0/0:15
!
dial-peer voice 9 voip
tone ringback alert-no-PI
description client From City Calls
preference 2
destination-pattern 678.$
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711alaw
fax protocol t38 ls-redundancy 5 hs-redundancy 2 fallback pass-through g711alaw
no vad
!
dial-peer voice 10 voip
tone ringback alert-no-PI
description client From City Calls
preference 2
destination-pattern 920.$
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711alaw
fax protocol t38 ls-redundancy 5 hs-redundancy 2 fallback pass-through g711alaw
no vad
!
dial-peer voice 11 voip
tone ringback alert-no-PI
description client From City Calls
preference 2
destination-pattern 93..$
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711alaw
fax protocol t38 ls-redundancy 5 hs-redundancy 2 fallback pass-through g711alaw
no vad
!
dial-peer voice 12 voip
tone ringback alert-no-PI
description client From City Calls
preference 2
destination-pattern 91..$
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711alaw
fax protocol t38 ls-redundancy 5 hs-redundancy 2 fallback pass-through g711alaw
no vad
!
dial-peer voice 13 pots
tone ringback alert-no-PI
description From City Calls
preference 2
incoming called-number 678.$
no digit-strip
direct-inward-dial
!
dial-peer voice 14 pots
tone ringback alert-no-PI
description From City Calls
preference 2
incoming called-number 920.$
no digit-strip
direct-inward-dial
!
dial-peer voice 15 pots
tone ringback alert-no-PI
description From City Calls
preference 2
incoming called-number 91..$
no digit-strip
direct-inward-dial
!
sip-ua
set pstn-cause 19 sip-status 486
set pstn-cause 31 sip-status 480
sip-server ipv4:10.15.20.2:5060
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 60 0
login local
transport input telnet
line vty 5 15
login
transport input telnet
!
end

Share this post


Link to post
Share on other sites

Нет лога то, не идёт оно в pots, следовательно и в потоке 0.

2.debug isdn q931

лог в студию.:)

 

Router#show isdn status
Global ISDN Switchtype = primary-net5
ISDN Serial0/0:15 interface
       dsl 0, interface ISDN Switchtype = primary-net5
   Layer 1 Status:
       ACTIVE
   Layer 2 Status:
       TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
   Layer 3 Status:
       0 Active Layer 3 Call(s)
   Active dsl 0 CCBs = 0
   The Free Channel Mask:  0x7FFF7FFF
   Number of L2 Discards = 0, L2 Session ID = 178
   Total Allocated ISDN CCBs = 0

Share this post


Link to post
Share on other sites

dial-peer voice 1 voip

huntstop

preference 3

incoming called-number .T

Вот этот диалпир собирает все звонки.

 

dial-peer voice 2 voip

preference 3

incoming called-number 1502......$

Какой смысл в 3-х одинаковых войп диалпирах?

 

dial-peer voice 6 pots

voice cut-through alert

translation-profile outgoing World

preference 1

destination-pattern 1502......$

Да ещё в 3-х одинаковых потс диалпирах, с паттерном из войп диалпира?

 

voice translation-rule 1

rule 1 /^1502/ //

И вот это делается через "strip-digits 4"

 

dial-peer voice 9 voip

tone ringback alert-no-PI

description client From City Calls

preference 2

destination-pattern 678.$

Из города точно приходят 4-е цифры?

Share this post


Link to post
Share on other sites
dial-peer voice 1 voip

huntstop

preference 3

incoming called-number .T

 

Нет не собирает, сорри конечно за мусор, считайте его нет, хотел что бы собрало всё, для теста сделал, считайте его нет, поменял его на 8.T

 

Router#show dialplan number 1502565656

Macro Exp.: 1502565656

No match, result=-1

 

 

Какой смысл в 3-х одинаковых войп диалпирах?

В каких трёх одинаковых в этих 2,3,4 ? Пускай будут, для порядка в целом, что бы лишние цифры не пробегали. Pots соответственно для VOIP. Пускай может и не красиво, но работать должно.

 

 

И вот это делается через "strip-digits 4"

Знаю, мне удобней префикс резать, опять же на работу не влияет.

 

Из города точно приходят 4-е цифры?

Точно, приходят 4-е, и я написал у меня из SIP в ISDN не уходит, а не на оборот, из ISDN не проверял, мне туда ни чего не завернули. Так что пока исход тещю.

 

Из приколов циски входящая свзяь с ISDN тоже муть показывает

Router#show dialplan incall 0/0:15 number  9100
Matched port

VoiceEncapPeer5
       peer type = voice, information type = voice,
       description = `',
       tag = 5, destination-pattern = `8.T',
...........................................

Router#show running-config | begin dial-peer voice 5
dial-peer voice 5 pots
voice cut-through alert
translation-profile outgoing World
preference 3
destination-pattern 8.T
progress_ind setup enable 3
progress_ind progress enable 8
no digit-strip
port 0/0:15

 

Логика отсутствует напрочь.

Share this post


Link to post
Share on other sites

Как цыске отличить "1502......$" войп диалпира от тех же "1502......$" в потсовом диалпире?

 

Точно, приходят 4-е,

Что за город такой?

В России минимум 5 цифр, а из E1 обычно приходит нормализованный формат(11 цифр), да и уходить зачастую должно в нём же.

Share this post


Link to post
Share on other sites

Не в городе дело, а в АТС к которой будет прицеплено, я сам удивился.

 

Как цыске отличить "1502......$" войп диалпира от тех же "1502......$" в потсовом диалпире?

 

К сожелению вас не понял, на циске всегда два пира один VOIP, другой Pots, шаблоны должны совпадать, ну или трансляция в VOIP должна быть такая, что бы попало в pots. У меня все циски настроены подобно, выбираю префикс допустим 3333, потом делаю voip 3333......$, потом делаю pots который его отправит в нужный E1.

Такое делаю уже не первый год и примеры в тырнете всегда такие.

Share this post


Link to post
Share on other sites

Чё за гон!!!!!!!!!!!

Layer 2 Status:

TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

Этоже нет PRI.

 

Подымите логику PRI. И будет вам счастье. Дайте ещё командочку show controllers e1 :)

Share this post


Link to post
Share on other sites

У вас должно быть

cisco-1751#show controllers e1

E1 0/0 is up

Applique type is Channelized E1 - balanced

No alarms detected.

alarm-trigger is not set

Version info Firmware: 20070320, FPGA: 20, spm_count = 1

Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (689 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 24 hours)

0 Line Code Violations, 0 Path Code Violations,

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

 

 

cisco-1751#show isdn status

Global ISDN Switchtype = primary-net5

ISDN Serial0/0:15 interface

******* Network side configuration *******

dsl 0, interface ISDN Switchtype = primary-net5

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

Layer 3 Status:

Удачи!

Share this post


Link to post
Share on other sites

Спасибо за здравый совет, посмотрю... может и упустил.

Share this post


Link to post
Share on other sites

Вроде бы всё так

 

Router#show controllers e1
E1 0/0 is up.
 Applique type is Channelized E1 - balanced
 No alarms detected.
 alarm-trigger is not set
 Version info Firmware: 20050620, FPGA: 16, spm_count = 0
 Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.
 CRC Threshold is 320. Reported from firmware  is 320.
 Data in current interval (664 seconds elapsed):
    0 Line Code Violations, 0 Path Code Violations
    0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
    0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
 Total Data (last 24 hours)
    0 Line Code Violations, 0 Path Code Violations,
    0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
    0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

 

Router#show isdn status
Global ISDN Switchtype = primary-net5
ISDN Serial0/0:15 interface
       dsl 0, interface ISDN Switchtype = primary-net5
   Layer 1 Status:
       ACTIVE
   Layer 2 Status:
       TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
   Layer 3 Status:
       0 Active Layer 3 Call(s)
   Active dsl 0 CCBs = 0
   The Free Channel Mask:  0x7FFF7FFF
   Number of L2 Discards = 0, L2 Session ID = 137
   Total Allocated ISDN CCBs = 0

 

Теперь собсно вопрос, может так случиться, что на АТС поток подняли не PRI, а чёт другое, мне пришлось принять на верну, что всё ОК, была бы моя АТС, знал бы наверняка...

Share this post


Link to post
Share on other sites

Ну поток поднят номально. Теперь смотрите логику PRI. Метод енкапсуляции на АТС. Ну и вообще поднят ли там PRI.

 

Да ещё уточните - кто мастер а кто слейв в PRI!!!. Сейчас у Вас циска слейв.

Share this post


Link to post
Share on other sites

ну подымать можно всё что угодно PRI BRI CAS и т.д. Нужно чёткое согласование всех параметров с настройщиком АТС. Иначе это как оператор интернета притащил домой вам шнурок а настройки-ну сами догадайтесь.

Share this post


Link to post
Share on other sites

Сказал, сделай мне поток на АТС как для Cisco AS5350, которая уже подключена , по идеи, настройки вот такие подходили.

 

 

controller E1 2/0
framing NO-CRC4
pri-group timeslots 1-31
!
interface Serial2/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn overlap-receiving
isdn not-end-to-end 64
isdn incoming-voice modem
isdn map address ^8228.* plan isdn type subscriber
isdn T306 60000
isdn T310 60000
isdn send-alerting
isdn sending-complete
no cdp enable
!
voice-port 2/0:D
input gain 2
output attenuation -2
echo-cancel coverage 32
no non-linear
no vad
no comfort-noise
cptone RU
bearer-cap 3100Hz
!

Edited by E^X

Share this post


Link to post
Share on other sites

На всякий случай воткнул и user и network, результат идентичный

TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

Share this post


Link to post
Share on other sites

Ок, пну в понедельник, спасибо.

Share this post


Link to post
Share on other sites

К сожелению вас не понял, на циске всегда два пира один VOIP, другой Pots, шаблоны должны совпадать, ну или трансляция в VOIP должна быть такая, что бы попало в pots.

На кой ляд?

 

Исходя из префиксов "1502" и "8" конфиг должен выглядеть примерно так:

 

!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SIP-Сity-Gateway
!
boot-start-marker
boot-end-marker
!
enable password ****
!
memory-size iomem 15
tdm clock E1 0/0 both export line
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
voice-card 0
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ip bootp server
no ip domain lookup
no ftp-server write-enable
isdn switch-type primary-net5
!
!
!
voice service pots
supported-language ru
!
voice service voip
fax protocol pass-through g711alaw
sip
 header-passing
!
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g729r8
codec preference 3 g723r63
!
!
!
!
!
!
!
!
!
!
!
controller E1 0/0
pri-group timeslots 1-31
!
!
!
interface FastEthernet0/0
ip address 192.168.111.200 255.255.255.0
speed auto
full-duplex
no cdp enable
!
interface Serial0/0:15
no ip address
no logging event link-status
isdn switch-type primary-net5
isdn incoming-voice voice
isdn global-disconnect
isdn send-alerting
isdn sending-complete
isdn outgoing display-ie
isdn outgoing ie caller-number
isdn outgoing ie called-number
no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.111.1
!
no ip http server
!
no cdp run
!
control-plane
!
!
!
voice-port 0/0:15
no echo-cancel enable
no non-linear
no comfort-noise
cptone RU
bearer-cap 3100Hz
!
!
!
!
!
dial-peer voice 1 voip
tone ringback alert-no-PI
destination-pattern ....$
voice-class codec 1
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
fax protocol pass-through g711alaw
no vad
!
dial-peer voice 2 pots
tone ringback alert-no-PI
destination-pattern 8T
progress_ind setup enable 3
progress_ind progress enable 8
direct-inward-dial
port 0/0:15
!
dial-peer voice 3 pots
tone ringback alert-no-PI
destination-pattern 1502......$
digit-strip 4
progress_ind setup enable 3
progress_ind progress enable 8
direct-inward-dial
port 0/0:15
!
gateway
timer receive-rtp 1200
!
sip-ua
retry bye 2
retry cancel 2
retry register 10
timers register 150
sip-server ipv4:10.15.20.2:5060
!
!
telephony-service
max-conferences 4
!
!
line con 0
line aux 0
line vty 0 4
password ****
login
!
end

Share this post


Link to post
Share on other sites

Должен быть пир для принятия VOIP, иначе как я укажу личные настройки факса, кодека, трансляции номера допустим один общий pots на разные VOIP пиры с разными префиксами, такое пару раз нужно было, иначе всё уйдёт в peer по умолчанию и там глобальными настройками будет рулиться, что может оказаться не нужным для меня, если вам так приятно, то так и делайте, проблемы с потоком и мне прямо на это указали, проморгал сию сам. И буду уже с потоком разбираться.

Share this post


Link to post
Share on other sites

"Должен быть пир для принятия VOIP, иначе как я укажу личные настройки факса, кодека, трансляции номера"

 

Ну так если ты делаешь пир для исходящих в voip с destination-pattern ....$

То для однообразия конфига для входящих с voip будет правильно сделать пир с answer-address ....$

Share this post


Link to post
Share on other sites

"Должен быть пир для принятия VOIP, иначе как я укажу личные настройки факса, кодека, трансляции номера"

 

Ну так если ты делаешь пир для исходящих в voip с destination-pattern ....$

То для однообразия конфига для входящих с voip будет правильно сделать пир с answer-address ....$

 

Это может понадобиться только для асимметричного вызова. Например, в одну сторону G.729, а в другую G.711

Представляет чисто теоретический интерес и на практике не применяется.

Share this post


Link to post
Share on other sites

Поправил поток АТСник, всё забегало.

Дефолтными пирами пользоваться не буду, это сказать вопрос условно назовём "веры".

Share this post


Link to post
Share on other sites

У меня на цисках и терминация H323+729,723,711 и SIP+711, H323+711, SIP+729.

Так без входного пира VOIP грустно будет. И циска хуже не работает, всё согласно её видения телефонии.

Share this post


Link to post
Share on other sites

У меня на цисках и терминация H323+729,723,711 и SIP+711, H323+711, SIP+729.

С асимметрией?

 

Так без входного пира VOIP грустно будет.

Это чем же?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this